summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-19 19:08:09 +0100
committerSam James <sam@gentoo.org>2023-09-19 19:10:12 +0100
commita5f9b359fefdfbf7ad8a8de947b5f34a85fffee6 (patch)
treeb1dbedeedbf086cc1c1f073225840483d6597dd3
parentdev-libs/openssl: add 3.0.11 (diff)
downloadgentoo-a5f9b359fefdfbf7ad8a8de947b5f34a85fffee6.tar.gz
gentoo-a5f9b359fefdfbf7ad8a8de947b5f34a85fffee6.tar.bz2
gentoo-a5f9b359fefdfbf7ad8a8de947b5f34a85fffee6.zip
sys-apps/hwdata: add 0.374
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/hwdata/Manifest1
-rw-r--r--sys-apps/hwdata/hwdata-0.374.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/hwdata/Manifest b/sys-apps/hwdata/Manifest
index d268aa0ff19e..59ca225c73a7 100644
--- a/sys-apps/hwdata/Manifest
+++ b/sys-apps/hwdata/Manifest
@@ -1,3 +1,4 @@
DIST hwdata-0.371.tar.gz 2340297 BLAKE2B bb92b6d4f66879eacc1efae13ff1a5fe58014614c4af1906eca0489053f61d0ae2f4be777532cb6209cb2d133f8787774bc803a4d2cdf11a1014d7218bf25650 SHA512 62739cce61493f5d46a9cec5732bd4f9e0c86adec5b56cca31fa50c0d85e3a48d32f5abeaa5ca26f4ba42fc13affe4350b66a1838e958b037ddec7b30e726e86
DIST hwdata-0.372.tar.gz 2349386 BLAKE2B 0b3c8a7d23cd999090839d046ce6228098bb4976d0be56a07b6b32bdd968e11933b0d648cf4d596ed9ca09f5b754083c62bf0aba116835de6aed72f228cacf1b SHA512 3a7fda4c1f06dff62892dd0d21095d7603a2ec16e67667215b2f59640a38845a79b2dc2a19bcc40656fd472e4216393ac08e190939ec05ef6d4af3e7e6c9141f
DIST hwdata-0.373.tar.gz 2356072 BLAKE2B 22be63c94f1ba0fe5e31f1a19d8bf60a302bd6a2a7a15fbeaba0c3399490f86e067c5c84e1bbf5c4cc55a1ec588282d41c5ca9f3cf9e774ae559cac1b95d5812 SHA512 cb940a1cad1b7b6cef0e4bca980b0e6f0af06bf157069645645bb4403d98fbb26bbeef580c984b73091375db09e96c8b672b52d5cf27d75581ff8f0e935d8294
+DIST hwdata-0.374.tar.gz 2363130 BLAKE2B 696a0281307bb04f2aa9d946b97fdfffd918a3ee3ccc3479842779a4158e06733d128ca5feedf757fa15abb21bdc502cf3d81a775056aed17a95ddefade38df9 SHA512 c4dad796a170fb3b047ac4fe4a9fb32bc58858cdab7ca424d64e5ea00968af45d95af672a147faa2936436a904eae314b6143de2f75c0649ae9985dc4cad4301
diff --git a/sys-apps/hwdata/hwdata-0.374.ebuild b/sys-apps/hwdata/hwdata-0.374.ebuild
new file mode 100644
index 000000000000..afddd20d2fd1
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.374.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+
+ edo "${conf[@]}"
+}