summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-19 10:00:20 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-19 13:47:14 +0200
commita603a7c799137c6bfbf86be7b65dc339e42ad052 (patch)
tree793a5c4f180730a15a7dcf0142bee9e8a430ed5f
parentdev-python/bottleneck: Enable py3.13 (diff)
downloadgentoo-a603a7c799137c6bfbf86be7b65dc339e42ad052.tar.gz
gentoo-a603a7c799137c6bfbf86be7b65dc339e42ad052.tar.bz2
gentoo-a603a7c799137c6bfbf86be7b65dc339e42ad052.zip
dev-python/uncertainties: Fix tests with numpy-2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild b/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
index 5c1abc030534..09df84db552d 100644
--- a/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
+++ b/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,6 +31,10 @@ distutils_enable_sphinx doc --no-autodoc
src_prepare() {
# not used in py3, see https://github.com/lebigot/uncertainties/pull/168
sed -i -e '/future/d' setup.py || die
+ # fix tests with numpy-2
+ # https://github.com/lmfit/uncertainties/pull/225
+ sed -e "/assert not hasattr(numpy, 'acos')/d" \
+ -i uncertainties/unumpy/test_unumpy.py || die
distutils-r1_src_prepare
}