summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-23 02:24:15 +0000
committerSam James <sam@gentoo.org>2023-01-23 02:32:56 +0000
commita60d56a96360ed046267f3919467d0527ba9da99 (patch)
tree75e8b5a6426095a0ac2421e61fdfc4b1a3c93868
parentsys-block/spindown: EAPI 8, respect CXX, fix musl build (diff)
downloadgentoo-a60d56a96360ed046267f3919467d0527ba9da99.tar.gz
gentoo-a60d56a96360ed046267f3919467d0527ba9da99.tar.bz2
gentoo-a60d56a96360ed046267f3919467d0527ba9da99.zip
net-p2p/litecoind: fix build w/ gcc 12
Closes: https://bugs.gentoo.org/888605 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-p2p/litecoind/files/litecoind-0.18.1-gcc12.patch22
-rw-r--r--net-p2p/litecoind/litecoind-0.18.1-r1.ebuild7
2 files changed, 27 insertions, 2 deletions
diff --git a/net-p2p/litecoind/files/litecoind-0.18.1-gcc12.patch b/net-p2p/litecoind/files/litecoind-0.18.1-gcc12.patch
new file mode 100644
index 000000000000..12bc5c7b2b1d
--- /dev/null
+++ b/net-p2p/litecoind/files/litecoind-0.18.1-gcc12.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/888605
+--- a/src/bench/block_assemble.cpp
++++ b/src/bench/block_assemble.cpp
+@@ -22,6 +22,7 @@
+
+ #include <list>
+ #include <vector>
++#include <array>
+
+ static std::shared_ptr<CBlock> PrepareBlock(const CScript& coinbase_scriptPubKey)
+ {
+--- a/src/net_processing.cpp
++++ b/src/net_processing.cpp
+@@ -29,6 +29,7 @@
+ #include <util/system.h>
+ #include <util/moneystr.h>
+ #include <util/strencodings.h>
++#include <array>
+
+ #include <memory>
+
+
diff --git a/net-p2p/litecoind/litecoind-0.18.1-r1.ebuild b/net-p2p/litecoind/litecoind-0.18.1-r1.ebuild
index 7dd0e1ddb9f3..23dcc99ddf88 100644
--- a/net-p2p/litecoind/litecoind-0.18.1-r1.ebuild
+++ b/net-p2p/litecoind/litecoind-0.18.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,7 +33,10 @@ RDEPEND="
upnp? ( net-libs/miniupnpc:= )"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-system-leveldb.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-system-leveldb.patch
+ "${FILESDIR}"/${P}-gcc12.patch
+)
src_prepare() {
default