summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-03-19 19:17:10 -0400
committerMike Pagano <mpagano@gentoo.org>2023-03-19 19:17:10 -0400
commita61cae85086657418491fde39972638c1852fb10 (patch)
treef1d3154094b553a307cbe877f8f74d9b56a5ad08
parentnet-wireless/wireless-regdb: update Manifest (diff)
downloadgentoo-a61cae85.tar.gz
gentoo-a61cae85.tar.bz2
gentoo-a61cae85.zip
sys-kernel/git-sources: add 6.3_rc3
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.3_rc3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 151a069145c1..388e42c7e23a 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,3 +1,4 @@
DIST linux-6.2.tar.xz 136430892 BLAKE2B 05b63254734ea685db437cb1c00a6da63eee74d7e99f4ed2d074aaa01ac4487813ab297d337a6855cdbcbb33346b631c4256ee3b06191adfb1be3615a56bdd6d SHA512 a01bee0b968b95183934fe3504516be7ef5811944a061f5aed05ecebaa27b5eb64e33232fd0a8dd622b3c8743bfe462ef7e464d381734d111a0ad6a6d9f66ddd
DIST patch-6.3-rc1.patch 75751420 BLAKE2B 6e3cddb5397bea144a14b2b1efb1816841d81fa44030066a0196d97493121edfa451310dcb023d2feea45f17c43a8e3d1ecac63cf2a1b8c759c42bec5529d528 SHA512 f5f3240508ba1a0b5fef3a88ba781b7b76502eb242dbc670217f4c599d8394781d8fd8f05a24a831b25c18951e2a3278d1a89e99f2ef818d865c588371527e01
DIST patch-6.3-rc2.patch 77506749 BLAKE2B 827dfc8da94ee33d4c0ff93f9fc1595d87ef94e0fd4bf50c4d493f9e4762e7b5678385b5af07198e8b018ffa9dc64474899e818ba359b18ed6cf61aeaba48c86 SHA512 a1d4fa8346f71159bc767ba85ab6970d20fb5ca7e31a635b6a793c28a504f276c95dd7f5bb4f76eb20c781c7e25ac0c9ed3e2c6f449e3ea8da89b9868fc826ee
+DIST patch-6.3-rc3.patch 77958099 BLAKE2B 5e459202c7e77ec1cb977cd6e7d49b014e9ca0fdaef9edf69fe425e2326fd89efae0a278570834691b523a5c3d69276da5b391c6dea2f87fb17f3dd1b55190e9 SHA512 9ff7f62ba90d2e37f50398538ee25f03e520763f0a7bd41d5bc2187b7bcc9512aa52599786246660ab3daf465888c6e17ba0588c907c01810a4572e9afbad246
diff --git a/sys-kernel/git-sources/git-sources-6.3_rc3.ebuild b/sys-kernel/git-sources/git-sources-6.3_rc3.ebuild
new file mode 100644
index 000000000000..ae9a3401cdd2
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.3_rc3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.2"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}