summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-13 17:04:22 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-13 17:13:48 +0200
commita636c23ecb359fcf9a43999edc8769c6bc81a20a (patch)
treea5d636938e0e79f506fcdeb2290af702611f13b7
parentdev-util/watchman: add 2022.08.08.00 (diff)
downloadgentoo-a636c23e.tar.gz
gentoo-a636c23e.tar.bz2
gentoo-a636c23e.zip
app-shells/pwsh-bin: bump to 7.2.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-shells/pwsh-bin/Manifest3
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.2.6.ebuild51
2 files changed, 54 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index d7c918c97ca2..9c31602427aa 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -7,3 +7,6 @@ DIST powershell-7.2.4-linux-x64.tar.gz 69406638 BLAKE2B b7676de3c23417d92b754075
DIST powershell-7.2.5-linux-arm32.tar.gz 66201903 BLAKE2B cdf6b2f53b0392fdc9a4f2761dc13406be7b87e6814e926bb7838c64d27edb92839bca41e3e1993cc3316eaac21d025b57ebdbdd55a88c209b9b84946c36fe7d SHA512 5eff39888d9c375ff891371b8fd2ef8c9a2ff5917504c1569733767d2def33aa047836a54f4f15f6260adf46a05f4e8ae912ba2e86029c4a34cd47bb5085d9b4
DIST powershell-7.2.5-linux-arm64.tar.gz 64716033 BLAKE2B 06df8b25795f4df10c057acc8d001c46bcf4f5137e8d4a841216c172ffdb20d6ba3b31528f2f766a91ccbe1bc62f202ba78acef4a6af732a20035aac4a5ef9be SHA512 3ff38d1b109c0b9fdd8d20aa9ddd817424cf7883da7f4f16dcdb70c0f1260841ea6f61a3a675aabc471722920c8ba8f25a24885825cc7e29a9d5617876c070dd
DIST powershell-7.2.5-linux-x64.tar.gz 69364625 BLAKE2B 71a91e9d8196cca8a903fdeac1c8b4a7f6ad9c21d649fc5aeaf1cf3033cde3141219513b2a9661d36280c95746cfc0b4c47b3fe3cecff4f9feaffe60043c0743 SHA512 96efbcf4f325338bc9aa4da7b955366cc49bae89a98d5ad53840386aefed59e929b62d91d5bdbbe57e4bf471cd31c57e1fa5b4cd42f60b797bb438c165cf432e
+DIST powershell-7.2.6-linux-arm32.tar.gz 66272150 BLAKE2B 4a8f0f6595e23cfda9881c698be808714b4d543f963a932926f13a57c143b51ca9357befb1c151d86ea831ff17e54da6324fc1b11c0d1edf2b2c2ff4c086a8ad SHA512 a265d13a32050d9920e020fbd4cb2b183230a5a243b78773f6517fc2f82968009a8c559aae382b7b2d85ef0302d56bf46e01bebb1994c9495c2e5afc57330914
+DIST powershell-7.2.6-linux-arm64.tar.gz 64784215 BLAKE2B 2b792c1a4a2495e6cad0d0f545c55f89bcde933af3627f9f8ceb8d66f319ce7c4aca069167ebae79e12a2fe4e057ce970c64b0967684adecdbe6bae0de908dcb SHA512 5600f721503046bfabe0352bb406a3b528e7830e60286b25ab97a5c9729546a9ab4f1e2a5b33c4cde7b04ad713c9416fe55eb8b653f1f3bb87663a23d741ded4
+DIST powershell-7.2.6-linux-x64.tar.gz 69438809 BLAKE2B ae55f01e1fef540e0c0da317dfe00fb1dbcffd531697fdf8a95982499057d4c573aec45a8805aecc23152c09f735280ba6a546b819373e8259984e4aaf119c88 SHA512 b331f5a3d0457d8a212740e5034791d04275cce411ca88bd5ff59349f2a62147d20ecef30d6aeb7c399e870397ddfe4d68fe72f90c928ae66dbc00931072e782
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.2.6.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.2.6.ebuild
new file mode 100644
index 000000000000..c78be49848d4
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.2.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell - binary precompiled for glibc"
+HOMEPAGE="https://powershell.org/"
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+pwsh-symlink"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+ pwsh-symlink? ( !app-shells/pwsh )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local dest=opt/pwsh
+ dodir ${dest}
+
+ local broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ [[ -L ${symlink} ]] && { rm "${symlink}" || die ; }
+ done
+
+ mv "${S}/"* "${ED}"/${dest}/ || die
+ fperms 0755 /${dest}/pwsh
+
+ dosym ../../${dest}/pwsh /usr/bin/pwsh-bin
+ use pwsh-symlink && dosym ../../${dest}/pwsh /usr/bin/pwsh
+}