summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-02-26 16:23:31 +0100
committerPacho Ramos <pacho@gentoo.org>2023-02-26 16:51:32 +0100
commita645c864b8322a334317042707bd2b66ed0e8638 (patch)
treeb9ade49c62a638cfc75673c4aa547e769601ccd9
parentdev-python/pyocr: Use pypi.eclass (diff)
downloadgentoo-a645c864.tar.gz
gentoo-a645c864.tar.bz2
gentoo-a645c864.zip
net-misc/r8168: drop 8.050.03
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--net-misc/r8168/Manifest1
-rw-r--r--net-misc/r8168/files/r8168-8.050.02-5.18-fix.patch51
-rw-r--r--net-misc/r8168/files/r8168-8.050.03-5.19-fix.patch23
-rw-r--r--net-misc/r8168/r8168-8.050.03.ebuild41
4 files changed, 0 insertions, 116 deletions
diff --git a/net-misc/r8168/Manifest b/net-misc/r8168/Manifest
index 0770f6988b67..df4b080d77e0 100644
--- a/net-misc/r8168/Manifest
+++ b/net-misc/r8168/Manifest
@@ -1,2 +1 @@
-DIST r8168-8.050.03.tar.bz2 115525 BLAKE2B 9681417c5ded9d089259d80226a16789beaacf31902d896410d581927468c44486a4c496e45d9973851ccca2d4c408159064452849b03347c789390b2b23e57b SHA512 b4c0af2f4e6b9dc36f2db9e33f465d8598afa0b28577ea1f016617e853af00cf41886941fd8173a5b035e219d87a0fae28771230079c88f34039efe669c1e1c6
DIST r8168-8.051.02.tar.bz2 115969 BLAKE2B 28b809c0330920ee0db7a8f8d41e178882531cd0a6793efeadd9670b1a9b5cbe903061073fd1d461f4234feb41249a244f9ef35cdbb780da498e5a6d6f1a5490 SHA512 2f29a413e7db2b7295ea0a970b3385de1dfd6e41e1820097355687daa5c8d155c1cf6115c72875bff4f366365579bffc81733469a62d76f437065b7e514387ca
diff --git a/net-misc/r8168/files/r8168-8.050.02-5.18-fix.patch b/net-misc/r8168/files/r8168-8.050.02-5.18-fix.patch
deleted file mode 100644
index 442fa1c3eadf..000000000000
--- a/net-misc/r8168/files/r8168-8.050.02-5.18-fix.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-Functions like 'pci_dma_sync_single_for_device', 'pci_set_dma_mask', and 'pci_set_consistent_dma_mask'
-no longer exist in 5.18.0.
-Fix similar to https://www.mail-archive.com/linux-kernel@vger.kernel.org/msg2238850.html
-
---- a/src/r8168_n.c
-+++ b/src/r8168_n.c
-@@ -3698,7 +3698,11 @@
- txd->opts2 = 0;
- while (1) {
- memset(tmpAddr, pattern++, len - 14);
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5,18,0)
- pci_dma_sync_single_for_device(tp->pci_dev,
-+#else
-+ dma_sync_single_for_device(&tp->pci_dev->dev,
-+#endif
- le64_to_cpu(mapping),
- len, DMA_TO_DEVICE);
- txd->opts1 = cpu_to_le32(DescOwn | FirstFrag | LastFrag | len);
-@@ -3726,7 +3730,11 @@
- if (rx_len == len) {
- dma_sync_single_for_cpu(tp_to_dev(tp), le64_to_cpu(rxd->addr), tp->rx_buf_sz, DMA_FROM_DEVICE);
- i = memcmp(skb->data, rx_skb->data, rx_len);
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5,18,0)
- pci_dma_sync_single_for_device(tp->pci_dev, le64_to_cpu(rxd->addr), tp->rx_buf_sz, DMA_FROM_DEVICE);
-+#else
-+ dma_sync_single_for_device(&tp->pci_dev->dev, le64_to_cpu(rxd->addr), tp->rx_buf_sz, DMA_FROM_DEVICE);
-+#endif
- if (i == 0) {
- // dev_printk(KERN_INFO, tp_to_dev(tp), "loopback test finished\n",rx_len,len);
- break;
-@@ -26408,11 +26416,20 @@
-
- if ((sizeof(dma_addr_t) > 4) &&
- use_dac &&
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5,18,0)
- !pci_set_dma_mask(pdev, DMA_BIT_MASK(64)) &&
- !pci_set_consistent_dma_mask(pdev, DMA_BIT_MASK(64))) {
-+#else
-+ !dma_set_mask(&pdev->dev, DMA_BIT_MASK(64)) &&
-+ !dma_set_coherent_mask(&pdev->dev, DMA_BIT_MASK(64))) {
-+#endif
- dev->features |= NETIF_F_HIGHDMA;
- } else {
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5,18,0)
- rc = pci_set_dma_mask(pdev, DMA_BIT_MASK(32));
-+#else
-+ rc = dma_set_mask(&pdev->dev, DMA_BIT_MASK(32));
-+#endif
- if (rc < 0) {
- #if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,0)
- if (netif_msg_probe(tp))
diff --git a/net-misc/r8168/files/r8168-8.050.03-5.19-fix.patch b/net-misc/r8168/files/r8168-8.050.03-5.19-fix.patch
deleted file mode 100644
index d0f5d30ada06..000000000000
--- a/net-misc/r8168/files/r8168-8.050.03-5.19-fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Andrea Righi <andrea.righi@canonical.com>
-Subject: support linux 5.19
-
-Index: r8168-8.050.03/src/r8168_n.c
-===================================================================
---- r8168-8.050.03.orig/src/r8168_n.c
-+++ r8168-8.050.03/src/r8168_n.c
-@@ -116,6 +116,15 @@
- #define FIRMWARE_8168FP_3 "rtl_nic/rtl8168fp-3.fw"
- #define FIRMWARE_8168FP_4 "rtl_nic/rtl8168fp-4.fw"
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 18, 0)
-+static inline void netif_set_gso_max_size(struct net_device *dev,
-+ unsigned int size)
-+{
-+ /* dev->gso_max_size is read locklessly from sk_setup_caps() */
-+ WRITE_ONCE(dev->gso_max_size, size);
-+}
-+#endif
-+
- /* Maximum number of multicast addresses to filter (vs. Rx-all-multicast).
- The RTL chips use a 64 element hash table based on the Ethernet CRC. */
- static const int multicast_filter_limit = 32;
diff --git a/net-misc/r8168/r8168-8.050.03.ebuild b/net-misc/r8168/r8168-8.050.03.ebuild
deleted file mode 100644
index 6c2652606478..000000000000
--- a/net-misc/r8168/r8168-8.050.03.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-info linux-mod
-
-DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
-HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
-
-# "GBE Ethernet LINUX driver r8168 for kernel up to 5.17" from above link,
-# we need to mirror it to avoid users from needing to fill a captcha to
-# download
-SRC_URI="https://dev.gentoo.org/~pacho/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-MODULE_NAMES="r8168(net:${S}/src)"
-BUILD_TARGETS="modules"
-IUSE="use-firmware"
-
-CONFIG_CHECK="~!R8169"
-WARNING_R8169="CONFIG_R8169 is enabled. ${P} will not be loaded unless kernel driver Realtek 8169 PCI Gigabit Ethernet (CONFIG_R8169) is DISABLED."
-
-PATCHES=(
- "${FILESDIR}/r8168-8.050.02-5.18-fix.patch"
- "${FILESDIR}/r8168-8.050.03-5.19-fix.patch"
-)
-
-pkg_setup() {
- linux-mod_pkg_setup
- BUILD_PARAMS="KERNELDIR=${KV_DIR}"
- BUILD_PARAMS+=" ENABLE_USE_FIRMWARE_FILE=$(usex use-firmware y n)"
-}
-
-src_install() {
- linux-mod_src_install
- einstalldocs
-}