summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-01-27 02:03:19 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2018-02-07 12:12:19 +0000
commita64be65cfe9aec2718c18d16a8185d5a5f5114e2 (patch)
treee0f4ce1833ec575e9d051d8e235a1e634fc7030c
parentdev-libs/uriparser: 0.8.5 (diff)
downloadgentoo-a64be65c.tar.gz
gentoo-a64be65c.tar.bz2
gentoo-a64be65c.zip
dev-python/ruamel-std-pathlib: add new package
Dependency of dev-python/ruamel-yaml, which is a new dependency of app-misc/khard and will be added to the tree in a following commit. Based on work by Foster McLane <fkmclane@gmail.com> Bug: https://bugs.gentoo.org/644994 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/ruamel-std-pathlib/Manifest1
-rw-r--r--dev-python/ruamel-std-pathlib/metadata.xml16
-rw-r--r--dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild40
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/ruamel-std-pathlib/Manifest b/dev-python/ruamel-std-pathlib/Manifest
new file mode 100644
index 000000000000..4755eec233b9
--- /dev/null
+++ b/dev-python/ruamel-std-pathlib/Manifest
@@ -0,0 +1 @@
+DIST ruamel-std-pathlib-0.6.3.tar.gz 19520 BLAKE2B b403338cec80b38104f012c2b2626d473f12d557c2300d606462f2eb009bac72cec65b2f4e5a88192832a99dfc28573ea9ba8e7b73078ad8bac77136dd929040 SHA512 1210d8f7ae77c6358fc857c3ee447b2eb9802eaa31a210804acd74ec23dfd6ac9dec90dd7b21c79dcb4845dff4ad3614dd615c4798d3d7a39cc3a877cb9b63b0
diff --git a/dev-python/ruamel-std-pathlib/metadata.xml b/dev-python/ruamel-std-pathlib/metadata.xml
new file mode 100644
index 000000000000..8f2f19173a83
--- /dev/null
+++ b/dev-python/ruamel-std-pathlib/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fkmclane@gmail.com</email>
+ <name>Foster McLane</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>andrey_utkin@gentoo.org</email>
+ <name>Andrey Utkin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">ruamel/std.pathlib</remote-id>
+ <remote-id type="pypi">ruamel.std.pathlib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
new file mode 100644
index 000000000000..39663517d757
--- /dev/null
+++ b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Ruamel enhancements to pathlib and pathlib2"
+HOMEPAGE="https://pypi.python.org/pypi/ruamel.std.pathlib https://bitbucket.org/ruamel/std.pathlib"
+MY_PN="${PN//-/.}"
+SRC_URI="https://bitbucket.org/${MY_PN/.//}/get/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_4)
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ py.test -v _test/test_*.py || die
+}