summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-01 02:57:29 +0100
committerSam James <sam@gentoo.org>2021-04-01 22:17:02 +0100
commita6503185001adad02f1adea45f4f021f8c4ac452 (patch)
tree8189fa6bd9e050ec052ba0f898eae4808eb703e4
parentsys-kernel/gentoo-sources: amd64 stable (bug #778824) (diff)
downloadgentoo-a6503185.tar.gz
gentoo-a6503185.tar.bz2
gentoo-a6503185.zip
app-admin/yadm: use python-any-r1 API for tests
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-admin/yadm/yadm-2.4.0.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/app-admin/yadm/yadm-2.4.0.ebuild b/app-admin/yadm/yadm-2.4.0.ebuild
index 10da88e012a8..b056f1e5a96a 100644
--- a/app-admin/yadm/yadm-2.4.0.ebuild
+++ b/app-admin/yadm/yadm-2.4.0.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit bash-completion-r1
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit bash-completion-r1 python-any-r1
DESCRIPTION="A dotfile manager for the config files in your home folder"
HOMEPAGE="https://github.com/TheLocehiliosan/yadm/"
@@ -21,13 +22,23 @@ RDEPEND="
dev-vcs/git
"
-DEPEND="
- test? ( ${RDEPEND}
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ ${PYTHON_DEPS}
dev-python/pytest
dev-tcltk/expect
)
"
+python_check_deps() {
+ has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_compile() {
emake "${PN}.md"
}