summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-10 18:03:56 +0000
committerSam James <sam@gentoo.org>2022-05-10 19:36:00 +0000
commita67752097b07e8857a1041b13194a1659dfc4d43 (patch)
tree8cd0ca9969bc2b76127640daf817782dede1399e
parentnet-misc/sstp-client: add gitlab upstream metadata (diff)
downloadgentoo-a6775209.tar.gz
gentoo-a6775209.tar.bz2
gentoo-a6775209.zip
net-misc/sstp-client: add 1.0.17
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/sstp-client/Manifest1
-rw-r--r--net-misc/sstp-client/files/sstp-client-1.0.17-fix-bashism-configure.ac.patch23
-rw-r--r--net-misc/sstp-client/sstp-client-1.0.17.ebuild65
3 files changed, 89 insertions, 0 deletions
diff --git a/net-misc/sstp-client/Manifest b/net-misc/sstp-client/Manifest
index 5bbc71ccec93..a45ddcf16074 100644
--- a/net-misc/sstp-client/Manifest
+++ b/net-misc/sstp-client/Manifest
@@ -1 +1,2 @@
DIST sstp-client-1.0.12.tar.gz 468683 BLAKE2B 4bb97465ee29eb6dd816a69b45c53e58e9de2cd5d7b5c9e39ea4ebbb3c3de0c21b3d95317114ae8c93bc3be359300bd6a55fa0512540bf25405fb47f8fb4e736 SHA512 d29128e59977fa844b0f2b02580284bb4e909994e5616c4dfa150b7a9807d0f34219355abe8c315c60c5f2482e3255824ce7e05566dbea9a7f13a1739d46468f
+DIST sstp-client-1.0.17.tar.gz 482831 BLAKE2B d19c752b3f061401f89eb46bd52091e3ab0a3c931c6646a55c1ee0e6dd7e9c501fba14b7c870a2514cb72fb0fd1d8bc89538562d4d99b9d58a081e0917734f5d SHA512 eff18eb894b2c96d46315b5ac7530fe50e8dd6e6c29ea946cd0e7c05c56416e85088fc65650fb77c05e3a747cb0b4e3575af5457515d240161027910abae9775
diff --git a/net-misc/sstp-client/files/sstp-client-1.0.17-fix-bashism-configure.ac.patch b/net-misc/sstp-client/files/sstp-client-1.0.17-fix-bashism-configure.ac.patch
new file mode 100644
index 000000000000..a3a41fb206a9
--- /dev/null
+++ b/net-misc/sstp-client/files/sstp-client-1.0.17-fix-bashism-configure.ac.patch
@@ -0,0 +1,23 @@
+https://gitlab.com/eivnaes/sstp-client/-/merge_requests/2
+
+From 3cae209750549b17c547c3025859c0468cd5fcf6 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 10 May 2022 18:04:20 +0000
+Subject: [PATCH] configure.ac: fix bashism
+
+configure scripts are expected to work with POSIX compliant shells providing
+/bin/sh so use = instead of == to work with both Bash and other shells.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -129,7 +129,7 @@ PKG_CHECK_EXISTS([pppd],
+ AM_CONDITIONAL(WITH_PPP_PLUGIN, test "${enable_ppp_plugin}" = "yes")
+ AC_ARG_WITH([pppd-auth-notify-support],
+ AS_HELP_STRING([--with-pppd-auth-notify-support], [is the auth-notifier supported in this pppd version]))
+-AS_IF([test "x$with_pppd_auth_notify_support" == "xyes" ],
++AS_IF([test "x$with_pppd_auth_notify_support" = "xyes" ],
+ [AC_DEFINE(USE_PPPD_AUTH_HOOK,1,[Define if pppd has support for client side authentication complete notification])
+ PPPD_AUTH_NOTIFIER="yes"],
+ [PPPD_AUTH_NOTIFIER="no"])
+GitLab
diff --git a/net-misc/sstp-client/sstp-client-1.0.17.ebuild b/net-misc/sstp-client/sstp-client-1.0.17.ebuild
new file mode 100644
index 000000000000..57f15cf30687
--- /dev/null
+++ b/net-misc/sstp-client/sstp-client-1.0.17.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="A client implementation of Secure Socket Tunneling Protocol (SSTP)"
+HOMEPAGE="http://sstp-client.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sstp-client/${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="static"
+
+DEPEND="dev-libs/libevent:=
+ dev-libs/openssl:=
+ net-dialup/ppp:="
+RDEPEND="${DEPEND}
+ acct-group/sstpc
+ acct-user/sstpc"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~NETFILTER_NETLINK"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.12-remove-network-test.patch"
+ "${FILESDIR}/${PN}-1.0.12-fix-example.patch"
+
+ "${FILESDIR}/${PN}-1.0.17-fix-bashism-configure.ac.patch"
+)
+
+DOCS=( AUTHORS ChangeLog DEVELOPERS NEWS README TODO USING )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local PPPD_VER="$(best_version net-dialup/ppp)"
+ # Reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER#*/*-}
+ # Main version without beta/pre/patch/revision
+ PPPD_VER=${PPPD_VER%%[_-]*}
+
+ local myeconfargs=(
+ --enable-ppp-plugin
+ --enable-group=sstpc
+ --enable-user=sstpc
+ --with-pppd-plugin-dir="/usr/$(get_libdir)/pppd/${PPPD_VER}"
+ --with-runtime-dir="/run/sstpc"
+ $(use_enable static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}