summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-10 04:57:06 +0100
committerSam James <sam@gentoo.org>2023-08-10 04:57:06 +0100
commita685f699e19daaa572044c82858580af15465189 (patch)
tree26d45b99e8a7726b7aba745b23c595373529467f
parentdev-qt/qtwebengine: fix build w/ binutils-2.41 (diff)
downloadgentoo-a685f699e19daaa572044c82858580af15465189.tar.gz
gentoo-a685f699e19daaa572044c82858580af15465189.tar.bz2
gentoo-a685f699e19daaa572044c82858580af15465189.zip
media-video/ffmpeg-chromium: fix build w/ binutils-2.41
Closes: https://bugs.gentoo.org/911839 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-video/ffmpeg-chromium/ffmpeg-chromium-102.ebuild1
-rw-r--r--media-video/ffmpeg-chromium/ffmpeg-chromium-106.ebuild1
-rw-r--r--media-video/ffmpeg-chromium/ffmpeg-chromium-114.ebuild1
-rw-r--r--media-video/ffmpeg-chromium/files/ffmpeg-chromium-binutils-2.41.patch77
4 files changed, 80 insertions, 0 deletions
diff --git a/media-video/ffmpeg-chromium/ffmpeg-chromium-102.ebuild b/media-video/ffmpeg-chromium/ffmpeg-chromium-102.ebuild
index 5c5350f293b1..6e4409a5274b 100644
--- a/media-video/ffmpeg-chromium/ffmpeg-chromium-102.ebuild
+++ b/media-video/ffmpeg-chromium/ffmpeg-chromium-102.ebuild
@@ -116,6 +116,7 @@ S="${WORKDIR}"
PATCHES=(
"${FILESDIR}"/${PN}-100.patch
"${FILESDIR}"/${PN}-vk-headers.patch
+ "${FILESDIR}"/${PN}-binutils-2.41.patch
"${FILESDIR}"/chromium.patch
)
diff --git a/media-video/ffmpeg-chromium/ffmpeg-chromium-106.ebuild b/media-video/ffmpeg-chromium/ffmpeg-chromium-106.ebuild
index 39b454aa1a07..a25fa2fc9cdb 100644
--- a/media-video/ffmpeg-chromium/ffmpeg-chromium-106.ebuild
+++ b/media-video/ffmpeg-chromium/ffmpeg-chromium-106.ebuild
@@ -114,6 +114,7 @@ RESTRICT="
PATCHES=(
"${FILESDIR}"/${PN}-100.patch
"${FILESDIR}"/${PN}-vk-headers.patch
+ "${FILESDIR}"/${PN}-binutils-2.41.patch
"${FILESDIR}"/chromium.patch
)
diff --git a/media-video/ffmpeg-chromium/ffmpeg-chromium-114.ebuild b/media-video/ffmpeg-chromium/ffmpeg-chromium-114.ebuild
index a550da7245bf..da89ecc4a215 100644
--- a/media-video/ffmpeg-chromium/ffmpeg-chromium-114.ebuild
+++ b/media-video/ffmpeg-chromium/ffmpeg-chromium-114.ebuild
@@ -113,6 +113,7 @@ RESTRICT="
PATCHES=(
"${FILESDIR}"/${PN}-100.patch
+ "${FILESDIR}"/${PN}-binutils-2.41.patch
"${FILESDIR}"/chromium.patch
)
diff --git a/media-video/ffmpeg-chromium/files/ffmpeg-chromium-binutils-2.41.patch b/media-video/ffmpeg-chromium/files/ffmpeg-chromium-binutils-2.41.patch
new file mode 100644
index 000000000000..81d544625919
--- /dev/null
+++ b/media-video/ffmpeg-chromium/files/ffmpeg-chromium-binutils-2.41.patch
@@ -0,0 +1,77 @@
+https://bugs.gentoo.org/911582
+https://bugs.gentoo.org/911839
+https://trac.ffmpeg.org/ticket/10405
+https://git.videolan.org/?p=ffmpeg.git;a=commit;h=25cd95a9dc3510c3cc0d7aad6f9d83f6a1078c7e
+https://sourceware.org/PR30578
+https://gcc.gnu.org/PR108941
+
+From 25cd95a9dc3510c3cc0d7aad6f9d83f6a1078c7e Mon Sep 17 00:00:00 2001
+From: =?utf8?q?R=C3=A9mi=20Denis-Courmont?= <remi@remlab.net>
+Date: Sun, 16 Jul 2023 18:18:02 +0300
+Subject: [PATCH] avcodec/x86/mathops: clip constants used with shift
+ instructions within inline assembly
+
+Fixes assembling with binutil as >= 2.41
+
+Signed-off-by: James Almer <jamrial@gmail.com>
+(cherry picked from commit effadce6c756247ea8bae32dc13bb3e6f464f0eb)
+--- a/libavcodec/x86/mathops.h
++++ b/libavcodec/x86/mathops.h
+@@ -35,12 +35,20 @@
+ static av_always_inline av_const int MULL(int a, int b, unsigned shift)
+ {
+ int rt, dummy;
++ if (__builtin_constant_p(shift))
+ __asm__ (
+ "imull %3 \n\t"
+ "shrdl %4, %%edx, %%eax \n\t"
+ :"=a"(rt), "=d"(dummy)
+- :"a"(a), "rm"(b), "ci"((uint8_t)shift)
++ :"a"(a), "rm"(b), "i"(shift & 0x1F)
+ );
++ else
++ __asm__ (
++ "imull %3 \n\t"
++ "shrdl %4, %%edx, %%eax \n\t"
++ :"=a"(rt), "=d"(dummy)
++ :"a"(a), "rm"(b), "c"((uint8_t)shift)
++ );
+ return rt;
+ }
+
+@@ -113,19 +121,31 @@ __asm__ volatile(\
+ // avoid +32 for shift optimization (gcc should do that ...)
+ #define NEG_SSR32 NEG_SSR32
+ static inline int32_t NEG_SSR32( int32_t a, int8_t s){
++ if (__builtin_constant_p(s))
+ __asm__ ("sarl %1, %0\n\t"
+ : "+r" (a)
+- : "ic" ((uint8_t)(-s))
++ : "i" (-s & 0x1F)
+ );
++ else
++ __asm__ ("sarl %1, %0\n\t"
++ : "+r" (a)
++ : "c" ((uint8_t)(-s))
++ );
+ return a;
+ }
+
+ #define NEG_USR32 NEG_USR32
+ static inline uint32_t NEG_USR32(uint32_t a, int8_t s){
++ if (__builtin_constant_p(s))
+ __asm__ ("shrl %1, %0\n\t"
+ : "+r" (a)
+- : "ic" ((uint8_t)(-s))
++ : "i" (-s & 0x1F)
+ );
++ else
++ __asm__ ("shrl %1, %0\n\t"
++ : "+r" (a)
++ : "c" ((uint8_t)(-s))
++ );
+ return a;
+ }
+
+--
+2.30.2