summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-04-04 17:54:13 -0400
committerMike Pagano <mpagano@gentoo.org>2021-04-04 17:54:13 -0400
commita68d95155c0b7ac600528c951c0cf35f9a4c3c47 (patch)
tree288a5e9d43343dbb04b47d3608ea2048e16490d7
parentdev-java/commons-collections: 4.1 -> EAPI 7 bump. (diff)
downloadgentoo-a68d95155c0b7ac600528c951c0cf35f9a4c3c47.tar.gz
gentoo-a68d95155c0b7ac600528c951c0cf35f9a4c3c47.tar.bz2
gentoo-a68d95155c0b7ac600528c951c0cf35f9a4c3c47.zip
sys-kernel/git-sources: Linux patch 5.12-rc6
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.12_rc6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 20cd5b97e194..2ca2f9e9c7a4 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -3,3 +3,4 @@ DIST patch-5.12-rc2.patch 38085886 BLAKE2B 936f291c72b0befa6daf3f3070247e94a2e5a
DIST patch-5.12-rc3.patch 38689504 BLAKE2B 25962d05cfd031ea45347f339da8dd206c38ee16c78fd5ff39edb564474b11d4321e450904f9db491f62bb6002e338ef3136327d656c028eaae6f8a3b9207229 SHA512 585a883af66641247e3a44ca56788dc5afe5a2f3a8bd0d9aaabba0324cbbbd4dffdad0d9bc65e30f77903c870985bfbfe1a3283cc709b92417f89d2c94ab8f16
DIST patch-5.12-rc4.patch 38986964 BLAKE2B 1d1d105866e52607197dac9a2ccd9b47abd9ca132d465ebdd9cabf9f557e1648d69a0df843fac2d4c5af3e404b9c560ca154a177b303b90e96bbb5a46b822baa SHA512 51957643d3c49757652608a22093b2d5d2c802cb3449e529e55aa1a131ac27c8c8832cc0cc74ea93435191712e289c36f8edbe049541075b121406377ba5e3c7
DIST patch-5.12-rc5.patch 39323574 BLAKE2B ec3cf459048293b1dd4445fcdef14dd68733d9c70cd2206a069943459f48ee1929c96568c37abe4396eeca3c27e388931df89a0fc92e5c7a23de7d8d2a1729eb SHA512 cce82e4193de63f3ab87bd132baf6c63883aef91b31b8a96488c26206c35e22aecd0a5f4d6b562d98701fba0367e38f672d43015786cf480697aeaa6a43b5788
+DIST patch-5.12-rc6.patch 39417467 BLAKE2B b33e573e4c56dd9f4a5de81817c59898c16ee0c7890e0072fddfa17cf080ebd2e53e52ca1124bf4c6cc3b458a3f8b8851778b1de20ad955f68bf4749a6a125bb SHA512 d68adeaa37396043a76594da8219e35e8d20474ef1df7610f1409149d565d9718dad54fd86ec681814b954fe7f84e164c2a82eec151365d44ec53a263da4de57
diff --git a/sys-kernel/git-sources/git-sources-5.12_rc6.ebuild b/sys-kernel/git-sources/git-sources-5.12_rc6.ebuild
new file mode 100644
index 000000000000..841923d20fb6
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.12_rc6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.11"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}