summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-12 17:13:31 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-12 18:03:36 +0100
commita697724b10bc7c1ca73e12b63e146627d71bcbfd (patch)
treedc9cc215bbf9ec3408abf1231fa3908a11db839b
parentapp-containers/earthly: drop old 0.7.23 (diff)
downloadgentoo-a697724b10bc7c1ca73e12b63e146627d71bcbfd.tar.gz
gentoo-a697724b10bc7c1ca73e12b63e146627d71bcbfd.tar.bz2
gentoo-a697724b10bc7c1ca73e12b63e146627d71bcbfd.zip
app-containers/earthly: drop old 0.8.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.8.0.ebuild73
2 files changed, 0 insertions, 75 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index 7f14b051488a..dfde7814bec4 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -1,5 +1,3 @@
-DIST earthly-0.8.0-deps.tar.xz 158417236 BLAKE2B 998240c6065dd46eebc311975fa98e657a9568b6e26f0113d00e2f55b1cea8b017425fb6cafa7a7a5d7dd2ccdbaf711cee62b5a98d92322f9ff8a6458bb31a02 SHA512 1fd31f82acb7862a4deff611f088b73fd15e04a2bf56d91dff955ffb4c3c54425f6011b7a2bcf94fbb721ea820cc3728f8038870eb073c6d12d435406167dc8b
-DIST earthly-0.8.0.tar.gz 8029214 BLAKE2B 1ca0afa4e92a05fca47ada6a6b74d789fb9571b0e92cc7bbb0ccc88930a128db76382b3e5137073ebd82f74fb8d43b81f8e6d056a08e6fa73978f23b680b36e2 SHA512 661c1e15cf8943dfcd8d55c36191f4f9da6dc705bb894194ff0a31733038f7b74d2b187a066c6a6cc329a9a89f362299f1de3b370f273ce87e2e3cdd2b4c8163
DIST earthly-0.8.3-deps.tar.xz 158480860 BLAKE2B 4b875ef1ab7a244e2b92f13bc3dc55772c8e74af77b8a9814b2e964da4547a84fd7fe94ce96f77d4793a41039857e45ed133e61b8798d03c94d9546668dbaccd SHA512 e0071fbb9d5e85a81322c1e8fa36d393916031b99ca8783ab70c15084e5dd60cedbed24b9e7fe1e7c7b2e79c6b5f554b0518524b63b4c5e6d25aa99e56bec404
DIST earthly-0.8.3.tar.gz 8034636 BLAKE2B f61133eda18d81588d35a1b4916bdc72e3a037007d4872e093be035dc25f502a8947e2610af49f8339835cc2fd607ee2bc813ad19124625f0fa55aa3e183bed8 SHA512 a2880e0b1c8d2646b70ae21557f5e05f00b31667ae10fcd124d9519b1e9a75386b7f7be3867a2ac96b3381cefa6ea1ff560844df0ae098e7ae5acc11eaa93f97
DIST earthly-0.8.4-deps.tar.xz 158470344 BLAKE2B c3ec6369f8b397abd9b76dc77461c628e14ecc5866c8b66d094c3fe3194b18330be78454b57f211a717785210da40dc3c83e7d9769c62d621ca42a9d70f7be7f SHA512 d9b0960e02cf288b933a8da954e597957b2e8dc0920e2dca208a17d41c84bc1bcff789ee1c02fa930d5d0a816cb03437b091375168e0f46f3d3cf330a643b308
diff --git a/app-containers/earthly/earthly-0.8.0.ebuild b/app-containers/earthly/earthly-0.8.0.ebuild
deleted file mode 100644
index f36efb1e95ed..000000000000
--- a/app-containers/earthly/earthly-0.8.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
-if [[ "${PV}" == 0.8.0 ]] ; then
- COMMIT_SHA=c23e2735fdceeb3f17bae3746a05cbc8e98fafe3
-else
- die 'Could not detect "COMMIT_SHA", please update the ebuild.'
-fi
-
-inherit go-module
-
-DESCRIPTION="Build automation tool that executes in containers"
-HOMEPAGE="https://earthly.dev/
- https://github.com/earthly/earthly/"
-SRC_URI="
- https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
- https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
-"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="
- || (
- app-containers/docker
- app-containers/podman
- )
-"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-src_compile() {
- mkdir -p bin || die
-
- local go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
- local go_ldflags="
- -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
- -X main.GitSha=${COMMIT_SHA}
- -X main.Version=v${PV}
- "
- local -a go_buildargs=(
- -tags "${go_tags}"
- -ldflags "${go_ldflags}"
- -o bin
- )
- ego build "${go_buildargs[@]}" ./cmd/...
-}
-
-src_install() {
- exeinto /usr/bin
- doexe bin/earthly
- newexe bin/debugger earthly-debugger
-
- einstalldocs
-}
-
-pkg_postinst() {
- if has_version "app-containers/podman" ; then
- ewarn "Podman is supported but not recommended."
- ewarn "If issues arise, then please try running earthly with docker."
- fi
-
- if has_version "app-containers/podman[rootless]" ; then
- ewarn "Running podman in rootless mode is not supported because"
- ewarn "earthly/dind and earthly/buildkit require privileged access."
- ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
- fi
-}