summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-08-23 11:02:36 +0200
committerDavid Seifert <soap@gentoo.org>2023-08-23 11:02:36 +0200
commita69c6913657923c13ae97aecd45cc1e573fb43c8 (patch)
tree8f3f14e74563ccca105e8a8e69d4bdd13d55a125
parentRename {dev-libs → net-libs}/paho-mqtt-c (diff)
downloadgentoo-a69c6913.tar.gz
gentoo-a69c6913.tar.bz2
gentoo-a69c6913.zip
dev-util/nvidia-cuda-toolkit: drop 12.1.1-r1, 12.2.0
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-util/nvidia-cuda-toolkit/Manifest2
-rw-r--r--dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-12.1.1-r1.ebuild317
-rw-r--r--dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-12.2.0.ebuild317
3 files changed, 0 insertions, 636 deletions
diff --git a/dev-util/nvidia-cuda-toolkit/Manifest b/dev-util/nvidia-cuda-toolkit/Manifest
index cd9abe18ad83..b33486cc3b57 100644
--- a/dev-util/nvidia-cuda-toolkit/Manifest
+++ b/dev-util/nvidia-cuda-toolkit/Manifest
@@ -1,4 +1,2 @@
DIST cuda_11.8.0_520.61.05_linux.run 4336730777 BLAKE2B cfdb4a51c49ee504e56a4a95de4e477ef207b678527cbb633c1e83e667f1a62c0f67038befd0b10f7ae24cda9c8bc5c54293d06a05b2e45be6cf677e40f71f17 SHA512 e96e1389abed34b5093b3a1d4e6ae9f3d4f8406621b1475f378efae65868657efce22da03b5b4e0a548d9635e406b8690b18b17b186d03ecb3ca0703c5d5787a
-DIST cuda_12.1.1_530.30.02_linux.run 4317456991 BLAKE2B 562865cc63202906d0a5c2511387c3ded069c45576810b3076908730021125188017c96e88704b31f0401e29435f01dd87dfe33ca36fce8122683c27e1b928ea SHA512 2f5b07b6253a7268afa81345acc8be9fc3ab80f7f5c565d199f72ac74467d562eb83b72f87f33bafa90c88612b16366c3e209cbec1cb0b5907839e5823520323
-DIST cuda_12.2.0_535.54.03_linux.run 4315928767 BLAKE2B 99eb9e0fc81e65809cfcf7937f21ef0ec96c9f049cc988c936a5ee1e3d1f99131a97e1b71e3f4e38732cb309440d0fe96b933a0b9534874f790a31d27bd52809 SHA512 151827e0c1e9400597837c49dc07cf85bebb1c492306bf231b4a1ee00b48433f4ff3da24ed6235d70304fd6f5ee389bb43debbdf69958ef221deb7df0d7d7dae
DIST cuda_12.2.1_535.86.10_linux.run 4332490379 BLAKE2B 73686e68cffce2bee5b48f0a15abfec5adba52c7070a9f02190d4030fd4afd38de91157f617fa8e3f25e4be0524cb5668f3b1c82e24709966825a04a498265e9 SHA512 f6446dd1cbebffef1581cd72025b69007eb47083e8d340256e48d092c6dc539d062078ede9ad07d78f27df860db2250c1f5a1a494bd448aac138725564749ac3
diff --git a/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-12.1.1-r1.ebuild b/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-12.1.1-r1.ebuild
deleted file mode 100644
index 039bae19520e..000000000000
--- a/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-12.1.1-r1.ebuild
+++ /dev/null
@@ -1,317 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit check-reqs toolchain-funcs unpacker
-
-DRIVER_PV="530.30.02"
-
-DESCRIPTION="NVIDIA CUDA Toolkit (compiler and friends)"
-HOMEPAGE="https://developer.nvidia.com/cuda-zone"
-SRC_URI="https://developer.download.nvidia.com/compute/cuda/${PV}/local_installers/cuda_${PV}_${DRIVER_PV}_linux.run"
-S="${WORKDIR}"
-
-LICENSE="NVIDIA-CUDA"
-SLOT="0/${PV}"
-KEYWORDS="-* ~amd64 ~amd64-linux"
-IUSE="debugger examples nsight profiler rdma vis-profiler sanitizer"
-RESTRICT="bindist mirror"
-
-# since CUDA 11, the bundled toolkit driver (== ${DRIVER_PV}) and the
-# actual required minimum driver version are different.
-RDEPEND="
- <sys-devel/gcc-13_pre[cxx]
- >=x11-drivers/nvidia-drivers-525.60.13
- examples? (
- media-libs/freeglut
- media-libs/glu
- )
- nsight? (
- dev-libs/libpfm
- dev-libs/wayland
- dev-qt/qtwayland:6
- || (
- dev-libs/openssl-compat:1.1.1
- dev-libs/openssl:0/1.1
- )
- media-libs/tiff-compat:4
- sys-libs/zlib
- )
- rdma? ( sys-cluster/rdma-core )
- vis-profiler? (
- >=virtual/jre-1.8:*
- )"
-BDEPEND="nsight? ( dev-util/patchelf )"
-
-QA_PREBUILT="opt/cuda/*"
-CHECKREQS_DISK_BUILD="15000M"
-
-pkg_setup() {
- check-reqs_pkg_setup
-}
-
-src_prepare() {
- # ATTENTION: change requires revbump, see link below for supported GCC # versions
- # https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#system-requirements
- local cuda_supported_gcc="8.5 9.5 10 11 12"
-
- sed \
- -e "s:CUDA_SUPPORTED_GCC:${cuda_supported_gcc}:g" \
- "${FILESDIR}"/cuda-config.in > "${T}"/cuda-config || die
-
- default
-}
-
-src_install() {
- local cudadir=/opt/cuda
- local ecudadir="${EPREFIX}${cudadir}"
- local pathextradirs ldpathextradirs
- dodir ${cudadir}
- into ${cudadir}
-
- # Install standard sub packages
- local builddirs=(
- builds/cuda_{cccl,cudart,cuobjdump,cuxxfilt,demo_suite,nvcc,nvdisasm,nvml_dev,nvprune,nvrtc,nvtx,opencl}
- builds/lib{cublas,cufft,cufile,curand,cusolver,cusparse,npp,nvjitlink,nvjpeg}
- builds/nvidia_fs
- $(usex profiler "builds/cuda_nvprof builds/cuda_cupti builds/cuda_profiler_api" "")
- $(usex vis-profiler "builds/cuda_nvvp" "")
- $(usex debugger "builds/cuda_gdb" "")
- )
-
- local d f
- for d in "${builddirs[@]}"; do
- ebegin "Installing ${d}"
- [[ -d ${d} ]] || die "Directory does not exist: ${d}"
-
- if [[ -d ${d}/bin ]]; then
- for f in ${d}/bin/*; do
- if [[ -f ${f} ]]; then
- dobin "${f}"
- else
- insinto ${cudadir}/bin
- doins -r "${f}"
- fi
- done
- fi
-
- insinto ${cudadir}
- if [[ -d ${d}/targets ]]; then
- doins -r "${d}"/targets
- fi
- if [[ -d ${d}/share ]]; then
- doins -r "${d}"/share
- fi
- if [[ -d ${d}/extras ]]; then
- doins -r "${d}"/extras
- fi
- eend $?
- done
- dobin "${T}"/cuda-config
-
- doins builds/EULA.txt
- # nvml and nvvm need special handling
- ebegin "Installing nvvm"
- doins -r builds/cuda_nvcc/nvvm
- fperms +x ${cudadir}/nvvm/bin/cicc
- eend $?
-
- ebegin "Installing nvml"
- doins -r builds/cuda_nvml_dev/nvml
- eend $?
-
- if use sanitizer; then
- ebegin "Installing sanitizer"
- dobin builds/integration/Sanitizer/compute-sanitizer
- doins -r builds/cuda_sanitizer_api/compute-sanitizer
- # special handling for the executable
- fperms +x ${cudadir}/compute-sanitizer/compute-sanitizer
- eend $?
- fi
-
- use debugger && ldpathextradirs+=":${ecudadir}/extras/Debugger/lib64"
- use profiler && ldpathextradirs+=":${ecudadir}/extras/CUPTI/lib64"
-
- if use vis-profiler; then
- ebegin "Installing libnvvp"
- doins -r builds/cuda_nvvp/libnvvp
- # special handling for the executable
- fperms +x ${cudadir}/libnvvp/nvvp
- eend $?
- pathextradirs+=":${ecudadir}/libnvvp"
- fi
-
- if use nsight; then
- local ncu_dir=$(grep -o 'nsight-compute-[0-9][0-9\.]*' -m1 manifests/cuda_x86_64.xml)
- ebegin "Installing ${ncu_dir}"
- mv builds/nsight_compute builds/${ncu_dir} || die
- doins -r builds/${ncu_dir}
-
- # check this list on every bump
- local exes=(
- ${ncu_dir}/ncu
- ${ncu_dir}/ncu-ui
- ${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/libexec/QtWebEngineProcess
- ${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/CrashReporter
- ${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/OpenGLVersionChecker
- ${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/QdstrmImporter
- ${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/ncu-ui
- ${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/ncu-ui.bin
- ${ncu_dir}/target/linux-desktop-glibc_2_11_3-x64/TreeLauncherSubreaper
- ${ncu_dir}/target/linux-desktop-glibc_2_11_3-x64/TreeLauncherTargetLdPreloadHelper
- ${ncu_dir}/target/linux-desktop-glibc_2_11_3-x64/ncu
- )
-
- dobin builds/integration/nsight-compute/{ncu,ncu-ui}
- eend $?
-
- # remove rdma libs (unless USE=rdma)
- if ! use rdma; then
- rm -r "${ED}"/${cudadir}/${ncu_dir}/host/target-linux-x64/CollectX || die
- fi
-
- local nsys_dir=$(grep -o 'nsight-systems-[0-9][0-9\.]*' -m1 manifests/cuda_x86_64.xml)
- ebegin "Installing ${nsys_dir}"
- mv builds/nsight_systems builds/${nsys_dir} || die
- doins -r builds/${nsys_dir}
-
- # check this list on every bump
- exes+=(
- ${nsys_dir}/host-linux-x64/nsys-ui
- ${nsys_dir}/host-linux-x64/nsys-ui.bin
- ${nsys_dir}/host-linux-x64/ResolveSymbols
- ${nsys_dir}/host-linux-x64/ImportNvtxt
- ${nsys_dir}/host-linux-x64/CrashReporter
- ${nsys_dir}/host-linux-x64/QdstrmImporter
- ${nsys_dir}/host-linux-x64/libexec/QtWebEngineProcess
- ${nsys_dir}/target-linux-x64/nsys
- ${nsys_dir}/target-linux-x64/launcher
- ${nsys_dir}/target-linux-x64/nvgpucs
- ${nsys_dir}/target-linux-x64/nsys-launcher
- ${nsys_dir}/target-linux-x64/sqlite3
- ${nsys_dir}/target-linux-x64/python/bin/python
- )
-
- # remove rdma libs (unless USE=rdma)
- if ! use rdma; then
- rm -r "${ED}"/${cudadir}/${nsys_dir}/target-linux-x64/CollectX || die
- fi
-
- dobin builds/integration/nsight-systems/{nsight-sys,nsys,nsys-exporter,nsys-ui}
- eend $?
-
- # nsight scripts and binaries need to have their executable bit set, #691284
- for f in "${exes[@]}"; do
- fperms +x ${cudadir}/${f}
- done
-
- # fix broken RPATHs
- patchelf --set-rpath '$ORIGIN' "${ED}"/${cudadir}/${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/libarrow.so || die
- patchelf --set-rpath '$ORIGIN' "${ED}"/${cudadir}/${nsys_dir}/host-linux-x64/libarrow.so || die
-
- # remove foreign archs (triggers SONAME warning, #749903)
- rm -r "${ED}"/${cudadir}/${ncu_dir}/target/linux-desktop-glibc_2_19_0-ppc64le || die
- rm -r "${ED}"/${cudadir}/${ncu_dir}/target/linux-desktop-t210-a64 || die
-
- # unbundle libstdc++
- rm "${ED}"/${cudadir}/${nsys_dir}/host-linux-x64/libstdc++.so.6 || die
-
- # unbundle openssl
- rm "${ED}"/${cudadir}/${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/lib{crypto,ssl}.so* || die
- rm "${ED}"/${cudadir}/${nsys_dir}/host-linux-x64/lib{crypto,ssl}.so* || die
-
- # unbundle libpfm
- rm "${ED}"/${cudadir}/${nsys_dir}/host-linux-x64/libpfm.so* || die
-
- # TODO: unbundle qt5
- # TODO: unbundle boost
- # TODO: unbundle icu
- # TODO: unbundle mesa
- # TODO: unbundle libSshClient
- # TODO: unbundle sqlite
- fi
-
- if use examples; then
- local exes=(
- extras/demo_suite/bandwidthTest
- extras/demo_suite/busGrind
- extras/demo_suite/deviceQuery
- extras/demo_suite/nbody
- extras/demo_suite/oceanFFT
- extras/demo_suite/randomFog
- extras/demo_suite/vectorAdd
- )
-
- # set executable bit on demo_suite binaries
- for f in "${exes[@]}"; do
- fperms +x ${cudadir}/${f}
- done
- else
- rm -r "${ED}"/${cudadir}/extras/demo_suite || die
- fi
-
- # remove rdma libs (unless USE=rdma)
- if ! use rdma; then
- rm "${ED}"/${cudadir}/targets/x86_64-linux/lib/libcufile_rdma* || die
- fi
-
- # Add include and lib symlinks
- dosym targets/x86_64-linux/include ${cudadir}/include
- dosym targets/x86_64-linux/lib ${cudadir}/lib64
-
- # Remove bad symlinks
- rm "${ED}"/${cudadir}/targets/x86_64-linux/include/include || die
- rm "${ED}"/${cudadir}/targets/x86_64-linux/lib/lib64 || die
-
- newenvd - 99cuda <<-EOF
- PATH=${ecudadir}/bin${pathextradirs}
- ROOTPATH=${ecudadir}/bin
- LDPATH=${ecudadir}/lib64:${ecudadir}/nvvm/lib64${ldpathextradirs}
- EOF
-
- # Cuda prepackages libraries, don't revdep-build on them
- insinto /etc/revdep-rebuild
- newins - 80${PN} <<-EOF
- SEARCH_DIRS_MASK="${ecudadir}"
- EOF
-}
-
-pkg_postinst_check() {
- local a="$("${EROOT}"/opt/cuda/bin/cuda-config -s)"
- local b="0.0"
- local v
- for v in ${a}; do
- ver_test "${v}" -gt "${b}" && b="${v}"
- done
-
- # if gcc and if not gcc-version is at least greatest supported
- if tc-is-gcc && \
- ver_test $(gcc-version) -gt "${b}"; then
- ewarn
- ewarn "gcc > ${b} will not work with CUDA"
- ewarn "Make sure you set an earlier version of gcc with gcc-config"
- ewarn "or append --compiler-bindir= pointing to a gcc bindir like"
- ewarn "--compiler-bindir=${EPREFIX}/usr/*pc-linux-gnu/gcc-bin/gcc${b}"
- ewarn "to the nvcc compiler flags"
- ewarn
- fi
-}
-
-pkg_postinst() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- pkg_postinst_check
- fi
-
- if use profiler || use nsight; then
- einfo
- einfo "nvidia-drivers restrict access to performance counters."
- einfo "You'll need to either run profiling tools (nvprof, nsight) "
- einfo "using sudo (needs cap SYS_ADMIN) or add the following line to "
- einfo "a modprobe configuration file "
- einfo "(e.g. /etc/modprobe.d/nvidia-prof.conf): "
- einfo
- einfo "options nvidia NVreg_RestrictProfilingToAdminUsers=0"
- einfo
- fi
-}
diff --git a/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-12.2.0.ebuild b/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-12.2.0.ebuild
deleted file mode 100644
index f1281e52c3d6..000000000000
--- a/dev-util/nvidia-cuda-toolkit/nvidia-cuda-toolkit-12.2.0.ebuild
+++ /dev/null
@@ -1,317 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit check-reqs toolchain-funcs unpacker
-
-DRIVER_PV="535.54.03"
-
-DESCRIPTION="NVIDIA CUDA Toolkit (compiler and friends)"
-HOMEPAGE="https://developer.nvidia.com/cuda-zone"
-SRC_URI="https://developer.download.nvidia.com/compute/cuda/${PV}/local_installers/cuda_${PV}_${DRIVER_PV}_linux.run"
-S="${WORKDIR}"
-
-LICENSE="NVIDIA-CUDA"
-SLOT="0/${PV}"
-KEYWORDS="-* ~amd64 ~amd64-linux"
-IUSE="debugger examples nsight profiler rdma vis-profiler sanitizer"
-RESTRICT="bindist mirror"
-
-# since CUDA 11, the bundled toolkit driver (== ${DRIVER_PV}) and the
-# actual required minimum driver version are different.
-RDEPEND="
- <sys-devel/gcc-13_pre[cxx]
- >=x11-drivers/nvidia-drivers-525.60.13
- examples? (
- media-libs/freeglut
- media-libs/glu
- )
- nsight? (
- dev-libs/libpfm
- dev-libs/wayland
- dev-qt/qtwayland:6
- || (
- dev-libs/openssl-compat:1.1.1
- dev-libs/openssl:0/1.1
- )
- media-libs/tiff-compat:4
- sys-libs/zlib
- )
- rdma? ( sys-cluster/rdma-core )
- vis-profiler? (
- >=virtual/jre-1.8:*
- )"
-BDEPEND="nsight? ( dev-util/patchelf )"
-
-QA_PREBUILT="opt/cuda/*"
-CHECKREQS_DISK_BUILD="15000M"
-
-pkg_setup() {
- check-reqs_pkg_setup
-}
-
-src_prepare() {
- # ATTENTION: change requires revbump, see link below for supported GCC # versions
- # https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#system-requirements
- local cuda_supported_gcc="8.5 9.5 10 11 12"
-
- sed \
- -e "s:CUDA_SUPPORTED_GCC:${cuda_supported_gcc}:g" \
- "${FILESDIR}"/cuda-config.in > "${T}"/cuda-config || die
-
- default
-}
-
-src_install() {
- local cudadir=/opt/cuda
- local ecudadir="${EPREFIX}${cudadir}"
- local pathextradirs ldpathextradirs
- dodir ${cudadir}
- into ${cudadir}
-
- # Install standard sub packages
- local builddirs=(
- builds/cuda_{cccl,cudart,cuobjdump,cuxxfilt,demo_suite,nvcc,nvdisasm,nvml_dev,nvprune,nvrtc,nvtx,opencl}
- builds/lib{cublas,cufft,cufile,curand,cusolver,cusparse,npp,nvjitlink,nvjpeg}
- builds/nvidia_fs
- $(usex profiler "builds/cuda_nvprof builds/cuda_cupti builds/cuda_profiler_api" "")
- $(usex vis-profiler "builds/cuda_nvvp" "")
- $(usex debugger "builds/cuda_gdb" "")
- )
-
- local d f
- for d in "${builddirs[@]}"; do
- ebegin "Installing ${d}"
- [[ -d ${d} ]] || die "Directory does not exist: ${d}"
-
- if [[ -d ${d}/bin ]]; then
- for f in ${d}/bin/*; do
- if [[ -f ${f} ]]; then
- dobin "${f}"
- else
- insinto ${cudadir}/bin
- doins -r "${f}"
- fi
- done
- fi
-
- insinto ${cudadir}
- if [[ -d ${d}/targets ]]; then
- doins -r "${d}"/targets
- fi
- if [[ -d ${d}/share ]]; then
- doins -r "${d}"/share
- fi
- if [[ -d ${d}/extras ]]; then
- doins -r "${d}"/extras
- fi
- eend $?
- done
- dobin "${T}"/cuda-config
-
- doins builds/EULA.txt
- # nvml and nvvm need special handling
- ebegin "Installing nvvm"
- doins -r builds/cuda_nvcc/nvvm
- fperms +x ${cudadir}/nvvm/bin/cicc
- eend $?
-
- ebegin "Installing nvml"
- doins -r builds/cuda_nvml_dev/nvml
- eend $?
-
- if use sanitizer; then
- ebegin "Installing sanitizer"
- dobin builds/integration/Sanitizer/compute-sanitizer
- doins -r builds/cuda_sanitizer_api/compute-sanitizer
- # special handling for the executable
- fperms +x ${cudadir}/compute-sanitizer/compute-sanitizer
- eend $?
- fi
-
- use debugger && ldpathextradirs+=":${ecudadir}/extras/Debugger/lib64"
- use profiler && ldpathextradirs+=":${ecudadir}/extras/CUPTI/lib64"
-
- if use vis-profiler; then
- ebegin "Installing libnvvp"
- doins -r builds/cuda_nvvp/libnvvp
- # special handling for the executable
- fperms +x ${cudadir}/libnvvp/nvvp
- eend $?
- pathextradirs+=":${ecudadir}/libnvvp"
- fi
-
- if use nsight; then
- local ncu_dir=$(grep -o 'nsight-compute-[0-9][0-9\.]*' -m1 manifests/cuda_x86_64.xml)
- ebegin "Installing ${ncu_dir}"
- mv builds/nsight_compute builds/${ncu_dir} || die
- doins -r builds/${ncu_dir}
-
- # check this list on every bump
- local exes=(
- ${ncu_dir}/ncu
- ${ncu_dir}/ncu-ui
- ${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/libexec/QtWebEngineProcess
- ${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/CrashReporter
- ${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/OpenGLVersionChecker
- ${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/QdstrmImporter
- ${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/ncu-ui
- ${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/ncu-ui.bin
- ${ncu_dir}/target/linux-desktop-glibc_2_11_3-x64/TreeLauncherSubreaper
- ${ncu_dir}/target/linux-desktop-glibc_2_11_3-x64/TreeLauncherTargetLdPreloadHelper
- ${ncu_dir}/target/linux-desktop-glibc_2_11_3-x64/ncu
- )
-
- dobin builds/integration/nsight-compute/{ncu,ncu-ui}
- eend $?
-
- # remove rdma libs (unless USE=rdma)
- if ! use rdma; then
- rm -r "${ED}"/${cudadir}/${ncu_dir}/host/target-linux-x64/CollectX || die
- fi
-
- local nsys_dir=$(grep -o 'nsight-systems-[0-9][0-9\.]*' -m1 manifests/cuda_x86_64.xml)
- ebegin "Installing ${nsys_dir}"
- mv builds/nsight_systems builds/${nsys_dir} || die
- doins -r builds/${nsys_dir}
-
- # check this list on every bump
- exes+=(
- ${nsys_dir}/host-linux-x64/nsys-ui
- ${nsys_dir}/host-linux-x64/nsys-ui.bin
- ${nsys_dir}/host-linux-x64/ResolveSymbols
- ${nsys_dir}/host-linux-x64/ImportNvtxt
- ${nsys_dir}/host-linux-x64/CrashReporter
- ${nsys_dir}/host-linux-x64/QdstrmImporter
- ${nsys_dir}/host-linux-x64/libexec/QtWebEngineProcess
- ${nsys_dir}/target-linux-x64/nsys
- ${nsys_dir}/target-linux-x64/launcher
- ${nsys_dir}/target-linux-x64/nvgpucs
- ${nsys_dir}/target-linux-x64/nsys-launcher
- ${nsys_dir}/target-linux-x64/sqlite3
- ${nsys_dir}/target-linux-x64/python/bin/python
- )
-
- # remove rdma libs (unless USE=rdma)
- if ! use rdma; then
- rm -r "${ED}"/${cudadir}/${nsys_dir}/target-linux-x64/CollectX || die
- fi
-
- dobin builds/integration/nsight-systems/{nsight-sys,nsys,nsys-exporter,nsys-ui}
- eend $?
-
- # nsight scripts and binaries need to have their executable bit set, #691284
- for f in "${exes[@]}"; do
- fperms +x ${cudadir}/${f}
- done
-
- # fix broken RPATHs
- patchelf --set-rpath '$ORIGIN' "${ED}"/${cudadir}/${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/libarrow.so || die
- patchelf --set-rpath '$ORIGIN' "${ED}"/${cudadir}/${nsys_dir}/host-linux-x64/libarrow.so || die
-
- # remove foreign archs (triggers SONAME warning, #749903)
- rm -r "${ED}"/${cudadir}/${ncu_dir}/target/linux-desktop-glibc_2_19_0-ppc64le || die
- rm -r "${ED}"/${cudadir}/${ncu_dir}/target/linux-desktop-t210-a64 || die
-
- # unbundle libstdc++
- rm "${ED}"/${cudadir}/${nsys_dir}/host-linux-x64/libstdc++.so.6 || die
-
- # unbundle openssl
- rm "${ED}"/${cudadir}/${ncu_dir}/host/linux-desktop-glibc_2_11_3-x64/lib{crypto,ssl}.so* || die
- rm "${ED}"/${cudadir}/${nsys_dir}/host-linux-x64/lib{crypto,ssl}.so* || die
-
- # unbundle libpfm
- rm "${ED}"/${cudadir}/${nsys_dir}/host-linux-x64/libpfm.so* || die
-
- # TODO: unbundle qt5
- # TODO: unbundle boost
- # TODO: unbundle icu
- # TODO: unbundle mesa
- # TODO: unbundle libSshClient
- # TODO: unbundle sqlite
- fi
-
- if use examples; then
- local exes=(
- extras/demo_suite/bandwidthTest
- extras/demo_suite/busGrind
- extras/demo_suite/deviceQuery
- extras/demo_suite/nbody
- extras/demo_suite/oceanFFT
- extras/demo_suite/randomFog
- extras/demo_suite/vectorAdd
- )
-
- # set executable bit on demo_suite binaries
- for f in "${exes[@]}"; do
- fperms +x ${cudadir}/${f}
- done
- else
- rm -r "${ED}"/${cudadir}/extras/demo_suite || die
- fi
-
- # remove rdma libs (unless USE=rdma)
- if ! use rdma; then
- rm "${ED}"/${cudadir}/targets/x86_64-linux/lib/libcufile_rdma* || die
- fi
-
- # Add include and lib symlinks
- dosym targets/x86_64-linux/include ${cudadir}/include
- dosym targets/x86_64-linux/lib ${cudadir}/lib64
-
- # Remove bad symlinks
- rm "${ED}"/${cudadir}/targets/x86_64-linux/include/include || die
- rm "${ED}"/${cudadir}/targets/x86_64-linux/lib/lib64 || die
-
- newenvd - 99cuda <<-EOF
- PATH=${ecudadir}/bin${pathextradirs}
- ROOTPATH=${ecudadir}/bin
- LDPATH=${ecudadir}/lib64:${ecudadir}/nvvm/lib64${ldpathextradirs}
- EOF
-
- # Cuda prepackages libraries, don't revdep-build on them
- insinto /etc/revdep-rebuild
- newins - 80${PN} <<-EOF
- SEARCH_DIRS_MASK="${ecudadir}"
- EOF
-}
-
-pkg_postinst_check() {
- local a="$("${EROOT}"/opt/cuda/bin/cuda-config -s)"
- local b="0.0"
- local v
- for v in ${a}; do
- ver_test "${v}" -gt "${b}" && b="${v}"
- done
-
- # if gcc and if not gcc-version is at least greatest supported
- if tc-is-gcc && \
- ver_test $(gcc-version) -gt "${b}"; then
- ewarn
- ewarn "gcc > ${b} will not work with CUDA"
- ewarn "Make sure you set an earlier version of gcc with gcc-config"
- ewarn "or append --compiler-bindir= pointing to a gcc bindir like"
- ewarn "--compiler-bindir=${EPREFIX}/usr/*pc-linux-gnu/gcc-bin/gcc${b}"
- ewarn "to the nvcc compiler flags"
- ewarn
- fi
-}
-
-pkg_postinst() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- pkg_postinst_check
- fi
-
- if use profiler || use nsight; then
- einfo
- einfo "nvidia-drivers restrict access to performance counters."
- einfo "You'll need to either run profiling tools (nvprof, nsight) "
- einfo "using sudo (needs cap SYS_ADMIN) or add the following line to "
- einfo "a modprobe configuration file "
- einfo "(e.g. /etc/modprobe.d/nvidia-prof.conf): "
- einfo
- einfo "options nvidia NVreg_RestrictProfilingToAdminUsers=0"
- einfo
- fi
-}