summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2021-11-01 12:24:38 +0100
committerTobias Klausmann <klausman@gentoo.org>2021-11-03 12:52:15 +0100
commita69cf8d8976ca5968c07ec8ac1ae1ac5da99a7e9 (patch)
tree658b2e50799aad7dcf87936e420b98639a681d11
parentdev-python/qtawesome: add version 1.1.0 (diff)
downloadgentoo-a69cf8d8976ca5968c07ec8ac1ae1ac5da99a7e9.tar.gz
gentoo-a69cf8d8976ca5968c07ec8ac1ae1ac5da99a7e9.tar.bz2
gentoo-a69cf8d8976ca5968c07ec8ac1ae1ac5da99a7e9.zip
app-admin/lib_users: Add v0.15
Unfortunately, nose is deprecated and its spiritual successor nose2 is only keyworded on amd64 and x86, so we have to drop all other keywords. lib_users _may_ abandon the nose/nose2 dependency in the future, but it's not a given. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
-rw-r--r--app-admin/lib_users/Manifest1
-rw-r--r--app-admin/lib_users/lib_users-0.15.ebuild (renamed from app-admin/lib_users/lib_users-0.14-r1.ebuild)10
2 files changed, 6 insertions, 5 deletions
diff --git a/app-admin/lib_users/Manifest b/app-admin/lib_users/Manifest
index 0de0bd00f288..3728a22a903d 100644
--- a/app-admin/lib_users/Manifest
+++ b/app-admin/lib_users/Manifest
@@ -1 +1,2 @@
DIST lib_users-0.14.tar.gz 25746 BLAKE2B 4aa2dbbd7c53be13f79988a62c7997f0787ea9b773fc57681a021ff75ba9ff0988ac3032b21150c4e4958849a6195df09d388b6341e1ac139f34ce9555786233 SHA512 533c6e8f486e58d0fd22aea9a30adf91c3a8340a8a3719f6374ddfa8120d402c8202ab8ceb0e78aedd46e3e5875795392ed40497a66d51de5c2ca6a275a1a777
+DIST lib_users-0.15.tar.gz 25899 BLAKE2B e54dfe20cf5e3e3da3bddcf044cda36a5d51dec9baa808202d81ed0ef8a8b434b3c6f31a279b544308a32e6ebf91008ac2db49278da7624a6037ffdf1db309b6 SHA512 f9eab0d7c634602c496154dc20bd8374842df77c6abfaf69a0c34013f01c3a7541a006cb2b027539f6c088a55bea78682bf156723899d614f39ee48773fb9ea8
diff --git a/app-admin/lib_users/lib_users-0.14-r1.ebuild b/app-admin/lib_users/lib_users-0.15.ebuild
index d162c03e45d6..b5a163398ad1 100644
--- a/app-admin/lib_users/lib_users-0.14-r1.ebuild
+++ b/app-admin/lib_users/lib_users-0.15.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-r1
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/klausman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -21,12 +21,12 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}
test? (
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose2[${PYTHON_USEDEP}]
)"
RDEPEND="${PYTHON_DEPS}"
src_test() {
- python_foreach_impl nosetests --verbosity=2
+ python_foreach_impl nose2 --verbosity=2
}
my_install() {