summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-27 06:34:06 +0000
committerSam James <sam@gentoo.org>2021-01-27 06:34:37 +0000
commita69dc77d70d4eec570353c055a6339e3e00e1eab (patch)
tree2eb0841f1fd25c5304e2bd9c5a048fde7a760ab7
parentdev-util/gtk-update-icon-cache: Stabilize 3.24.24 sparc, #767358 (diff)
downloadgentoo-a69dc77d.tar.gz
gentoo-a69dc77d.tar.bz2
gentoo-a69dc77d.zip
dev-ml/dose3: import Debian patchset (p16)
Closes: https://bugs.gentoo.org/675892 Closes: https://bugs.gentoo.org/707938 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ml/dose3/Manifest2
-rw-r--r--dev-ml/dose3/dose3-5.0.1_p16.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-ml/dose3/Manifest b/dev-ml/dose3/Manifest
index 57bc6e62d881..75bf4cff0ee9 100644
--- a/dev-ml/dose3/Manifest
+++ b/dev-ml/dose3/Manifest
@@ -1 +1,3 @@
DIST dose3-5.0.1.tar.gz 297433 BLAKE2B 74ae954604f26398f091b4f14d2a633132ae62102f52af13284af27e41cd7c47afb1b533b0821a8921ba33fa6658e94b3bb6bf5f104f48881a50e14517cd65e2 SHA512 e66526319446054041f138ee2633043d0832089f6a554cf566a28de899d10383acfb1aa6bf1a368811602939676510933a7d2404fd34dbeba15045b458f5af84
+DIST dose3_5.0.1-16.debian.tar.xz 39448 BLAKE2B a5ae8c74ee1a5a89bf3594cbaf0b37703fcf03a03e336c6b91626fcb6767518c517bf28ec4a24f6cbeb40e1544b34e95855507f39aacca110e8daa6e6e5d3994 SHA512 52d14a45bc0b0a66c4cf3acc05b479b1456c78fa8cb0e453a01dd2f0d849dfcf959bd9e8ff8d505272ad7ad542ff402013746816ead3ccd2dbd0bed572ee2930
+DIST dose3_5.0.1.orig.tar.gz 297433 BLAKE2B 74ae954604f26398f091b4f14d2a633132ae62102f52af13284af27e41cd7c47afb1b533b0821a8921ba33fa6658e94b3bb6bf5f104f48881a50e14517cd65e2 SHA512 e66526319446054041f138ee2633043d0832089f6a554cf566a28de899d10383acfb1aa6bf1a368811602939676510933a7d2404fd34dbeba15045b458f5af84
diff --git a/dev-ml/dose3/dose3-5.0.1_p16.ebuild b/dev-ml/dose3/dose3-5.0.1_p16.ebuild
new file mode 100644
index 000000000000..a407b1aeddfe
--- /dev/null
+++ b/dev-ml/dose3/dose3-5.0.1_p16.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library to perform analysis on package repositories"
+HOMEPAGE="http://www.mancoosi.org/software/ https://gforge.inria.fr/projects/dose"
+SRC_URI="http://deb.debian.org/debian/pool/main/d/dose3/${PN}_$(ver_cut 1-3).orig.tar.gz"
+SRC_URI+=" http://deb.debian.org/debian/pool/main/d/dose3/${PN}_${PV/_p/-}.debian.tar.xz"
+#SRC_URI="https://gforge.inria.fr/frs/download.php/file/36063/${P}.tar.gz"
+S="${WORKDIR}/${PN}-$(ver_cut 1-3)"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt parmap zip bzip2 xml curl rpm4 test"
+
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+"
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt=]
+ dev-ml/cudf:=[ocamlopt=]
+ >=dev-ml/extlib-1.7.0:=[ocamlopt=]
+ >=dev-ml/ocamlgraph-1.8.6:=[ocamlopt=]
+ dev-ml/re:=[ocamlopt=]
+ parmap? ( dev-ml/parmap:=[ocamlopt=] )
+ zip? ( dev-ml/camlzip:=[ocamlopt=] )
+ bzip2? ( dev-ml/camlbz2:= )
+ xml? (
+ dev-ml/ocaml-expat:=[ocamlopt=]
+ dev-ml/xml-light:=[ocamlopt=]
+ )
+ curl? ( dev-ml/ocurl:= )
+ rpm4? ( app-arch/rpm )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pyyaml[libyaml] )
+"
+
+# missing test data
+RESTRICT="test"
+
+QA_FLAGS_IGNORED='.*'
+
+src_prepare() {
+ default
+ sed -e 's/INSTALLOPTS=-s/INSTALLOPTS=/' -i Makefile.config.in || die
+
+ # Not relevant to us, Debian specific adjustments
+ rm "${WORKDIR}"/debian/patches/0009-Fix-and-constraints-against-virtual-packages.patch || die
+ rm "${WORKDIR}"/debian/patches/binaries-prefix-edos || die
+
+ elog "Applying Debian patchset..."
+ for file in "${WORKDIR}"/debian/patches/*.patch ; do
+ eapply "${file}"
+ done
+}
+
+src_configure() {
+ econf \
+ $(use ocamlopt || echo "--with-bytecodeonly") \
+ $(use parmap && echo "--with-parmap") \
+ $(use zip && echo "--with-zip") \
+ $(use bzip2 && echo "--with-bz2") \
+ $(use xml && echo "--with-xml") \
+ $(use curl && echo "--with-curl") \
+ $(use rpm4 && echo "--with-rpm4")
+}
+
+src_compile() {
+ emake -j1 VERBOSE="-classic-display"
+}
+
+src_install() {
+ emake DESTDIR="${D}" BINDIR="${ED}/usr/bin" install || die
+ dodoc CHANGES CREDITS README.architecture TODO
+}