summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-04-09 15:32:18 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-04-09 15:41:38 +0200
commita6ae328cd334096c25c2fbc0299d166ce69f91ae (patch)
tree3d470a6058a8556ad9e4c7f6b3bd3dff164365d6
parentapp-arch/bzip2: EAPI update and patch cleanup. (diff)
downloadgentoo-a6ae328cd334096c25c2fbc0299d166ce69f91ae.tar.gz
gentoo-a6ae328cd334096c25c2fbc0299d166ce69f91ae.tar.bz2
gentoo-a6ae328cd334096c25c2fbc0299d166ce69f91ae.zip
dev-python/ntlm-auth: 1.1.0 bump
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--dev-python/ntlm-auth/Manifest1
-rw-r--r--dev-python/ntlm-auth/ntlm-auth-1.1.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/ntlm-auth/Manifest b/dev-python/ntlm-auth/Manifest
index ce7b7550b26c..67028e574d51 100644
--- a/dev-python/ntlm-auth/Manifest
+++ b/dev-python/ntlm-auth/Manifest
@@ -1 +1,2 @@
DIST ntlm-auth-1.0.6.tar.gz 48282 BLAKE2B 988634d78d6c30a92791baaf4dff865fe2bba8318ce1bcd9739c267d11fb29ae90e7b0348b05b4ef3754cf20675aa690973cca03fa35c195ae0c73c6ac6120e8 SHA512 e6abafd52affebfe0f60ed1fd77543dbfe675a82774bffc44d2e034226806ce6781adc5ca8ac29c35c6fe75440f94a1763e01b0987669cb44a6fe01e102a1489
+DIST ntlm-auth-1.1.0.tar.gz 38624 BLAKE2B 22c6fbe7ef95b7ee88b803b7ccc5f63f1a27ec9285a4527dac20c3d774abef9765f8a7aa7265effd70869f02e09e6d3b8012c50b703c3b0979e41c0134843be2 SHA512 0c41cfab957c48d5fabf391422323556289cc6d8ba5a50c82bb179f6cdbf68528f005c3987e0b47fb47aff2fbcf00deebb0ac4220df6bd08d335879344f8470a
diff --git a/dev-python/ntlm-auth/ntlm-auth-1.1.0.ebuild b/dev-python/ntlm-auth/ntlm-auth-1.1.0.ebuild
new file mode 100644
index 000000000000..54b600d8ff15
--- /dev/null
+++ b/dev-python/ntlm-auth/ntlm-auth-1.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Calculates NTLM Authentication codes"
+HOMEPAGE="https://github.com/jborean93/ntlm-auth"
+SRC_URI="https://github.com/jborean93/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/ordereddict[${PYTHON_USEDEP}]' python2_7)"
+DEPEND="${RDEPEND}"