summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-02-25 19:36:20 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-03-16 21:31:12 +0200
commita6cb268c1175a8302bf048593db53e06c3bcc16d (patch)
treef9d983b3b7f76db3f89aece1e6943abba221c7cc
parentgui-libs/wayfire-plugins-extra: drop 0.7.5 (diff)
downloadgentoo-a6cb268c.tar.gz
gentoo-a6cb268c.tar.bz2
gentoo-a6cb268c.zip
gui-libs/neatvnc: add 0.8.0
Bug: https://bugs.gentoo.org/902141 Closes: https://bugs.gentoo.org/925498 Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--gui-libs/neatvnc/Manifest1
-rw-r--r--gui-libs/neatvnc/files/neatvnc-0.8.0-fix-tracing-undeclared-variable.patch26
-rw-r--r--gui-libs/neatvnc/neatvnc-0.8.0.ebuild86
-rw-r--r--gui-libs/neatvnc/neatvnc-9999.ebuild22
4 files changed, 134 insertions, 1 deletions
diff --git a/gui-libs/neatvnc/Manifest b/gui-libs/neatvnc/Manifest
index fbd029cfd3d7..fb744fdd0e24 100644
--- a/gui-libs/neatvnc/Manifest
+++ b/gui-libs/neatvnc/Manifest
@@ -1,2 +1,3 @@
DIST neatvnc-0.6.0.tar.gz 578084 BLAKE2B 63a064054a61996bd09064e4684d6d4e836290b9c0a097138a8dbefc3615b8d22f1932caef3b147bf3a12fa14ef808d314016d53411e2d461e775e1a34522e15 SHA512 7fc38aa36faba227e37ec241b874f7c83e7bb912b22cb1f2198622a0bb3145661111bf58b3f9e376b0d03f04b667ba94f2e60f7f5e886c141178a874c820ea91
DIST neatvnc-0.7.0.tar.gz 660642 BLAKE2B ae14f3d35839ae141d6cce760c118f6605b66c16e3d8e6fae4606deaa63adacab13d3c8dbc001a3937f4f1f6f9c908607176ea36a914d39a126730c77f3470c7 SHA512 79abf2f6d5676e1d8dc9f70a341ae0247ae20dd95f8724d27c667ae42d45c8b5f4de2321c0dad6278e0eebefbcda0a512da917fa6e5def801f938875bdab18d0
+DIST neatvnc-0.8.0.tar.gz 661726 BLAKE2B 075831ad8f2a4e209b316b848ac2f5b2dbcd0ecf36e2ecc2b264be255ca0250d9a61ae5df1c522c310459cc2a536958cb01567ee640fca52db3966329d89cd09 SHA512 bd5bfbcec88711a64eb45c12cad208d594f24e3812d98ccb9eb3a3f8a933df3040fcb21e4bdf0df3ea44332096b6f0bca6dcb8f4be15d42541ab98b2295d4091
diff --git a/gui-libs/neatvnc/files/neatvnc-0.8.0-fix-tracing-undeclared-variable.patch b/gui-libs/neatvnc/files/neatvnc-0.8.0-fix-tracing-undeclared-variable.patch
new file mode 100644
index 000000000000..72bf4285d9fd
--- /dev/null
+++ b/gui-libs/neatvnc/files/neatvnc-0.8.0-fix-tracing-undeclared-variable.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/902141
+https://github.com/any1/neatvnc/pull/110
+
+From ce654aaf8b680768c4c51bef858e16f0db895814 Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Sun, 25 Feb 2024 19:31:47 +0200
+Subject: [PATCH] server: remove undeclared variable from tracing macro
+
+* 3647457f6d769fe3c9518078008ef56be58b70b1 accidentally referred to
+ an nonexistant variable.
+
+Signed-off-by: Alfred Wingate <parona@protonmail.com>
+--- a/src/server.c
++++ b/src/server.c
+@@ -2109,7 +2109,7 @@ static void complete_fb_update(struct nvnc_client* client)
+ client->current_fb = NULL;
+ process_fb_update_requests(client);
+ client_unref(client);
+- DTRACE_PROBE2(neatvnc, update_fb_done, client, pts);
++ DTRACE_PROBE1(neatvnc, update_fb_done, client);
+ }
+
+ static void on_write_frame_done(void* userdata, enum stream_req_status status)
+--
+2.43.2
+
diff --git a/gui-libs/neatvnc/neatvnc-0.8.0.ebuild b/gui-libs/neatvnc/neatvnc-0.8.0.ebuild
new file mode 100644
index 000000000000..45912b2bf4d3
--- /dev/null
+++ b/gui-libs/neatvnc/neatvnc-0.8.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Liberally licensed VNC server library with a clean interface"
+HOMEPAGE="https://github.com/any1/neatvnc/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
+else
+ SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples gbm h264 jpeg ssl test tracing websockets"
+REQUIRED_USE="h264? ( gbm )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ =dev-libs/aml-0.3*
+ sys-libs/zlib
+ x11-libs/pixman
+ examples? (
+ media-libs/libpng:=
+ )
+ gbm? ( media-libs/mesa )
+ h264? (
+ media-video/ffmpeg:=
+ x11-libs/libdrm
+ )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ ssl? ( net-libs/gnutls:= )
+ tracing? ( dev-debug/systemtap )
+ websockets? (
+ dev-libs/gmp:=
+ dev-libs/nettle:=[gmp]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libdrm
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/neatvnc-0.8.0-fix-tracing-undeclared-variable.patch"
+)
+
+src_prepare() {
+ default
+
+ # useful soname
+ sed -i -e "s/'0.0.0'/meson.project_version()/" meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use test tests)
+ $(meson_feature jpeg)
+ $(meson_feature ssl tls)
+ $(meson_feature websockets nettle)
+ $(meson_use tracing systemtap)
+ $(meson_feature gbm)
+ $(meson_feature h264)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ einstalldocs
+
+ if use examples; then
+ newbin "${BUILD_DIR}"/examples/draw neatvnc-example-draw
+ newbin "${BUILD_DIR}"/examples/png-server neatvnc-example-png-server
+ fi
+}
diff --git a/gui-libs/neatvnc/neatvnc-9999.ebuild b/gui-libs/neatvnc/neatvnc-9999.ebuild
index 64004b4ea3b4..6e2c4493b97e 100644
--- a/gui-libs/neatvnc/neatvnc-9999.ebuild
+++ b/gui-libs/neatvnc/neatvnc-9999.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
else
SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~riscv ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc64 ~riscv ~x86"
fi
LICENSE="ISC"
@@ -26,6 +26,9 @@ RDEPEND="
=dev-libs/aml-0.3*
sys-libs/zlib
x11-libs/pixman
+ examples? (
+ media-libs/libpng:=
+ )
gbm? ( media-libs/mesa )
h264? (
media-video/ffmpeg:=
@@ -47,6 +50,13 @@ BDEPEND="
virtual/pkgconfig
"
+src_prepare() {
+ default
+
+ # useful soname
+ sed -i -e "s/'0.0.0'/meson.project_version()/" meson.build || die
+}
+
src_configure() {
local emesonargs=(
$(meson_use examples)
@@ -60,3 +70,13 @@ src_configure() {
)
meson_src_configure
}
+
+src_install() {
+ meson_src_install
+ einstalldocs
+
+ if use examples; then
+ newbin "${BUILD_DIR}"/examples/draw neatvnc-example-draw
+ newbin "${BUILD_DIR}"/examples/png-server neatvnc-example-png-server
+ fi
+}