summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-21 09:45:03 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-21 09:54:52 +0200
commita6e815bba4145f5f072d8ddd655539060209edea (patch)
tree3cdb65938c4f060b2ca7a4b4262e43a8809047c6
parentapp-misc/fdupes: remove comment. (diff)
downloadgentoo-a6e815bb.tar.gz
gentoo-a6e815bb.tar.bz2
gentoo-a6e815bb.zip
app-misc/ondir: honour CFLAGS, LD and LDFLAGS.
Closes: https://bugs.gentoo.org/722338 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--app-misc/ondir/ondir-0.2.4.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-misc/ondir/ondir-0.2.4.ebuild b/app-misc/ondir/ondir-0.2.4.ebuild
index 2f51ec18dee6..e3c9190d013a 100644
--- a/app-misc/ondir/ondir-0.2.4.ebuild
+++ b/app-misc/ondir/ondir-0.2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,15 +22,17 @@ src_prepare() {
default
sed -i \
-e "s:\(/man/.*$\):/share\1:g" \
- -e "s:-g:${CFLAGS}:" Makefile || die "sed Makefile failed"
+ -e "s#^CFLAGS=\(.*\)#CFLAGS= \1 ${CFLAGS}#g;" \
+ -e "s#^LDFLAGS=\(.*\)#LDFLAGS= \1 ${LDFLAGS}#g;" \
+ -i Makefile || die "sed Makefile failed"
}
src_compile() {
emake \
CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
PREFIX="${EPREFIX}/usr" \
- CONF="${EPREFIX}/etc/ondirrc" \
- LDFLAGS="${LDFLAGS}"
+ CONF="${EPREFIX}/etc/ondirrc"
}
src_install() {