summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2018-04-18 14:05:46 +0100
committerMarek Szuba <marecki@gentoo.org>2018-04-18 14:06:05 +0100
commita719bc24b1dc31b775497786d471bdcbb1cfb9be (patch)
tree9382e85e3c62ae4b78b5428c32f9ec6c062eff66
parentdev-python/flake8: arm stable wrt bug #649350 (diff)
downloadgentoo-a719bc24.tar.gz
gentoo-a719bc24.tar.bz2
gentoo-a719bc24.zip
net-p2p/syncthing: bump to 0.14.46
Closes: https://bugs.gentoo.org/show_bug.cgi?id=652460 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--net-p2p/syncthing/Manifest1
-rw-r--r--net-p2p/syncthing/syncthing-0.14.46.ebuild123
2 files changed, 124 insertions, 0 deletions
diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index 71c66bb7c5a5..395edbd971c2 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -1,3 +1,4 @@
DIST syncthing-0.14.38.tar.gz 8246629 BLAKE2B 93c01750fedd57cc07bffa14fe65d98fc1cf48b43eaf965fc3ff9546a24acada411a89a19b47e2f5b5e7508e57646d0560559c35bb3c378b7c04e3db14b7ffaa SHA512 be5f7527d63e8db427705c34b26d783d9abd7cb5727d3dcf08ee62b1ace5454b7dfed4f030ec53e847a34f560cf349460f68c859a1008c5105aef65ef42c5cc5
DIST syncthing-0.14.40.tar.gz 8300965 BLAKE2B 6cafde21707c3334b55d29f741059dae79c9566373e365e2e5f275df60170b2d0a7e13db8b0a061410f327387c4eb446f5104cebf2457918dc0f5419baec7acc SHA512 3e79b034d71d1c862d21433f897dc774d3e421628804ed9c8304d4ed0dccb90fa8ec738aef476bf074ba70d4c9947114c5b6a8326faa5d6b6e5dcc03dacabecb
DIST syncthing-0.14.44.tar.gz 10225689 BLAKE2B 67531246b9ffef72289f8c3d1372b4596f307a9608a2c2f09f96c2ca4eacd7413029cda9fadb0351c7980f7dc1ce17fa498fafa64860aa8437b158fa5e217fa2 SHA512 3a68c8ad3f586af22243d502322ed8269b10ea4d85b0a1bc39578d3da1bcc61e8753a6b94d5a7c8d7b56b86777932327450c2c08f447bb8a190a0171e2c015d4
+DIST syncthing-0.14.46.tar.gz 10200015 BLAKE2B 679b82af8ee5dad769ef01b77d0d3545d953ec2f2889faa129c433863094f431bf3e44a633109d944cbcaba6486a8b51257557eddfc20a2fb3f0cd8a77861b96 SHA512 ebf8491d1ac1dda90df35b8a9dafb808a9171d4a8083f0f24ac1c9b3aa8d2baac6cef61c5cd897a88c3fb93b114d79a31a341168859f091ed2cdef529321178c
diff --git a/net-p2p/syncthing/syncthing-0.14.46.ebuild b/net-p2p/syncthing/syncthing-0.14.46.ebuild
new file mode 100644
index 000000000000..00190a582b6b
--- /dev/null
+++ b/net-p2p/syncthing/syncthing-0.14.46.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/${PN}/${PN}"
+
+inherit golang-vcs-snapshot systemd user versionator
+
+DESCRIPTION="Open Source Continuous File Synchronization"
+HOMEPAGE="https://syncthing.net"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="selinux tools"
+
+RDEPEND="selinux? ( sec-policy/selinux-syncthing )"
+
+DOCS=( README.md AUTHORS CONTRIBUTING.md )
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+
+ if use tools ; then
+ # separate user for the relay server
+ enewgroup strelaysrv
+ enewuser strelaysrv -1 -1 /var/lib/strelaysrv strelaysrv
+ # and his home folder
+ keepdir /var/lib/strelaysrv
+ fowners strelaysrv:strelaysrv /var/lib/strelaysrv
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/strelaysrv|' \
+ src/${EGO_PN}/cmd/strelaysrv/etc/linux-systemd/strelaysrv.service \
+ || die
+}
+
+src_compile() {
+ export GOPATH="${S}:$(get_golibdir_gopath)"
+ cd src/${EGO_PN} || die
+ go run build.go -version "v${PV}" -no-upgrade install \
+ $(usex tools "all" "") || die "build failed"
+}
+
+src_test() {
+ cd src/${EGO_PN} || die
+ go run build.go test || die "test failed"
+}
+
+src_install() {
+ pushd src/${EGO_PN} >& /dev/null || die
+ doman man/*.[157]
+ einstalldocs
+
+ dobin bin/syncthing
+ if use tools ; then
+ exeinto /usr/libexec/syncthing
+ local exe
+ for exe in bin/* ; do
+ [[ "${exe}" == "bin/syncthing" ]] || doexe "${exe}"
+ done
+ fi
+ popd >& /dev/null || die
+
+ # openrc and systemd service files
+ systemd_dounit src/${EGO_PN}/etc/linux-systemd/system/${PN}{@,-resume}.service
+ systemd_douserunit src/${EGO_PN}/etc/linux-systemd/user/${PN}.service
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ if use tools ; then
+ # openrc and systemd service files
+ systemd_dounit src/${EGO_PN}/cmd/strelaysrv/etc/linux-systemd/strelaysrv.service
+ newconfd "${FILESDIR}/strelaysrv.confd" strelaysrv
+ newinitd "${FILESDIR}/strelaysrv.initd" strelaysrv
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/strelaysrv.logrotate" strelaysrv
+ fi
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ $(get_version_component_range 2) -gt \
+ $(get_version_component_range 2 ${v}) ]]; then
+ ewarn "Version ${PV} is not protocol-compatible with version" \
+ "0.$(($(get_version_component_range 2) - 1)).x or lower."
+ ewarn "Make sure all your devices are running at least version" \
+ "0.$(get_version_component_range 2).0."
+ fi
+ ewarn "Syncthing OpenRC init script now uses the upstream default of"
+ ewarn ""
+ ewarn " /var/lib/${PN}/.config/${PN}"
+ ewarn ""
+ ewarn "as its configuration directory. Please set SYNCTHING_HOMEDIR"
+ ewarn "to /var/lib/${PN} in /etc/conf.d/${PN} if you wish to continue"
+ ewarn "using the old Gentoo default. Systemd users are not affected."
+ done
+
+ # check if user syncthing-relaysrv exists
+ # if yes, warn that it has been moved to strelaysrv
+ if [[ -n "$(egetent passwd syncthing-relaysrv 2>/dev/null)" ]]; then
+ ewarn
+ ewarn "The user and group for the relay server have been changed"
+ ewarn "from syncthing-relaysrv to strelaysrv"
+ ewarn "The old user and group are not deleted automatically. Delete them by running:"
+ ewarn " userdel -r syncthing-relaysrv"
+ ewarn " groupdel syncthing-relaysrv"
+ fi
+}