summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-04-03 11:43:49 +0100
committerMatthew Smith <matthew@gentoo.org>2022-04-03 11:44:45 +0100
commita72cbbc68e0655cadf6eed1e77363b10a663478a (patch)
treef3eac00f4dd46c9faa516a5c4283939a79fb3932
parentdev-libs/cereal: conditionally skip tests (diff)
downloadgentoo-a72cbbc6.tar.gz
gentoo-a72cbbc6.tar.bz2
gentoo-a72cbbc6.zip
net-misc/seafile-client: Don't call qmake during build
Fixes call to command that does not exist. Does not change build process or installed files. Closes: https://bugs.gentoo.org/836689 Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--net-misc/seafile-client/files/seafile-client-8.0.6-select-qt5.patch11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-misc/seafile-client/files/seafile-client-8.0.6-select-qt5.patch b/net-misc/seafile-client/files/seafile-client-8.0.6-select-qt5.patch
index 8b8e6d55aa08..4d3a3d172644 100644
--- a/net-misc/seafile-client/files/seafile-client-8.0.6-select-qt5.patch
+++ b/net-misc/seafile-client/files/seafile-client-8.0.6-select-qt5.patch
@@ -1,8 +1,8 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1c4a444..aae406c 100644
+index 1c4a4447..5747df46 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -133,11 +133,8 @@ ENDIF()
+@@ -133,14 +133,12 @@ ENDIF()
####################
###### BEGIN: QT configuration
####################
@@ -14,5 +14,10 @@ index 1c4a444..aae406c 100644
+FIND_PACKAGE(Qt5Core)
+SET(DETECTED_QT_VERSION ${Qt5Core_VERSION})
MESSAGE("Qt version: ${DETECTED_QT_VERSION}")
++GET_TARGET_PROPERTY(QMAKE_EXECUTABLE_PATH Qt5::qmake IMPORTED_LOCATION)
EXECUTE_PROCESS(COMMAND
- bash -c "qmake --version|grep -iE '^using qt version [0-9]'|awk '{print $4}'|grep -iE '^[0-9]'|awk -F . '{print $1}'"
+- bash -c "qmake --version|grep -iE '^using qt version [0-9]'|awk '{print $4}'|grep -iE '^[0-9]'|awk -F . '{print $1}'"
++ bash -c "${QMAKE_EXECUTABLE_PATH} --version|grep -iE '^using qt version [0-9]'|awk '{print $4}'|grep -iE '^[0-9]'|awk -F . '{print $1}'"
+ OUTPUT_VARIABLE QT_VERSION_MAJOR
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
+ MESSAGE("QT_VERSION_MAJOR: ${QT_VERSION_MAJOR}")