summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-02 12:02:16 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-02 12:02:16 +0200
commita7305139e77019c29d1419498b769f0564e363ba (patch)
tree46aeaf3192f53e7840e5d96f3373585149c05d6b
parentnet-analyzer/nikto: Drop old (diff)
downloadgentoo-a7305139.tar.gz
gentoo-a7305139.tar.bz2
gentoo-a7305139.zip
net-dialup/rp-l2tp: Fix parallel build (#567744 by Felix Janda)
Package-Manager: Portage-2.3.27, Repoman-2.3.9
-rw-r--r--net-dialup/rp-l2tp/files/rp-l2tp-0.4-build.patch12
-rw-r--r--net-dialup/rp-l2tp/files/rp-l2tp-0.4-parallel-build.patch12
-rw-r--r--net-dialup/rp-l2tp/rp-l2tp-0.4-r4.ebuild22
3 files changed, 30 insertions, 16 deletions
diff --git a/net-dialup/rp-l2tp/files/rp-l2tp-0.4-build.patch b/net-dialup/rp-l2tp/files/rp-l2tp-0.4-build.patch
index 7bb534b67940..6ba8630e43d6 100644
--- a/net-dialup/rp-l2tp/files/rp-l2tp-0.4-build.patch
+++ b/net-dialup/rp-l2tp/files/rp-l2tp-0.4-build.patch
@@ -1,5 +1,5 @@
---- Makefile.in.orig 2014-06-24 15:20:47.028342728 +0400
-+++ Makefile.in 2014-06-24 15:21:07.468320934 +0400
+--- a/Makefile.in.orig 2014-06-24 15:20:47.028342728 +0400
++++ b/Makefile.in 2014-06-24 15:21:07.468320934 +0400
@@ -39,8 +39,8 @@
libl2tp.a: $(OBJS)
@@ -11,8 +11,8 @@
l2tpd: libl2tp.a libevent/libevent.a
$(MAKE) -C handlers
---- libevent/Makefile.in.orig 2002-09-30 23:45:00.000000000 +0400
-+++ libevent/Makefile.in 2014-06-24 15:24:31.535105268 +0400
+--- a/libevent/Makefile.in.orig 2002-09-30 23:45:00.000000000 +0400
++++ b/libevent/Makefile.in 2014-06-24 15:24:31.535105268 +0400
@@ -18,20 +18,20 @@
libevent.a: $(OBJS)
@@ -39,8 +39,8 @@
clean: FORCE
rm -f *.a *.o *~
---- handlers/Makefile.in.orig 2014-06-24 15:31:35.186667624 +0400
-+++ handlers/Makefile.in 2014-06-24 15:32:26.659615281 +0400
+--- a/handlers/Makefile.in.orig 2014-06-24 15:31:35.186667624 +0400
++++ b/handlers/Makefile.in 2014-06-24 15:32:26.659615281 +0400
@@ -20,19 +20,19 @@
all: $(HANDLERS) l2tp-control
diff --git a/net-dialup/rp-l2tp/files/rp-l2tp-0.4-parallel-build.patch b/net-dialup/rp-l2tp/files/rp-l2tp-0.4-parallel-build.patch
new file mode 100644
index 000000000000..cfbb096bef70
--- /dev/null
+++ b/net-dialup/rp-l2tp/files/rp-l2tp-0.4-parallel-build.patch
@@ -0,0 +1,12 @@
+--- a/Makefile.in~ 2018-04-02 11:58:30.000000000 +0200
++++ b/Makefile.in 2018-04-02 12:00:15.173470572 +0200
+@@ -42,8 +42,7 @@
+ $(AR) -rc $@ $^
+ @RANLIB@ $@ || true
+
+-l2tpd: libl2tp.a libevent/libevent.a
+- $(MAKE) -C handlers
++l2tpd: libl2tp.a libevent/libevent.a handlers
+ @CC@ $(LDFLAGS) -o l2tpd -rdynamic $(OBJS) $(EXTRA_LIBS)
+
+ libevent/libevent.a:
diff --git a/net-dialup/rp-l2tp/rp-l2tp-0.4-r4.ebuild b/net-dialup/rp-l2tp/rp-l2tp-0.4-r4.ebuild
index cfe036f1c588..7d468429c0ac 100644
--- a/net-dialup/rp-l2tp/rp-l2tp-0.4-r4.ebuild
+++ b/net-dialup/rp-l2tp/rp-l2tp-0.4-r4.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils toolchain-funcs
+EAPI=6
+inherit toolchain-funcs
DESCRIPTION="User-space implementation of L2TP for Linux and other UNIX systems"
HOMEPAGE="https://sourceforge.net/projects/rp-l2tp/"
@@ -13,19 +12,22 @@ LICENSE="GPL-2"
KEYWORDS="amd64 ~ppc x86"
SLOT="0"
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo.patch"
+ "${FILESDIR}/${P}-flags.patch"
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-parallel-build.patch"
+)
+
src_prepare() {
tc-export AR CC RANLIB
- epatch \
- "${FILESDIR}/${P}-gentoo.patch" \
- "${FILESDIR}/${P}-flags.patch" \
- "${FILESDIR}/${P}-build.patch"
- epatch_user
+ default
}
src_install() {
emake RPM_INSTALL_ROOT="${D}" install
- dodoc README
+ einstalldocs
newdoc l2tp.conf rp-l2tpd.conf
docinto libevent
dodoc libevent/Doc/*