summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2022-10-06 23:14:58 -0700
committerMatthew Smith <matthew@gentoo.org>2022-11-04 17:12:10 +0000
commita740841dc81fd3d20f5883a7084611f2c8d652cd (patch)
treeab7e7ec2173ea2fd94e6c2f4cfe14ed52c4cc7a8
parentnet-mail/getmail: Drop old stable 6.14 (diff)
downloadgentoo-a740841d.tar.gz
gentoo-a740841d.tar.bz2
gentoo-a740841d.zip
net-mail/getmail: add 6.18.10
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Closes: https://github.com/gentoo/gentoo/pull/27669 Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--net-mail/getmail/Manifest1
-rw-r--r--net-mail/getmail/getmail-6.18.10.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/getmail/Manifest b/net-mail/getmail/Manifest
index 902e577d3b54..565822d99c07 100644
--- a/net-mail/getmail/Manifest
+++ b/net-mail/getmail/Manifest
@@ -1 +1,2 @@
+DIST getmail-6.18.10.gh.tar.gz 205481 BLAKE2B a0597db32ff2ce43bf96feadcba4d926d48898cc412ec96e8d62086e29a364f6b806f0279878b95976e3ca7b0966afb19cb59939ef8bea1627a230518ea28602 SHA512 feda9236d3a1a7ceb21ca293d41c9631fec5f8753be4ece6e1b6910c052d10a8466547977fb4d0452ec4ae9f89ebff36105e0fe5843d02b2af3fd4bcea36e6c1
DIST getmail-6.18.9.tar.gz 204488 BLAKE2B 4bf95cec36ce10d5fd6c9fbb6b96923915a13f4b339a9846caafc5602a56612fb9f4b7209a138a03b81b19b7d28328bb46c60165215384650e7dcf98294cc5fa SHA512 dfeaebbca0c8766a16783d27171e65595d97a4b557943677dd7e7a66a9da8b49dfdbfb4aba9655ce3815ff6e2f991905317085b156ba6dbac841bb0fbb26c8b5
diff --git a/net-mail/getmail/getmail-6.18.10.ebuild b/net-mail/getmail/getmail-6.18.10.ebuild
new file mode 100644
index 000000000000..c93dc560dd6a
--- /dev/null
+++ b/net-mail/getmail/getmail-6.18.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ssl"
+inherit distutils-r1
+
+DESCRIPTION="A mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="https://www.getmail6.org/ https://github.com/getmail6/getmail6"
+SRC_URI="https://github.com/getmail6/getmail6/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/getmail6-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_prepare_all() {
+ # Use gentoo version number (including revision) for doc dir and remove COPYING file
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}