summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-08 14:00:40 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-08 14:01:44 +0100
commita75b7cbb0e4c2f9a70519aa90272a20596272832 (patch)
tree5561de872a2f479a00a3a8560dcf22737f948fea
parentxfce-base/libxfce4ui: Bump to 4.18.6 (diff)
downloadgentoo-a75b7cbb0e4c2f9a70519aa90272a20596272832.tar.gz
gentoo-a75b7cbb0e4c2f9a70519aa90272a20596272832.tar.bz2
gentoo-a75b7cbb0e4c2f9a70519aa90272a20596272832.zip
xfce-extra/xfce4-weather-plugin: Bump to 0.11.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-weather-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/Manifest b/xfce-extra/xfce4-weather-plugin/Manifest
index 7d70772c34a7..fc0f39f7fce9 100644
--- a/xfce-extra/xfce4-weather-plugin/Manifest
+++ b/xfce-extra/xfce4-weather-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-weather-plugin-0.11.1.tar.bz2 3100215 BLAKE2B 454fd3d4f1d40123b4ffd6f648b43079be444fccb876e123604deeee51741819ab3b65d81e56af9f25dce720f34d706f6c87211619a8e55b7f9f41bb5fc530e1 SHA512 625b2aab1ded60eb39171969cd67224569cf7477c0a6e47aa5600a4a09b4a2cecd4b830f4c01669e6f2289edd4e7d882b15d56526a1211b8b5b86141b585778f
+DIST xfce4-weather-plugin-0.11.2.tar.bz2 3096214 BLAKE2B e12d4e0a888b5c9602a0aa0bd595b89bc76a30fa3c250c16c2ddf328d4183c752a624a5e282447b4c987ed4a9ed1dc8e7f9413b3107956e1f67e96fce7213ec8 SHA512 011868165b17501a8b5aacb0387c23be635a1f4037a49501a823cf4aeb2be77d40aad51a4f1d1ccb1057b49e82d4cce2b2cffb82d165cf695340fbab99665ae2
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.2.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.2.ebuild
new file mode 100644
index 000000000000..3ede79a2b03b
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-weather-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-weather-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="upower"
+
+DEPEND="
+ >=dev-libs/glib-2.64.0
+ >=dev-libs/json-c-0.13.1:=
+ dev-libs/libxml2
+ >=net-libs/libsoup-2.42:2.4[ssl]
+ >=x11-libs/gtk+-3.22.0
+ >=xfce-base/libxfce4ui-4.14.0
+ >=xfce-base/libxfce4util-4.14.0
+ >=xfce-base/xfce4-panel-4.14.0
+ >=xfce-base/xfconf-4.12.0
+ upower? ( >=sys-power/upower-0.9.23 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}