summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-31 15:57:58 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-31 16:49:09 +0100
commita75d20906a6a03e4ae1a7c252eb0a32ac45e03da (patch)
tree143614bc9a9bf776c1f31142e62ca29777cb5bf4
parentdev-python/emoji: Remove old (diff)
downloadgentoo-a75d2090.tar.gz
gentoo-a75d2090.tar.bz2
gentoo-a75d2090.zip
dev-python/emoji: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/emoji/Manifest1
-rw-r--r--dev-python/emoji/emoji-2.2.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/emoji/Manifest b/dev-python/emoji/Manifest
index 18ebf2bc711f..63c0483fcb4a 100644
--- a/dev-python/emoji/Manifest
+++ b/dev-python/emoji/Manifest
@@ -1 +1,2 @@
DIST emoji-2.1.0.gh.tar.gz 265386 BLAKE2B a4928b2d9df30bed461ad184c1fd5eeb8c593fddd26f6704c2f91389645d29699ec53e04bf51b7543ef5afe6b53c1a543925558059e0d31f75bfe2631a6665d6 SHA512 a201ef3e1528b5c3321a923ef35c3014ab6644e790a8aad451c451e810dce7c0bb037bfe572c94badaa0169f289e10184a95a6a9234e36613f95f294e45b7c43
+DIST emoji-2.2.0.gh.tar.gz 293134 BLAKE2B 4f6d8cf297c36a688b7f5e2f4afceb7e55102b23507fcac95799b6a6ab82521c55fcec884dcb2270e8290516942b7ef923de99b4e8da9241ce5828256b991653 SHA512 51150605c7b20fdb9a62746df098995814fb3b5b6c6b79dc65fb35dd8036c95b150b63c6af37f1baaf5dfab521c41ff7d0360864ffa77f696ba2465c50e1da79
diff --git a/dev-python/emoji/emoji-2.2.0.ebuild b/dev-python/emoji/emoji-2.2.0.ebuild
new file mode 100644
index 000000000000..20469a0482c6
--- /dev/null
+++ b/dev-python/emoji/emoji-2.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Emoji for Python"
+HOMEPAGE="
+ https://github.com/carpedm20/emoji/
+ https://pypi.org/project/emoji/
+"
+SRC_URI="
+ https://github.com/carpedm20/emoji/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+distutils_enable_tests pytest