summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-12-10 20:11:15 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-12-10 20:12:38 +0100
commita75d4fc0b832d7df94303c51da2cecb0b0aeee3b (patch)
tree591936b169a28d11eceeafa6cc0be1a185fc6cc6
parentsys-apps/systemd: add 255 (diff)
downloadgentoo-a75d4fc0b832d7df94303c51da2cecb0b0aeee3b.tar.gz
gentoo-a75d4fc0b832d7df94303c51da2cecb0b0aeee3b.tar.bz2
gentoo-a75d4fc0b832d7df94303c51da2cecb0b0aeee3b.zip
sys-apps/systemd: sync live
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 412ecb66e468..a5c20a8b0bde 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -487,6 +487,12 @@ pkg_postinst() {
rm "${EROOT}/var/lib/systemd/timesync"
fi
+ if [[ -z ${ROOT} && -d /run/systemd/system ]]; then
+ ebegin "Reexecuting system manager (systemd)"
+ systemctl daemon-reexec
+ eend $? || FAIL=1
+ fi
+
if [[ ${FAIL} ]]; then
eerror "One of the postinst commands failed. Please check the postinst output"
eerror "for errors. You may need to clean up your system and/or try installing"