summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-08-25 17:07:30 -0400
committerCraig Andrews <candrews@gentoo.org>2020-08-25 17:08:08 -0400
commita762bf47f145488ae284c1601e253320f336fb3d (patch)
treec8aa9b1ade4571ab762f715866663514febfb981
parentdev-util/rocm-cmake: Cleanup old versions (diff)
downloadgentoo-a762bf47.tar.gz
gentoo-a762bf47.tar.bz2
gentoo-a762bf47.zip
dev-libs/rocr-runtime: Remove USE="non-free"
Upstream no longer publishes the dev-libs/hsa-ext-rocr library. ROC has had open-source OpenCL image support since 3.3. Closes: https://bugs.gentoo.org/716930 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--dev-libs/rocr-runtime/metadata.xml3
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-3.7.0.ebuild4
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-9999.ebuild19
3 files changed, 16 insertions, 10 deletions
diff --git a/dev-libs/rocr-runtime/metadata.xml b/dev-libs/rocr-runtime/metadata.xml
index e13e7321708c..d53b83185ad3 100644
--- a/dev-libs/rocr-runtime/metadata.xml
+++ b/dev-libs/rocr-runtime/metadata.xml
@@ -15,7 +15,4 @@
<longdescription lang="en">
Radeon Open Compute Platform Runtime
</longdescription>
- <use>
- <flag name="non-free">Enables HSA image support using <pkg>dev-libs/hsa-ext-rocr</pkg></flag>
- </use>
</pkgmetadata>
diff --git a/dev-libs/rocr-runtime/rocr-runtime-3.7.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-3.7.0.ebuild
index 064969d47e2f..d69d702b2dee 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-3.7.0.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-3.7.0.ebuild
@@ -23,11 +23,9 @@ PATCHES=(
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
-IUSE="non-free"
COMMON_DEPEND="sys-process/numactl"
-RDEPEND="${COMMON_DEPEND}
- non-free? ( dev-libs/hsa-ext-rocr )"
+RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
>=dev-libs/roct-thunk-interface-${PV}
>=dev-libs/rocm-device-libs-${PV}
diff --git a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
index 5ddab400ad03..d69d702b2dee 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
@@ -17,18 +17,29 @@ fi
DESCRIPTION="Radeon Open Compute Runtime"
HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.7.0-cmake-install-paths.patch"
+)
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
-IUSE="non-free"
COMMON_DEPEND="sys-process/numactl"
-RDEPEND="${COMMON_DEPEND}
- non-free? ( dev-libs/hsa-ext-rocr )"
+RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
- >=dev-libs/roct-thunk-interface-${PV}"
+ >=dev-libs/roct-thunk-interface-${PV}
+ >=dev-libs/rocm-device-libs-${PV}
+ app-editors/vim-core"
+ # vim-core is needed for "xxd"
src_prepare() {
sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
+
+ # ... otherwise system llvm/clang is used ...
+ sed -e "s:find_package(Clang REQUIRED HINTS \${CMAKE_INSTALL_PREFIX}/llvm \${CMAKE_PREFIX_PATH}/llvm PATHS /opt/rocm/llvm ):find_package(Clang REQUIRED HINTS /usr/lib/llvm/roc ):" -i image/blit_src/CMakeLists.txt || die
+
+ # Gentoo installs "*.bc" to "/usr/lib" instead of a "[path]/bitcode" directory ...
+ sed -e "s:/opt/rocm/amdgcn/bitcode:/usr/lib:" -i image/blit_src/CMakeLists.txt || die
+
cmake_src_prepare
}