summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-21 10:25:29 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 06:29:01 -0500
commita78643494815566ae1213987a9b129d2b03152a5 (patch)
tree71994ab4a817d0e0b04ec8514388fad9816083b1
parentdev-gap/polenta: new package, add 1.3.10 (diff)
downloadgentoo-a78643494815566ae1213987a9b129d2b03152a5.tar.gz
gentoo-a78643494815566ae1213987a9b129d2b03152a5.tar.bz2
gentoo-a78643494815566ae1213987a9b129d2b03152a5.zip
dev-gap/io: new package, add 4.8.2
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--dev-gap/io/Manifest1
-rw-r--r--dev-gap/io/files/io-4.7.1-headers.patch13
-rw-r--r--dev-gap/io/io-4.8.2.ebuild40
-rw-r--r--dev-gap/io/metadata.xml26
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-gap/io/Manifest b/dev-gap/io/Manifest
new file mode 100644
index 000000000000..305d730f040b
--- /dev/null
+++ b/dev-gap/io/Manifest
@@ -0,0 +1 @@
+DIST io-4.8.2.tar.bz2 587425 BLAKE2B 1c8e9cb398b64823f0cdcaa7be5c81b22ae852ff812e24005e0e4462d6f0880fc9e1fd221e57bc7baa25e14c7bf742a377721f8209c4dfe03a67d5d72b60a603 SHA512 84738ce4e09eeb896b7d2f1f187e90da5ca08dbe8b0066dfa41d425cc989c78fc5c37729fb04a77bdc22e9a692c061be05f8d0719bfc0e0ea94f57987108ba78
diff --git a/dev-gap/io/files/io-4.7.1-headers.patch b/dev-gap/io/files/io-4.7.1-headers.patch
new file mode 100644
index 000000000000..7a7e1d1ff702
--- /dev/null
+++ b/dev-gap/io/files/io-4.7.1-headers.patch
@@ -0,0 +1,13 @@
+diff --git a/src/io.c b/src/io.c
+index 60a21ea..bc2499b 100644
+--- a/src/io.c
++++ b/src/io.c
+@@ -14,7 +14,7 @@
+ #include "compiled.h" // GAP headers
+
+ #if GAP_KERNEL_MAJOR_VERSION >= 6
+-#include "src/profile.h"
++#include "profile.h"
+ #endif
+
+ #undef PACKAGE
diff --git a/dev-gap/io/io-4.8.2.ebuild b/dev-gap/io/io-4.8.2.ebuild
new file mode 100644
index 000000000000..06e9f54c7b67
--- /dev/null
+++ b/dev-gap/io/io-4.8.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools gap-pkg
+
+DESCRIPTION="Bindings for low level C library I/O routines"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND="sci-mathematics/gap:="
+RDEPEND="${DEPEND}"
+
+gap-pkg_enable_tests
+
+src_prepare() {
+ default
+
+ # These tests require network access
+ rm tst/http.g || die
+ sed -e 's/"http.g", //' -i tst/testgap.tst || die
+
+ # Support pathological CFLAGS
+ eautoreconf
+}
+
+src_install() {
+ # There's no install target for the autotools build system
+ gap-pkg_src_install
+
+ if use examples; then
+ docinto examples
+ dodoc example/*
+ fi
+}
diff --git a/dev-gap/io/metadata.xml b/dev-gap/io/metadata.xml
new file mode 100644
index 000000000000..eef2c86430e3
--- /dev/null
+++ b/dev-gap/io/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The IO package, as its name suggests, provides bindings for GAP to
+ the lower levels of Input/Output functionality in the C library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/io</remote-id>
+ </upstream>
+</pkgmetadata>