summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-08 00:20:17 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-08 00:29:42 +0200
commita7b01fb982b71ded49b4367a4082ee00fcb7d297 (patch)
tree9db1170edd8a5f5cddbf76b3231a6a4e3f7c9b97
parentapp-admin/awscli: Bump to 1.19.107 (diff)
downloadgentoo-a7b01fb9.tar.gz
gentoo-a7b01fb9.tar.bz2
gentoo-a7b01fb9.zip
dev-python/requests-mock: Port to py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/requests-mock/requests-mock-1.9.3.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/requests-mock/requests-mock-1.9.3.ebuild b/dev-python/requests-mock/requests-mock-1.9.3.ebuild
index 9d82f5779dac..ecf8e6aa4b5d 100644
--- a/dev-python/requests-mock/requests-mock-1.9.3.ebuild
+++ b/dev-python/requests-mock/requests-mock-1.9.3.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Mock out responses from the requests package"
@@ -30,7 +29,7 @@ BDEPEND="
"
distutils_enable_sphinx doc/source
-distutils_enable_tests unittest
+distutils_enable_tests pytest
python_prepare_all() {
# Disable reno which only works inside a git repository