summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-02 03:40:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-02 04:00:13 +0200
commita7c5e1dabd472ca0d5406414785e1e802c24316d (patch)
treeac991e566cb55237a0c3e93a11fea50fccc9d921
parentdev-python/marshmallow: Remove old (diff)
downloadgentoo-a7c5e1dabd472ca0d5406414785e1e802c24316d.tar.gz
gentoo-a7c5e1dabd472ca0d5406414785e1e802c24316d.tar.bz2
gentoo-a7c5e1dabd472ca0d5406414785e1e802c24316d.zip
dev-python/marshmallow: Bump to 3.21.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.21.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index c010ed9e4898..697bd8b45f51 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
DIST marshmallow-3.21.1.gh.tar.gz 183822 BLAKE2B 786287604312b4c54167458c35caf5ac3eb2c9ce63c1b9bd0b8fc33e208e5f694e84842c75c93fd91535bc231ebf703ea3ea0b352d100b59f103e280b840b170 SHA512 6de06ced6a58ef0c312ee4c1edfbe011401bba08c27fcf2dd2c3e44cb072cded1cf5f16a4d4945344d56f0d26b5eb165f6d031b50c215f122c7cc6fe25389318
+DIST marshmallow-3.21.2.gh.tar.gz 183818 BLAKE2B 01e14514d836c36c9f24a6e0a527271bd17ea5ce1ce35cabb6200a886c85ef970e7d54191307d1580568f05b501ec6028c7f126475ac64c160fec75c247a4c20 SHA512 b151f7e712dc5dd5d7f592942a6a4b09d462b684f542406c8bc57237e4b2402eb287d02e4ca2ef65e10dccb1e200b9ff8ae24f69160af1c6aa02fc5dfdc9eeba
diff --git a/dev-python/marshmallow/marshmallow-3.21.2.ebuild b/dev-python/marshmallow/marshmallow-3.21.2.ebuild
new file mode 100644
index 000000000000..2adebae08366
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.21.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-17.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest