summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-22 16:52:15 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-22 16:52:15 +0200
commita7ef121be2bf04a4a82693e0aa240374f3ff45bc (patch)
treed0d207c037464830e0bba0c073ba7761d53a48e1
parentdev-perl/GD: Remove old (diff)
downloadgentoo-a7ef121be2bf04a4a82693e0aa240374f3ff45bc.tar.gz
gentoo-a7ef121be2bf04a4a82693e0aa240374f3ff45bc.tar.bz2
gentoo-a7ef121be2bf04a4a82693e0aa240374f3ff45bc.zip
www-apache/mod_perl: Fix build with Perl 5.34
Closes: https://bugs.gentoo.org/791403 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.11-perl534.patch17
-rw-r--r--www-apache/mod_perl/mod_perl-2.0.11.ebuild1
2 files changed, 18 insertions, 0 deletions
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.11-perl534.patch b/www-apache/mod_perl/files/mod_perl-2.0.11-perl534.patch
new file mode 100644
index 000000000000..c6c5bed4ed0c
--- /dev/null
+++ b/www-apache/mod_perl/files/mod_perl-2.0.11-perl534.patch
@@ -0,0 +1,17 @@
+
+Fix build for perl >= 5.33.7
+
+Patch by Leon Timmermans <fawaka@gmail.com> from https://github.com/Perl/perl5/issues/18617
+
+
+--- perl/modperl/trunk/src/modules/perl/modperl_perl.c 2021/04/20 13:48:02 1889013
++++ perl/modperl/trunk/src/modules/perl/modperl_perl.c 2021/04/20 13:55:29 1889014
+@@ -268,7 +268,7 @@
+ #ifdef MP_NEED_HASH_SEED_FIXUP
+ if (MP_init_hash_seed_set) {
+ #if MP_PERL_VERSION_AT_LEAST(5, 17, 6)
+- memcpy(&PL_hash_seed, &MP_init_hash_seed,
++ memcpy(PL_hash_seed, &MP_init_hash_seed,
+ sizeof(PL_hash_seed) > sizeof(MP_init_hash_seed) ?
+ sizeof(MP_init_hash_seed) : sizeof(PL_hash_seed));
+ PL_hash_seed_set = MP_init_hash_seed_set;
diff --git a/www-apache/mod_perl/mod_perl-2.0.11.ebuild b/www-apache/mod_perl/mod_perl-2.0.11.ebuild
index 3248c243ac04..77fb5135e3a3 100644
--- a/www-apache/mod_perl/mod_perl-2.0.11.ebuild
+++ b/www-apache/mod_perl/mod_perl-2.0.11.ebuild
@@ -62,6 +62,7 @@ PATCHES=(
"${FILESDIR}/${PN}"-2.0.10_rc1-bundled-Apache-Test.patch # 352724
"${FILESDIR}/${PN}"-2.0.10_rc1-Gentoo-not-Unix.patch
"${FILESDIR}/${PN}"-2.0.11-ranlib.patch # 728554
+ "${FILESDIR}/${PN}"-2.0.11-perl534.patch # 791403
)
src_prepare() {