summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-24 15:58:28 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-24 16:46:56 +0200
commita7f69056bfc282b99f63cfcf3a143993ae66d7e3 (patch)
tree63434d794ced334cf8844f54bde37e5693a9823a
parentdev-perl/Net-SSLeay: libressl support dropped (diff)
downloadgentoo-a7f69056.tar.gz
gentoo-a7f69056.tar.bz2
gentoo-a7f69056.zip
dev-perl/WattsUp-Daemon: EAPI bump, openrc fix, bug 670410
Closes: https://bugs.gentoo.org/670410 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild29
-rw-r--r--dev-perl/WattsUp-Daemon/files/WattsUp-Daemon-0.4-openrc.patch9
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild b/dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild
new file mode 100644
index 000000000000..542ec6f226c2
--- /dev/null
+++ b/dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module
+
+DESCRIPTION="Watt's Up Monitoring Daemon"
+HOMEPAGE="https://dev.gentoo.org/~robbat2/wattsup-daemon/"
+SRC_URI="https://dev.gentoo.org/~robbat2/wattsup-daemon/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+BDEPEND="dev-perl/Device-SerialPort
+ dev-perl/Time-TAI64
+ virtual/perl-Time-HiRes"
+RDEPEND="${BDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-openrc.patch" )
+
+mydoc="AUTHORS doc/wattsup_spec_v442.txt"
+
+src_install() {
+ perl-module_src_install
+ newinitd gentoo/wattsup-daemon.initd wattsup-daemon
+ newconfd gentoo/wattsup-daemon.confd wattsup-daemon
+}
diff --git a/dev-perl/WattsUp-Daemon/files/WattsUp-Daemon-0.4-openrc.patch b/dev-perl/WattsUp-Daemon/files/WattsUp-Daemon-0.4-openrc.patch
new file mode 100644
index 000000000000..6741775c799f
--- /dev/null
+++ b/dev-perl/WattsUp-Daemon/files/WattsUp-Daemon-0.4-openrc.patch
@@ -0,0 +1,9 @@
+diff -ruN WattsUp-Daemon-0.4.orig/gentoo/wattsup-daemon.initd WattsUp-Daemon-0.4/gentoo/wattsup-daemon.initd
+--- WattsUp-Daemon-0.4.orig/gentoo/wattsup-daemon.initd 2007-12-02 09:44:07.000000000 +0100
++++ WattsUp-Daemon-0.4/gentoo/wattsup-daemon.initd 2021-04-24 15:51:40.437424079 +0200
+@@ -1,4 +1,4 @@
+-#!/sbin/runscript
++#!/sbin/openrc-run
+ # Copyright 2007, Robin H. Johnson <robbat2@gentoo.org>
+ # You can use and redistribute WattsUpDaemon under the same terms as Perl itself.
+