summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-01-30 01:37:44 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-01-30 01:39:00 +0100
commita7fa452ea0b84128bd45f820f62f340032bbe299 (patch)
treec44b472d688aa833da7fbc78e3381f64f29d417e
parentsys-process/at: Bump to version 3.2.4 (diff)
downloadgentoo-a7fa452e.tar.gz
gentoo-a7fa452e.tar.bz2
gentoo-a7fa452e.zip
sci-mathematics/easycrypt: fix theories location; bump to EAPI 8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-mathematics/easycrypt/easycrypt-1.0_pre20211210-r2.ebuild (renamed from sci-mathematics/easycrypt/easycrypt-1.0_pre20211210-r1.ebuild)17
1 files changed, 12 insertions, 5 deletions
diff --git a/sci-mathematics/easycrypt/easycrypt-1.0_pre20211210-r1.ebuild b/sci-mathematics/easycrypt/easycrypt-1.0_pre20211210-r2.ebuild
index 17f451552103..ef1279bbd12b 100644
--- a/sci-mathematics/easycrypt/easycrypt-1.0_pre20211210-r1.ebuild
+++ b/sci-mathematics/easycrypt/easycrypt-1.0_pre20211210-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-COMMIT="49aec58ea63a64adcf5fbabcc14c6739f337b206"
+H=49aec58ea63a64adcf5fbabcc14c6739f337b206
inherit dune
@@ -14,8 +14,8 @@ if [[ "${PV}" == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
else
- SRC_URI="https://github.com/EasyCrypt/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${COMMIT}"
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${H}"
fi
LICENSE="CeCILL-B CeCILL-C"
@@ -36,3 +36,10 @@ RDEPEND="
dev-ml/zarith:=
"
DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local theories="[\"$(ocamlc -where)/easycrypt/theories\"]"
+ sed -i "s|EcRelocate\.Sites\.theories|${theories}|g" src/ec.ml || die
+
+ default
+}