summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-26 18:53:59 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-26 18:53:59 +0300
commita7fffadee41bed79003d4228b702e6181bee6d61 (patch)
treee8449c7160763025cf41069795722fc2d488ed5f
parentnet-p2p/deluge: Keyword 2.1.1 arm, #866614 (diff)
downloadgentoo-a7fffade.tar.gz
gentoo-a7fffade.tar.bz2
gentoo-a7fffade.zip
dev-python/setuptools: add 65.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-65.3.0.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index cbbb1ee2436d..7029ff83bd89 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -8,3 +8,4 @@ DIST setuptools-65.0.2.tar.gz 2619562 BLAKE2B e00e6ff7fd18c77c3924151bdbb40b3624
DIST setuptools-65.1.0.tar.gz 2614949 BLAKE2B 89f4556b292afa7b46e558ff059647798a720647287419515cd3717ac37c6511f6ce2976967ceed98d1a34946116ad2fd366ce509b86a8153dc581171ab9c129 SHA512 6b18647b7a8a4c22e3115f233eaf97f7f564badcc31b2e5ee762630bbff3ef7f59397ca05cc4dbce65191f480be43f5e92de79eeaf8de6d32f0a79d88814e7e5
DIST setuptools-65.1.1.tar.gz 2615020 BLAKE2B 1c45d7106e5845b95e6eec52b72749f80f799f1c5695b39e79ae7b49f52c0eab39fba305a7d2cb54a852679479db3c512e562b52a931e6a325d640479e5d4399 SHA512 29ec01558d6f6432c82797313cf12f1b3125c2000d9582e89fff415f59362c44fbfa00340cfbc4f7f4f9898161b3b585058115d1bc5b4bbcdfc0991812f858a8
DIST setuptools-65.2.0.tar.gz 2614890 BLAKE2B a2da0870eaa0d36200dcfcab3fc63ea641d7b8451467ada32e834e94a9d33f84428e517a402d5e64ee999b5b8c2a0fff20044781fa5227ce3e2cc2fcb8f0796a SHA512 84e6e23780e6ef2e0010d4574bebf373f25f6c1e833b4e914f510e2fb3eabdbe1155c8b7d2cfeb93fd59c73fd3ad5b47c7b54e00ffaffa9ea84cf33fa5a6ee69
+DIST setuptools-65.3.0.tar.gz 2615722 BLAKE2B 1344fe17c1c2a4ec60dbf37b3e1cbad56bb5299bed9f8e30a21015f2457e1e90d6782369dfc2d804973e7348d22a356ec0ef75d1aeabba7d77e20e5ddf36e576 SHA512 3c173b1e1a8dbbed0bf3bf600df1256aeabf1b9dec34d5f5d0b1429b0fe16f2aa61fa6c4f400a5b6da24b9d679954866b76e019130bcf2246b138fe017025de9
diff --git a/dev-python/setuptools/setuptools-65.3.0.ebuild b/dev-python/setuptools/setuptools-65.3.0.ebuild
new file mode 100644
index 000000000000..c11a0923e907
--- /dev/null
+++ b/dev-python/setuptools/setuptools-65.3.0.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+# please bump dev-python/ensurepip-setuptools along with this package!
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_TESTED=( python3_{8..11} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="
+ https://github.com/pypa/setuptools/
+ https://pypi.org/project/setuptools/
+"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.4-r2[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-text-3.7.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.12.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/nspektr-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/ordered-set-4.0.2-r1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3-r2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.11.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-5.4.0-r3[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-python/wheel-0.37.1-r1[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/ini2toml-0.9[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-envs-2.2[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-path-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pip-run[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+DOCS=( {CHANGES,README}.rst )
+
+src_prepare() {
+ local PATCHES=(
+ # TODO: remove this when we're 100% PEP517 mode
+ "${FILESDIR}"/setuptools-62.4.0-py-compile.patch
+ )
+
+ # remove bundled dependencies, setuptools will switch to system deps
+ # automatically
+ rm -r */_vendor || die
+
+ # remove the ugly */extern hack that breaks on unvendored deps
+ rm -r */extern || die
+ find -name '*.py' -exec sed \
+ -e 's:from \w*[.]\+extern ::' -e 's:\w*[.]\+extern[.]::' \
+ -i {} + || die
+
+ distutils-r1_src_prepare
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ local -x SETUPTOOLS_USE_DISTUTILS=stdlib
+
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ return
+ fi
+
+ local EPYTEST_DESELECT=(
+ # network
+ # TODO: see if PRE_BUILT_SETUPTOOLS_* helps
+ setuptools/tests/config/test_apply_pyprojecttoml.py::test_apply_pyproject_equivalent_to_setupcfg
+ setuptools/tests/integration/test_pip_install_sdist.py::test_install_sdist
+ setuptools/tests/test_build_meta.py::test_legacy_editable_install
+ setuptools/tests/test_distutils_adoption.py
+ setuptools/tests/test_editable_install.py
+ setuptools/tests/test_setuptools.py::test_its_own_wheel_does_not_contain_tests
+ setuptools/tests/test_virtualenv.py::test_clean_env_install
+ setuptools/tests/test_virtualenv.py::test_no_missing_dependencies
+ setuptools/tests/test_virtualenv.py::test_test_command_install_requirements
+ # TODO
+ setuptools/tests/config/test_setupcfg.py::TestConfigurationReader::test_basic
+ setuptools/tests/config/test_setupcfg.py::TestConfigurationReader::test_ignore_errors
+ setuptools/tests/test_extern.py::test_distribution_picklable
+ # expects bundled deps in virtualenv
+ setuptools/tests/config/test_apply_pyprojecttoml.py::TestMeta::test_example_file_in_sdist
+ setuptools/tests/config/test_apply_pyprojecttoml.py::TestMeta::test_example_file_not_in_wheel
+ setuptools/tests/test_editable_install.py::test_editable_with_pyproject
+ )
+
+ epytest -n "$(makeopts_jobs)" setuptools
+}