summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-10-06 21:16:02 +0200
committerUlrich Müller <ulm@gentoo.org>2023-10-06 21:21:15 +0200
commita80d3ecc77e95ec7bfd6e65cc2e23f6529831e4b (patch)
treed23879b91859658a2eb14b27a17f5fe071ef8799
parentdev-python/msgpack: Stabilize 1.0.5-r1 arm64, #915320 (diff)
downloadgentoo-a80d3ecc.tar.gz
gentoo-a80d3ecc.tar.bz2
gentoo-a80d3ecc.zip
app-emacs/mic-paren: Fix byte-compilation and runtime errors
Update to EAPI 8. Update HOMEPAGE. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-emacs/mic-paren/files/mic-paren-3.15-cl-lib.patch11
-rw-r--r--app-emacs/mic-paren/files/mic-paren-3.15-quoting.patch29
-rw-r--r--app-emacs/mic-paren/mic-paren-3.15-r1.ebuild (renamed from app-emacs/mic-paren/mic-paren-3.15.ebuild)11
3 files changed, 48 insertions, 3 deletions
diff --git a/app-emacs/mic-paren/files/mic-paren-3.15-cl-lib.patch b/app-emacs/mic-paren/files/mic-paren-3.15-cl-lib.patch
new file mode 100644
index 000000000000..a549531d7dc0
--- /dev/null
+++ b/app-emacs/mic-paren/files/mic-paren-3.15-cl-lib.patch
@@ -0,0 +1,11 @@
+--- a/mic-paren.el
++++ b/mic-paren.el
+@@ -332,6 +332,8 @@
+ (defvar mic-paren-version "3.15"
+ "Version of mic-paren.")
+
++(require 'cl-lib)
++
+ ;;; ======================================================================
+ ;; Compatibility stuff
+ ;; BLOB to make custom stuff work even without customize
diff --git a/app-emacs/mic-paren/files/mic-paren-3.15-quoting.patch b/app-emacs/mic-paren/files/mic-paren-3.15-quoting.patch
new file mode 100644
index 000000000000..98b14dfea26e
--- /dev/null
+++ b/app-emacs/mic-paren/files/mic-paren-3.15-quoting.patch
@@ -0,0 +1,29 @@
+--- a/mic-paren.el
++++ b/mic-paren.el
+@@ -619,7 +619,7 @@
+ Do NOT set this variable directly but use
+ `paren-toggle-matching-quoted-paren' to activate/deactivate/toggle this
+ feature! The best method is to do this in a mode hook, e.g.:
+-\(add-hook \'LaTeX-mode-hook
++\(add-hook \\='LaTeX-mode-hook
+ \(function \(lambda \(\)
+ \(paren-toggle-matching-quoted-paren 1\)\)\)\)")
+
+@@ -633,7 +633,7 @@
+ Do NOT set this variable directly but use
+ `paren-toggle-matching-paired-delimiter' to activate/deactivate/toggle
+ this feature! The best method is to do this in a mode hook, e.g.:
+-\(add-hook \'LaTeX-mode-hook
++\(add-hook \\='LaTeX-mode-hook
+ \(function \(lambda \(\)
+ \(paren-toggle-matching-paired-delimiter 1\)\)\)\)")
+
+@@ -666,7 +666,7 @@
+ Do NOT set this variable directly but use `paren-toggle-open-paren-context'
+ to change the value of this option! The best method is to do this in a
+ mode hook, e.g.:
+-\(add-hook \'c-common-mode-hook
++\(add-hook \\='c-common-mode-hook
+ \(function \(lambda \(\)
+ \(paren-toggle-open-paren-context 1\)\)\)\)")
+
diff --git a/app-emacs/mic-paren/mic-paren-3.15.ebuild b/app-emacs/mic-paren/mic-paren-3.15-r1.ebuild
index b596004d84c3..a8c5729299fd 100644
--- a/app-emacs/mic-paren/mic-paren-3.15.ebuild
+++ b/app-emacs/mic-paren/mic-paren-3.15-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit elisp
DESCRIPTION="Advanced highlighting of matching parentheses"
-HOMEPAGE="https://www.gnuvola.org/software/j/mic-paren/
+HOMEPAGE="https://web.archive.org/web/20211016050703/https://www.gnuvola.org/software/j/mic-paren/
https://www.emacswiki.org/emacs/MicParen"
# taken from http://www.gnuvola.org/software/j/mic-paren/mic-paren.el
SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
@@ -15,4 +15,9 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+PATCHES=(
+ "${FILESDIR}"/${P}-quoting.patch
+ "${FILESDIR}"/${P}-cl-lib.patch
+)
+
SITEFILE="50${PN}-gentoo.el"