summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-13 08:56:58 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-13 08:57:34 +1200
commita8285cf91f478a9bb607441961e4dda69b80eb96 (patch)
tree7d5943eefab2eeb024dc28a39fe2cb470a3bc444
parentdev-perl/Mojolicious: Bump to version 7.600.0 (diff)
downloadgentoo-a8285cf91f478a9bb607441961e4dda69b80eb96.tar.gz
gentoo-a8285cf91f478a9bb607441961e4dda69b80eb96.tar.bz2
gentoo-a8285cf91f478a9bb607441961e4dda69b80eb96.zip
dev-perl/Mojolicious: Bump to version 7.700.0
Upstream: - Fix source ordering in content negotation in Mojolicious::Renderer - Fix content negotiation bug in ::Renderer that prevented all sources being considered - Fix source links in documentation browser - Mojolicious::Controller->respond_to improved and Plugin::DefaultHelpers now supports multiple MIME types in requests containing an X-Requested-With header - Fix RFC 7230 handling of "GET //foo/bar HTTP/1.1" in Message::Request - Fix bug in Mojo::Asset::File where forked process could prematurely delete temporary files - Remove Mojo::Cookie::Response 'origin' attribute - Remove deprecated data and remaining methods from Mojo::IOLoop::Delay - Add host_only attribute to Mojo::Cookie::Response - Mojo::Promise resolves with no results if no promises are passed - Add experimental timing->{begin,elapsed,rps,server_timing} helpers to Plugin::DefaultHelpers - Add experiimental Mojo::Headers->server_timing - Added support for new HTTP status code - Fix bug in Mojo::Log where short multi-line messages would not be properly formatted for systemd - Mojo::Log uses native systemd log levels - Add `-u` option to `get` command - Added `dont_use_nlink` option to Mojo::File::list_tree - Fix promise resolution bug in Mojo::Promise - Increase default `upgrade_timeout` from 60 to 180 seconds in Mojo::Server::Hypnotoad Security: - Upstream indicated in the changelog notes for 7.66 that "this contains fixes for security issues", presumably this commit: https://github.com/mojolicious/mojo/commit/c16a56a9d6575ddc53d15e76d58f0ebcb0eeb149 But upstream couldn't even be bothered to state what the security issue was, and reading the code doesn't make it apparent, but my best guess is its related to *adding* support for the host_only bit, which could result in web clients leaking cookies to the wrong domain without it. Some commentary says that "old cookies could be leaked", but I don't see any obvious changes to that effect. Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Mojolicious/Manifest1
-rw-r--r--dev-perl/Mojolicious/Mojolicious-7.700.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Mojolicious/Manifest b/dev-perl/Mojolicious/Manifest
index b1bb95f1c6de..de3392cd06a3 100644
--- a/dev-perl/Mojolicious/Manifest
+++ b/dev-perl/Mojolicious/Manifest
@@ -1,2 +1,3 @@
DIST Mojolicious-7.57.tar.gz 706093 BLAKE2B 13212367fe09a437a97093668558ded1216465b25dd145ecf7e62256f05f129a434164a346bb3e928482fc041acfd68350e9e71ac088c49f679df43221917f73 SHA512 2bb830ca14cda5571a614ad74144c047dd96fafe49b530b1e6e19115c43cc3b8f4f174f549fdb8816183e42f26620fcf36b47f7c05ae592273c74c38dfaa4c0b
DIST Mojolicious-7.60.tar.gz 708129 BLAKE2B bac0f8ac75255ed6d0597cc2d00eeca9da66e9c7548942daf50cca3d24875306a8e19934ae10b2e5b3bd727b1bb531b31a665938c32f861aacba6456fedf7779 SHA512 3e6e0ea266caf8e19546e587ce7bf4d8ef86fa0f2503ef7a1b97b2f4f4f55f9775894d1ad74dd4e84760a3c976f6b94451aa29260f9854d5cc3cefec512428a2
+DIST Mojolicious-7.70.tar.gz 711260 BLAKE2B 0f471c2039b94ad74d60471d879c9993e2dbf16ed23c710c02786ffe6056d613ee4095668d0c34919fc9649815905d4d771cc4adb832ed2b37b3016d6398884e SHA512 2cda5b378d5c1899d78c199c7f1d3439a6fd697ab885bb4d337270256534ec68f9d73267199a6f72e9677049cf9cd6f239451cac31aebcf4743229419a82dd8b
diff --git a/dev-perl/Mojolicious/Mojolicious-7.700.0.ebuild b/dev-perl/Mojolicious/Mojolicious-7.700.0.ebuild
new file mode 100644
index 000000000000..4a7e1449b484
--- /dev/null
+++ b/dev-perl/Mojolicious/Mojolicious-7.700.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SRI
+DIST_VERSION=7.70
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Real-time web framework"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/EV-4.0.0
+ )
+ >=virtual/perl-IO-Socket-IP-0.370.0
+ >=virtual/perl-JSON-PP-2.271.30
+ >=virtual/perl-Pod-Simple-3.90.0
+ >=virtual/perl-Time-Local-1.200.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/pod.t
+ t/pod_coverage.t
+)