summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2023-11-28 14:21:28 +0100
committerAgostino Sarubbo <ago@gentoo.org>2023-11-28 14:21:28 +0100
commita82f277597619087e68d0826b8669a58b71f820c (patch)
tree36fc13ebada06fb7c1103c6991b361a851332233
parentdev-db/pspg: add 5.8.1 (diff)
downloadgentoo-a82f277597619087e68d0826b8669a58b71f820c.tar.gz
gentoo-a82f277597619087e68d0826b8669a58b71f820c.tar.bz2
gentoo-a82f277597619087e68d0826b8669a58b71f820c.zip
app-admin/exo: version bump to 1.75.0
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.75.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index f6477798bc27..2a8189f0cc74 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.74.4.gh.tar.gz 10883511 BLAKE2B 1ef5a5afa1c84e6639a173ab2107c4fa2b78e9ea23c1030a3efa33573db30fdbf3cde123541ba4753bc463f51ab06c7a71200ddab5e37ffda271a1911e89bba0 SHA512 640746bd58617a5de00c6c3bac9429269589e0613d72f33d9a48ece14b34aedf43c92669b3635710322f84cfb3b469d7e426ed0c00c5018517dbe3d2f90b5d0b
+DIST exo-1.75.0.gh.tar.gz 10892978 BLAKE2B 25645735322f64da5aeeb2832ef40b68b0f0c42ca651f630d5a9892846486a1655da21452077998557d56652219bd0516d7d2857e788fea03a0e5401797191fa SHA512 e2661d07bc8117332f3d69213a56ee3e3d1e9fcb2731b5947682c72990b6e5410a406c20856abd4fedbf08970dafd695d006baa94ce5779b4897125899119390
diff --git a/app-admin/exo/exo-1.75.0.ebuild b/app-admin/exo/exo-1.75.0.ebuild
new file mode 100644
index 000000000000..aee98d607c89
--- /dev/null
+++ b/app-admin/exo/exo-1.75.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND=">=dev-lang/go-1.16:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} -ldflags "-X main.version=${PVR}-gentoo -X main.commit=" || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}