summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-07 03:49:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-07 05:14:54 +0200
commita835713aa603f2b855bf5dd3fa1e2afc89a0bb29 (patch)
tree2736f60d0462fbdc1cd7b771a69870eae7565d1d
parentdev-python/boto3: Bump to 1.28.0 (diff)
downloadgentoo-a835713aa603f2b855bf5dd3fa1e2afc89a0bb29.tar.gz
gentoo-a835713aa603f2b855bf5dd3fa1e2afc89a0bb29.tar.bz2
gentoo-a835713aa603f2b855bf5dd3fa1e2afc89a0bb29.zip
app-admin/awscli: Bump to 1.29.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.29.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index df5c93f89391..ceac23c5c83e 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -6,3 +6,4 @@ DIST aws-cli-1.27.164.gh.tar.gz 2441955 BLAKE2B 51a4e88eed1196baa92110c6ad671534
DIST aws-cli-1.27.165.gh.tar.gz 2445911 BLAKE2B 72496a0b5695c78631349b7b6efb4aee7a3681c3683cd567fe904d02d5198366e79146bfd2db373738936c88e2cd97b2e858e45de1e44ec863f386aef865367d SHA512 cde5e9bf6aa2783a0b8c90ae78686bb6a8d5e625e15826f735bcf6e138b112a56df25f4429192ed44fb7cc58e9ea736f7e7fd8ffe8ad0092ead763e3f801a7a0
DIST aws-cli-1.28.0.gh.tar.gz 2445988 BLAKE2B 5c56f908d72cdc10c3e256dd1cc279a202d302cfee0ce860dbefec33ec78aea7afcae37aa699bab6a8644503c9ff0648d0efd60a168f180847f4392e3440658f SHA512 cc3239b7609de0dfa0bb15fea044a9f51151e6c1873c07dc1f0893b0418721eef9b28d1757bc59f7d9e603b865eec406fbe3865e0f31de2f58142ca6768bd1a3
DIST aws-cli-1.28.1.gh.tar.gz 2446244 BLAKE2B b3642736467a629e810bab4998f797e12845427344689ca8bbe8e2e5e362debc71d2496dfb9ad9e0de1d0e018744e9e13268b6f203040475ef97b77fb99fbf1b SHA512 ab668d09979e5bb1ddec9862227d08c607ddfcac417fe298ac214caf492bcee678291132117925e0e229d10bf4b820c2acc3c335e5b0b9474151ad3233117668
+DIST aws-cli-1.29.0.gh.tar.gz 2449423 BLAKE2B 52948b35f391266c38a197d4fa20926c428def190a5821a64b33fe9939b5a30a252fd546a3f1f54056901ed9fe75e7d030d65ca40508658581a4246ad6ec1635 SHA512 5c1b31d2b5c9721b2b27ef21fbd58c74c70fce35122e1de4b1483b8bd6766f2b2b27c288aa1a3d91f1d37decdaa937823b4149f9b1d49acd4404477ee8f9dfd6
diff --git a/app-admin/awscli/awscli-1.29.0.ebuild b/app-admin/awscli/awscli-1.29.0.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.29.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}