summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-19 08:32:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-19 08:42:13 +0300
commita839770bccaadb7af70a4582d7163684b7288f41 (patch)
tree4860eab94bb4304737abf4ee6547b221fc0d8a06
parentsys-cluster/sanlock: add 3.8.4, enable py3.9, enable py3.10 (diff)
downloadgentoo-a839770bccaadb7af70a4582d7163684b7288f41.tar.gz
gentoo-a839770bccaadb7af70a4582d7163684b7288f41.tar.bz2
gentoo-a839770bccaadb7af70a4582d7163684b7288f41.zip
dev-python/pytz_deprecation_shim: new package (rdep of dev-python/tzlocal)
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pytz_deprecation_shim/Manifest1
-rw-r--r--dev-python/pytz_deprecation_shim/metadata.xml13
-rw-r--r--dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild37
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pytz_deprecation_shim/Manifest b/dev-python/pytz_deprecation_shim/Manifest
new file mode 100644
index 000000000000..6d44d53e6408
--- /dev/null
+++ b/dev-python/pytz_deprecation_shim/Manifest
@@ -0,0 +1 @@
+DIST pytz_deprecation_shim-0.1.0.post0.tar.gz 60190 BLAKE2B a6d186ca6fff17a3fb787ad6164fcf45fbac272e6123491a6822699cf54a115c9941f2b1ee3d227f531a0ab1d11846300dc24974611cc1671c77405606704754 SHA512 201eea777f4da9def1b060911da5eaa89652f6716d5608278fdc94a2f67af5ea23a8b667cb181e03d5edd7f0a07f4954047621668f4c2e7bb325dd07f454d0b6
diff --git a/dev-python/pytz_deprecation_shim/metadata.xml b/dev-python/pytz_deprecation_shim/metadata.xml
new file mode 100644
index 000000000000..12126b02ffe2
--- /dev/null
+++ b/dev-python/pytz_deprecation_shim/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytz-deprecation-shim</remote-id>
+ <remote-id type="github">pganssle/pytz-deprecation-shim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild b/dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild
new file mode 100644
index 000000000000..28c95ccfeac2
--- /dev/null
+++ b/dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+
+DESCRIPTION="Shims to make deprecation of pytz easier"
+HOMEPAGE="https://pypi.org/project/pytz-deprecation-shim/ https://github.com/pganssle/pytz-deprecation-shim"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytzdata[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' python3_8 pypy3)
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme