summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-05-18 19:23:06 +0200
committerHans de Graaff <graaff@gentoo.org>2024-05-18 19:23:36 +0200
commita846b9c412c9c112579a81c85ccb6d1094ddb75d (patch)
tree9b95c73fd6ea787094104e5ae7c57c8faeba7da9
parentwww-apache/passenger: drop 6.0.18, 6.0.19 (diff)
downloadgentoo-a846b9c412c9c112579a81c85ccb6d1094ddb75d.tar.gz
gentoo-a846b9c412c9c112579a81c85ccb6d1094ddb75d.tar.bz2
gentoo-a846b9c412c9c112579a81c85ccb6d1094ddb75d.zip
www-apache/passenger: add 6.0.21
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--www-apache/passenger/Manifest1
-rw-r--r--www-apache/passenger/passenger-6.0.21.ebuild128
2 files changed, 129 insertions, 0 deletions
diff --git a/www-apache/passenger/Manifest b/www-apache/passenger/Manifest
index 11f686b2a0c9..13fc3a7245ac 100644
--- a/www-apache/passenger/Manifest
+++ b/www-apache/passenger/Manifest
@@ -1 +1,2 @@
DIST passenger-6.0.20.tar.gz 8476308 BLAKE2B dc1ac3a1e2be1a9138594d68cf23fc0a73b6b0aca0550c022de56bc156825b3627de741128f163871c89747f178fb26fc41533962ba83ef2659ca71793c0fa62 SHA512 b46864cd7fa83fe39a2a4f42d581660c9a521b96942604b56caa567adff272bb092e82a46a6817a7b68be4830ad1015c9af4429a6d5b26edfe9c3e3884046559
+DIST passenger-6.0.21.tar.gz 8296486 BLAKE2B fd9a0c83a7b018234016521162a1cada38a6d2f9e314ceb77ae39b60b1581dc053034aed4df64696348478fbb6985ef0fc752c3b4a1d8c2b1f058262e97bf8d3 SHA512 f74c877485f5b0821934734b460f2f4823e6fbd6ca8f55a12f6095a00db3e03d2ddbed9f2e9455170346928b887d3887b444d18c251a8578853ee8b57a12e5dd
diff --git a/www-apache/passenger/passenger-6.0.21.ebuild b/www-apache/passenger/passenger-6.0.21.ebuild
new file mode 100644
index 000000000000..0c0ad6d0d23f
--- /dev/null
+++ b/www-apache/passenger/passenger-6.0.21.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+inherit apache-module flag-o-matic ruby-ng toolchain-funcs
+
+DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
+HOMEPAGE="https://www.phusionpassenger.com/"
+SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
+
+# Passenger is licensed MIT, but vendored code licenses should also be taken into account.
+LICENSE="Boost-1.0 MIT BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="apache2 debug"
+
+ruby_add_bdepend "dev-ruby/rake"
+
+ruby_add_rdepend "
+ >=dev-ruby/rack-1.0.0:*
+ >=dev-ruby/rake-0.8.1"
+
+# libev is bundled but with adapations that do not seem to be accepted
+# upstream, so we must use the bundled version :-(
+CDEPEND="
+ >=dev-libs/libuv-1.8.0
+ net-misc/curl[ssl]
+ apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
+
+RDEPEND="${RDEPEND} ${CDEPEND}"
+DEPEND="${DEPEND} ${CDEPEND}"
+
+APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
+APACHE2_MOD_DEFINE="PASSENGER"
+
+want_apache2
+
+pkg_setup() {
+ use debug && append-flags -DPASSENGER_DEBUG
+ depend.apache_pkg_setup
+}
+
+all_ruby_prepare() {
+ eapply "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
+
+ # Change these with sed instead of a patch so that we can easily use
+ # the toolchain-funcs methods.
+ sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
+ -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
+ -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
+
+ # Avoid fixed debugging CFLAGs.
+ sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
+
+ # Use sed here so that we can dynamically set the documentation directory.
+ sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
+ -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
+ src/ruby_supportlib/phusion_passenger.rb || die
+ sed -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
+ -i src/cxx_supportlib/ResourceLocator.h || die
+
+ # Don't install a tool that won't work in our setup.
+ sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
+ rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
+
+ # Make sure we use the system-provided version where possible
+ rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
+
+ # Fix hard-coded use of AR
+ sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
+
+ # Make sure apache support is not attempted with -apache2
+ if ! use apache2 ; then
+ sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
+ fi
+}
+
+all_ruby_compile() {
+ if use apache2 ; then
+ V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
+ APXS2="${APXS}" \
+ HTTPD="${APACHE_BIN}" \
+ FS_LIBDIR='/usr/'$(get_libdir) \
+ USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+ RANLIB=$(tc-getRANLIB) \
+ ruby -S rake apache2 || die "rake failed"
+ fi
+}
+
+each_ruby_compile() {
+ append-flags -fno-strict-aliasing
+
+ V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
+ APXS2="${APXS}" \
+ HTTPD="${APACHE_BIN}" \
+ FS_LIBDIR='/usr/'$(get_libdir) \
+ USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+ RANLIB=$(tc-getRANLIB) \
+ ${RUBY} -S rake native_support || die "rake failed"
+}
+
+all_ruby_install() {
+ if use apache2 ; then
+ APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
+ apache-module_src_install
+
+ # Patch in the correct libdir
+ sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
+ fi
+
+ dodoc CHANGELOG README.md doc/*.md
+}
+
+each_ruby_install() {
+ DISTDIR="${D}" \
+ RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
+ RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
+ APXS2="${APXS}" \
+ HTTPD="${APACHE_BIN}" \
+ FS_DOCDIR="/usr/share/doc/${P}" \
+ FS_LIBDIR='/usr/'$(get_libdir) \
+ EXTRA_LDFLAGS="${LDFLAGS}" \
+ USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+ RANLIB=$(tc-getRANLIB) \
+ ${RUBY} -S rake fakeroot || die "rake failed"
+}