summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-12-27 13:12:54 -0700
committerTim Harder <radhermit@gentoo.org>2019-12-27 13:15:06 -0700
commita84b0cb20d1d7e3dda9aba80f94034cdac8601b1 (patch)
tree9adb8df33a35626cad31d3ede5862b3461f38511
parentdev-util/icmake: version bump to 9.02.09 (diff)
downloadgentoo-a84b0cb20d1d7e3dda9aba80f94034cdac8601b1.tar.gz
gentoo-a84b0cb20d1d7e3dda9aba80f94034cdac8601b1.tar.bz2
gentoo-a84b0cb20d1d7e3dda9aba80f94034cdac8601b1.zip
app-text/yodl: version bump to 4.02.02
Closes: https://bugs.gentoo.org/652868 Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--app-text/yodl/Manifest1
-rw-r--r--app-text/yodl/yodl-4.02.02.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-text/yodl/Manifest b/app-text/yodl/Manifest
index 685959f21fbb..d69fcab190ed 100644
--- a/app-text/yodl/Manifest
+++ b/app-text/yodl/Manifest
@@ -1 +1,2 @@
DIST yodl-4.02.01.tar.gz 308670 BLAKE2B f94c094f17ec99e66f64a704e41814274f61128ff21b11077d772874dcbc9f15fbc878df8831e7f73d9b6c89a497462c694bc0bdb6cd5637c0db08303e3838d5 SHA512 59e23bb173786b8806f56bf302dee9d8d971d0d840c609e2b24d9783b5866fca2509be844616318f9a4f302117b3a41f620be5cba09181e7ccdcf0c141402be7
+DIST yodl-4.02.02.tar.gz 309075 BLAKE2B ce9da287ca59e20319ae8a132553b669ffff926c79e7ffbf7891af3e777c45815cbd784eaf8d706b7f4b8240ceac41c38882c7b5d2b51e2691da249b0f5be43b SHA512 531b5b61f85ed556163b0cf76a30451212849e5e03e11819cc466603db0856737a9d3bc34ba11419befd7925ec1bac33f92b707c38acd2fa8047e3e1223d0a78
diff --git a/app-text/yodl/yodl-4.02.02.ebuild b/app-text/yodl/yodl-4.02.02.ebuild
new file mode 100644
index 000000000000..25f75b909934
--- /dev/null
+++ b/app-text/yodl/yodl-4.02.02.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Your Own Document Language: a pre-document language and tools to process it"
+HOMEPAGE="https://fbb-git.gitlab.io/yodl/ https://gitlab.com/fbb-git/yodl"
+SRC_URI="https://gitlab.com/fbb-git/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-util/icmake-8.00.00"
+
+S=${WORKDIR}/${P}/${PN}
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]]; then
+ if tc-is-gcc && [[ $(gcc-major-version) -lt 8 ]]; then
+ die "Your compiler doesn't fully support C++17. Use GCC 8 or newer."
+ elif tc-is-clang && [[ $(clang-major-version) -lt 6 ]]; then
+ die "Your compiler doesn't fully support C++17. Use Clang 6 or newer."
+ fi
+ fi
+}
+
+src_prepare() {
+ sed -e "/DOC.* =/s/yodl\(-doc\)\?/${PF}/" \
+ -e "/COMPILER =/s/gcc/$(tc-getCC)/" \
+ -e "/CXX =/s/g++/$(tc-getCXX)/" \
+ -i INSTALL.im || die
+
+ sed -e "s/g++/$(tc-getCXX)/" \
+ -e "s:#define CLS://\0:" \
+ -i verbinsert/icmconf || die
+
+ sed -e "s/ar r /$(tc-getAR) r /" \
+ -e "s/ranlib/$(tc-getRANLIB)/" \
+ -i icmake/stdcompile || die
+
+ # required for std::filesystem usage
+ append-cxxflags -std=c++17
+
+ default
+}
+
+src_compile() {
+ ./build programs || die
+ ./build macros || die
+ ./build man || die
+ use doc && { ./build manual || die ; }
+}
+
+src_install() {
+ ./build install programs "${ED}" || die
+ ./build install macros "${ED}" || die
+ ./build install man "${ED}" || die
+ ./build install docs "${ED}" || die
+ use doc && { ./build install manual "${ED}" || die ; }
+}