summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-10-05 16:39:04 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-10-07 11:11:13 -0700
commita8642c7c9c94f90f82049ddbb895547105dad550 (patch)
tree2c2b186fa8971b6ae6ef539ec84b3343f4687d51
parentdev-python/xdis: New package, dep of dev-python/uncompyle6 (diff)
downloadgentoo-a8642c7c9c94f90f82049ddbb895547105dad550.tar.gz
gentoo-a8642c7c9c94f90f82049ddbb895547105dad550.tar.bz2
gentoo-a8642c7c9c94f90f82049ddbb895547105dad550.zip
dev-python/uncompyle6: New package, new dep for dev-python/hypothesis-3.5.*
Package-Manager: portage-2.3.1_p8
-rw-r--r--dev-python/uncompyle6/Manifest1
-rw-r--r--dev-python/uncompyle6/metadata.xml20
-rw-r--r--dev-python/uncompyle6/uncompyle6-2.8.3.ebuild38
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/uncompyle6/Manifest b/dev-python/uncompyle6/Manifest
new file mode 100644
index 000000000000..39f2884551a8
--- /dev/null
+++ b/dev-python/uncompyle6/Manifest
@@ -0,0 +1 @@
+DIST uncompyle6-2.8.3.tar.gz 504536 SHA256 213a5742d89d528e539121ab68b8d897a9fc60997ec30f6ec0764b6ca2d4a543 SHA512 635983a945a05f649d0f78191c59f6d1f0a7c922ad3bc8fc53396514a4cd133cdef228bac3189cd04d0c2104fb5da128f0ad8f868f6cfdd0bf3a0d52e08e773d WHIRLPOOL 93b1085e1b92e6dbfad39f27094636303d022298ee17460ea0f95d3338c6f0f1c03c6a0584d4805375c491e21fa7ca8e8b709532e6d9d1973d9a0b323734441b
diff --git a/dev-python/uncompyle6/metadata.xml b/dev-python/uncompyle6/metadata.xml
new file mode 100644
index 000000000000..14eb52ab65ea
--- /dev/null
+++ b/dev-python/uncompyle6/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dol-sen@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>rb@dustyfeet.com</email>
+ <name>Rocky Bernstein</name>
+ </maintainer>
+ <remote-id type="pypi">PyQRCode</remote-id>
+ </upstream>
+ <longdescription></longdescription>
+</pkgmetadata>
diff --git a/dev-python/uncompyle6/uncompyle6-2.8.3.ebuild b/dev-python/uncompyle6/uncompyle6-2.8.3.ebuild
new file mode 100644
index 000000000000..1fdfe44f5ee9
--- /dev/null
+++ b/dev-python/uncompyle6/uncompyle6-2.8.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python cross-version byte-code deparser"
+HOMEPAGE="https://github.com/rocky/python-uncompyle6/ https://pypi.python.org/pypi/umcompyle6"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/xdis-2.3.0
+ >=dev-python/spark-parser-1.4.0"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+# Tests are somewhat sketchy...
+# the main repo has makefiles and commands that don't reflect the actual
+# available options for the commands they are giving.
+# This test does not produce errors, but also does not seem to update the
+# files ok, failed,... just the # of files tested
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ ${EPYTHON} test/test_pyenvlib.py --verify --all || die \
+ "Tests failed under ${EPYTHON}"
+}