summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-02 01:38:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-02 01:43:06 +0200
commita86c332a81f3a88a1a5449600c031e0e1ec9e745 (patch)
tree11e321a5d75225728d5f7dee45dc6abcbdfc4e26
parentapp-text/libmspub: EAPI-7 bump, consolidate live build switch (diff)
downloadgentoo-a86c332a.tar.gz
gentoo-a86c332a.tar.bz2
gentoo-a86c332a.zip
media-libs/libfreehand: EAPI-7 bump, consolidate live build switch
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/libfreehand/libfreehand-9999.ebuild37
1 files changed, 21 insertions, 16 deletions
diff --git a/media-libs/libfreehand/libfreehand-9999.ebuild b/media-libs/libfreehand/libfreehand-9999.ebuild
index be281349087b..b0b78cb0249e 100644
--- a/media-libs/libfreehand/libfreehand-9999.ebuild
+++ b/media-libs/libfreehand/libfreehand-9999.ebuild
@@ -1,23 +1,28 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libfreehand.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
-
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libfreehand.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libfreehand/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
DESCRIPTION="Library for import of FreeHand drawings"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand"
-[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libfreehand/${P}.tar.xz"
LICENSE="MPL-2.0"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="doc static-libs test"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
RDEPEND="
dev-libs/librevenge
sys-libs/zlib
@@ -28,29 +33,29 @@ DEPEND="${RDEPEND}
dev-util/gperf
media-libs/lcms
sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
test? ( dev-util/cppunit )
"
src_prepare() {
default
[[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == 9999 ]] && eautoreconf
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
# bug 619762
append-cxxflags -std=c++14
- econf \
- --disable-werror \
- $(use_with doc docs) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable static-libs static)
$(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}