summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-01 08:22:57 +0000
committerSam James <sam@gentoo.org>2021-11-01 08:22:57 +0000
commita8a732b0d50fc74bdca9dc75e804e43369cb9e34 (patch)
treec83cd678a338a4dc92ebdd7f65176348dad1d80c
parentvirtual/dist-kernel: stabilize 5.10.76 for ppc64 (diff)
downloadgentoo-a8a732b0.tar.gz
gentoo-a8a732b0.tar.bz2
gentoo-a8a732b0.zip
net-libs/libtorrent-rasterbar: conditionally apply test patch
Closes: https://bugs.gentoo.org/821172 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r4.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r4.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r4.ebuild
index 69145fe1177c..4d585c2e540c 100644
--- a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r4.ebuild
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r4.ebuild
@@ -45,13 +45,18 @@ PATCHES=(
"${FILESDIR}"/${P}-boost-1.77.patch
"${FILESDIR}"/${P}-python-symbols.patch
"${FILESDIR}"/${PN}-2.0.4-asio-ssl-error.patch
- "${WORKDIR}"/${P}-ssl-tests-certs.patch
)
pkg_setup() {
use python && python-single-r1_pkg_setup
}
+src_prepare() {
+ use test && eapply "${WORKDIR}"/${P}-ssl-tests-certs.patch
+
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DCMAKE_CXX_STANDARD=14