summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:06:05 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:14 +0100
commita8a8db9c8e17c10aaf031e94b21cba365f992655 (patch)
tree177cc4a98b82736e203fc80acfe0161713206c84
parentdev-haskell/assoc: Migrate to CABAL_CHDEPS (v1.0.2) (diff)
downloadgentoo-a8a8db9c8e17c10aaf031e94b21cba365f992655.tar.gz
gentoo-a8a8db9c8e17c10aaf031e94b21cba365f992655.tar.bz2
gentoo-a8a8db9c8e17c10aaf031e94b21cba365f992655.zip
dev-haskell/async: Hackage revision bump
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/async/Manifest2
-rw-r--r--dev-haskell/async/async-2.2.4-r1.ebuild37
-rw-r--r--dev-haskell/async/async-2.2.4.ebuild48
-rw-r--r--dev-haskell/async/metadata.xml45
4 files changed, 40 insertions, 92 deletions
diff --git a/dev-haskell/async/Manifest b/dev-haskell/async/Manifest
index 985278d315c7..55c58a488c27 100644
--- a/dev-haskell/async/Manifest
+++ b/dev-haskell/async/Manifest
@@ -1,2 +1,2 @@
-DIST async-2.2.4.cabal 3095 BLAKE2B cb0491c2fa792c794308485031c8cb876b596f37f06bc53eb824eb09d83f539d315b1e5a49478fef5282609ab755c22442051684dda79e94dc02bca7cb2c5824 SHA512 a19d1ce77902377fe6afc24c10002ef539d21fb402cf245e0816a67086c2a13b0b2e7b984e054a6b846f2acbcbd0fd942819e381e8ff29ba995757cbf8d8aa8f
+DIST async-2.2.4-rev3.cabal 3112 BLAKE2B f6ba4c03655f37c60e45a5033b7d5a5c229e7db42544e9a960068d9c8852b1731f9907f7df2e554b3e461e1aba49cc8569eb74dda34b7b7874959165c3e86d05 SHA512 607f99484695767eb69b8650247cc6ca9a9d5e74eafa81d42dc01aa735dd2e6eec3021fbc232cafc4573e630f981ab31e090c6de04b99e2f0d450ea664dca3ea
DIST async-2.2.4.tar.gz 14148 BLAKE2B c47e47a4bbe98d05bdd6b8ad89888013643f36ea5ede8af306b98749cec3cf9c3e87330339af4152cf7e84f5b9ced39c1eb69079921d4c0b7c993191bc052c2d SHA512 24f37f974dd7573138475d04c0fccb97fcbd8b3de56f7d06199b8f936fd9a29cd0ba0574212a753a81de8958b3292ecee79d0e8d0d2f51eb91874424e6219569
diff --git a/dev-haskell/async/async-2.2.4-r1.ebuild b/dev-haskell/async/async-2.2.4-r1.ebuild
new file mode 100644
index 000000000000..2b522272e173
--- /dev/null
+++ b/dev-haskell/async/async-2.2.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+#hackport: flags: -bench
+
+CABAL_HACKAGE_REVISION=3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/simonmar/async"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/hashable-1.1.2.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ dev-haskell/hunit
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bench
+}
diff --git a/dev-haskell/async/async-2.2.4.ebuild b/dev-haskell/async/async-2.2.4.ebuild
deleted file mode 100644
index ef5fdcf7a9fd..000000000000
--- a/dev-haskell/async/async-2.2.4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.7.1.1.9999
-#hackport: flags: -bench
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-CABAL_HACKAGE_REVISION="1"
-inherit haskell-cabal
-
-DESCRIPTION="Run IO operations asynchronously and wait for their results"
-HOMEPAGE="https://github.com/simonmar/async"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
- https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal -> ${PF}.cabal"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-
-RDEPEND=">=dev-haskell/hashable-1.1.2.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
- >=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-2.6:=[profile?]
- >=dev-lang/ghc-8.4.3:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2.0.1
- test? ( dev-haskell/hunit
- dev-haskell/test-framework
- dev-haskell/test-framework-hunit )
-"
-BDEPEND="app-text/dos2unix"
-
-src_prepare() {
- # pull revised cabal from upstream
- cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
-
- # Convert to unix line endings
- dos2unix "${S}/${PN}.cabal" || die
-
- # Apply patches *after* pulling the revised cabal
- default
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-bench
-}
diff --git a/dev-haskell/async/metadata.xml b/dev-haskell/async/metadata.xml
index e34a2487ed0f..fadb019c43bb 100644
--- a/dev-haskell/async/metadata.xml
+++ b/dev-haskell/async/metadata.xml
@@ -3,51 +3,10 @@
<pkgmetadata>
<maintainer type="project">
<email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This package provides a higher-level interface over
- threads, in which an @Async a@ is a concurrent
- thread that will eventually deliver a value of
- type @a@. The package provides ways to create
- @Async@ computations, wait for their results, and
- cancel them.
-
- Using @Async@ is safer than using threads in two
- ways:
-
- * When waiting for a thread to return a result,
- if the thread dies with an exception then the
- caller must either re-throw the exception
- ('wait') or handle it ('waitCatch'); the
- exception cannot be ignored.
-
- * The API makes it possible to build a tree of
- threads that are automatically killed when
- their parent dies (see 'withAsync').
-
- Changes in 2.0.1.3:
-
- * Bump @base@ dependency to allow 4.6
-
- Changes in 2.0.1.2:
-
- * Bump @stm@ dependency to 2.4
-
- Changes in 2.0.1.1:
-
- * Safe Haskell support: @Control.Concurrent.Async@ is now @Trustworthy@
-
- Changes in 2.0.1.0:
-
- * Added a @Functor@ instance for @Async@
-
- * Added @asyncBound@, @asyncOn@, @asyncWithUnmask@, @asyncOnWithUnmask@, @withAsyncBound@, @withAsyncOn@, @withAsyncWithUnmask@, @withAsyncOnWithUnmask@.
-
- * Added @mapConcurrently@
-
- * Added @Concurrently@ (with @Applicative@ and @Alternative@ instances)
- </longdescription>
<upstream>
+ <remote-id type="hackage">async</remote-id>
<remote-id type="github">simonmar/async</remote-id>
</upstream>
</pkgmetadata>