summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-02 08:55:39 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-02 09:07:01 +0100
commita8be962e4749c08eb050195fc8488ed485e07d6a (patch)
treeec1351d1a1313168944299055fd642f31ff41a18
parentdev-python/argon2_cffi: Use distutils_enable_tests (diff)
downloadgentoo-a8be962e4749c08eb050195fc8488ed485e07d6a.tar.gz
gentoo-a8be962e4749c08eb050195fc8488ed485e07d6a.tar.bz2
gentoo-a8be962e4749c08eb050195fc8488ed485e07d6a.zip
dev-python/argon2_cffi: Use distutils_enable_sphinx
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/argon2_cffi/argon2_cffi-19.1.0.ebuild12
1 files changed, 1 insertions, 11 deletions
diff --git a/dev-python/argon2_cffi/argon2_cffi-19.1.0.ebuild b/dev-python/argon2_cffi/argon2_cffi-19.1.0.ebuild
index da5d18a898c0..76b849d3d56c 100644
--- a/dev-python/argon2_cffi/argon2_cffi-19.1.0.ebuild
+++ b/dev-python/argon2_cffi/argon2_cffi-19.1.0.ebuild
@@ -13,7 +13,6 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc"
COMMON_DEPEND="
~app-crypt/argon2-20171227:=
@@ -24,7 +23,6 @@ COMMON_DEPEND="
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
dev-python/hypothesis[${PYTHON_USEDEP}]
)
@@ -32,17 +30,9 @@ DEPEND="${COMMON_DEPEND}
DOCS=( AUTHORS.rst CHANGELOG.rst FAQ.rst README.rst )
+distutils_enable_sphinx docs
distutils_enable_tests pytest
python_configure_all() {
export ARGON2_CFFI_USE_SYSTEM=1
}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}