summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-11-29 21:29:47 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-11-29 21:44:23 +0100
commita8c215033b6e22bb7bf151f1d1026071459a4c35 (patch)
tree98e0d2f62c85f3187a82ddf4a26b48ddabbba070
parentdev-python/pylint: add 2.15.7 (diff)
downloadgentoo-a8c21503.tar.gz
gentoo-a8c21503.tar.bz2
gentoo-a8c21503.zip
sci-mathematics/mathlib-tools: bump to 1.3.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-mathematics/mathlib-tools/Manifest1
-rw-r--r--sci-mathematics/mathlib-tools/mathlib-tools-1.3.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-mathematics/mathlib-tools/Manifest b/sci-mathematics/mathlib-tools/Manifest
index 19758219dc4b..0311ca178453 100644
--- a/sci-mathematics/mathlib-tools/Manifest
+++ b/sci-mathematics/mathlib-tools/Manifest
@@ -1,2 +1,3 @@
DIST mathlib-tools-1.2.0.tar.gz 33995 BLAKE2B ce1125fa786daa6292556e35dd596dfc819eab739f1dac65de4eb966873d86ab779e61372694da281123d64c36b1978afa359e2bb154cbf39cfa0f1677b5f0f6 SHA512 3691ef89ec0325d223ab56f6b09d0fd729d006a3ce6aa338e814b1cb3d014e670da6c16a52233ceb1c1dbd6f027c769f1adedfe53cbccc4be73803abf4475ae0
DIST mathlib-tools-1.3.0.tar.gz 34918 BLAKE2B 4d54922cfe5de3d6671161081c49fe82568ad90795ece8ad43e9f62c75415204e62ff1822be213ab259371e82ea869ff63195056cc415a1f376fa0a4a438fb4f SHA512 250390e55170e5a7520f34dee27c9846351a64c4157e9f4a0ec1d0d9bf6b075b09187476375a90e7df2fdab6ce7b7b51ff03f1bf28007915242811f377ce3150
+DIST mathlib-tools-1.3.1.tar.gz 34918 BLAKE2B 4d54922cfe5de3d6671161081c49fe82568ad90795ece8ad43e9f62c75415204e62ff1822be213ab259371e82ea869ff63195056cc415a1f376fa0a4a438fb4f SHA512 250390e55170e5a7520f34dee27c9846351a64c4157e9f4a0ec1d0d9bf6b075b09187476375a90e7df2fdab6ce7b7b51ff03f1bf28007915242811f377ce3150
diff --git a/sci-mathematics/mathlib-tools/mathlib-tools-1.3.1.ebuild b/sci-mathematics/mathlib-tools/mathlib-tools-1.3.1.ebuild
new file mode 100644
index 000000000000..b9439cb1bcca
--- /dev/null
+++ b/sci-mathematics/mathlib-tools/mathlib-tools-1.3.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Development tools for Lean's mathlib"
+HOMEPAGE="https://github.com/leanprover-community/mathlib-tools"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/${PN}.git"
+else
+ H=1ce2e7143b2456867f4a671a078a4e9af3c73c11
+ SRC_URI="https://github.com/leanprover-community/${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${H}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND="
+ >=dev-python/GitPython-2.1.11[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.0[${PYTHON_USEDEP}]
+ dev-python/PyGithub[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${BDEPEND}
+ sci-mathematics/lean:0/3
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Remove problematic tests (mainly issues with network)
+ rm ./tests/test_functional.py || die
+
+ distutils-r1_python_prepare_all
+}