summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-10 06:51:31 +0100
committerSam James <sam@gentoo.org>2021-09-10 06:52:22 +0100
commita8c2c6280ec83612c914a212734db234e90cef6f (patch)
tree3bc6d69959f8134daf281ea033222e97d6d170ea
parentdev-ruby/httparty: add 0.19.0 (diff)
downloadgentoo-a8c2c628.tar.gz
gentoo-a8c2c628.tar.bz2
gentoo-a8c2c628.zip
sys-devel/autoconf-archive: backport upstream patches
Both pretty critical: - Revert broken AX_PTHREAD change which leads to unnecessary/incorrect changes in downstream configure.acs. - Python 3.10+ fixes Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/autoconf-archive/autoconf-archive-2021.02.19-r1.ebuild21
-rw-r--r--sys-devel/autoconf-archive/files/autoconf-archive-2021.02.19-python310.patch36
-rw-r--r--sys-devel/autoconf-archive/files/autoconf-archive-2021.02.19-revert-ax_pthreads.patch70
3 files changed, 127 insertions, 0 deletions
diff --git a/sys-devel/autoconf-archive/autoconf-archive-2021.02.19-r1.ebuild b/sys-devel/autoconf-archive/autoconf-archive-2021.02.19-r1.ebuild
new file mode 100644
index 000000000000..d9ba9d3bedf3
--- /dev/null
+++ b/sys-devel/autoconf-archive/autoconf-archive-2021.02.19-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="GNU Autoconf Macro Archive"
+HOMEPAGE="https://www.gnu.org/software/autoconf-archive/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# File collisions. #540246
+RDEPEND="!=gnome-base/gnome-common-3.14.0-r0
+ !>=gnome-base/gnome-common-3.14.0-r1[-autoconf-archive(+)]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2021.02.19-python310.patch
+ "${FILESDIR}"/${PN}-2021.02.19-revert-ax_pthreads.patch
+)
diff --git a/sys-devel/autoconf-archive/files/autoconf-archive-2021.02.19-python310.patch b/sys-devel/autoconf-archive/files/autoconf-archive-2021.02.19-python310.patch
new file mode 100644
index 000000000000..d76605eb5c1d
--- /dev/null
+++ b/sys-devel/autoconf-archive/files/autoconf-archive-2021.02.19-python310.patch
@@ -0,0 +1,36 @@
+Ensure configure tests don't fail with Python 3.10, 3.11.
+
+https://github.com/autoconf-archive/autoconf-archive/pull/235
+
+From: Yaakov Selkowitz <yselkowi@redhat.com>
+Date: Thu, 5 Aug 2021 11:12:47 -0400
+Subject: [PATCH 1/2] AX_PYTHON_DEVEL: fix for Python 3.10+
+
+--- a/m4/ax_python_devel.m4
++++ b/m4/ax_python_devel.m4
+@@ -208,7 +208,7 @@ EOD`
+ ac_python_version=$PYTHON_VERSION
+ else
+ ac_python_version=`$PYTHON -c "import sys; \
+- print (sys.version[[:3]])"`
++ print ("%d.%d" % sys.version_info[[:2]])"`
+ fi
+ fi
+
+
+From: Yaakov Selkowitz <yselkowi@redhat.com>
+Date: Thu, 5 Aug 2021 11:27:24 -0400
+Subject: [PATCH 2/2] AX_PYTHON: Add 3.10 and 3.11
+
+--- a/m4/ax_python.m4
++++ b/m4/ax_python.m4
+@@ -55,7 +55,7 @@
+ AC_DEFUN([AX_PYTHON],
+ [AC_MSG_CHECKING(for python build information)
+ AC_MSG_RESULT([])
+-for python in python3.9 python3.8 python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python3.0 python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python; do
++for python in python3.11 python3.10 python3.9 python3.8 python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python3.0 python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python; do
+ AC_CHECK_PROGS(PYTHON_BIN, [$python])
+ ax_python_bin=$PYTHON_BIN
+ if test x$ax_python_bin != x; then
+
diff --git a/sys-devel/autoconf-archive/files/autoconf-archive-2021.02.19-revert-ax_pthreads.patch b/sys-devel/autoconf-archive/files/autoconf-archive-2021.02.19-revert-ax_pthreads.patch
new file mode 100644
index 000000000000..3800fd292a6d
--- /dev/null
+++ b/sys-devel/autoconf-archive/files/autoconf-archive-2021.02.19-revert-ax_pthreads.patch
@@ -0,0 +1,70 @@
+This is an upstream revert which hasn't yet landed in a release.
+
+https://github.com/autoconf-archive/autoconf-archive/commit/59008cc7f85e1982eb298e1c424c2e6ad5942c4a
+https://github.com/autoconf-archive/autoconf-archive/pull/233
+https://github.com/autoconf-archive/autoconf-archive/commit/2567e0ce0f3a11b535c6b527386197fb49ff172b
+
+From: David Seifert <soap@gentoo.org>
+Date: Sat, 12 Jun 2021 22:29:03 +0200
+Subject: [PATCH] Revert "AX_PTHREAD: target > host"
+
+This reverts commit 2567e0ce0f3a11b535c6b527386197fb49ff172b.
+
+* `AC_CANONICAL_HOST` is the system on which the actual binary will run,
+ `AC_CANONICAL_TARGET` is the system for which code is generated. The
+ Autoconf manual even mentions that
+
+ --target=target-type
+ the type of system for which any compiler tools in the package produce code (**rarely needed**).
+--- a/m4/ax_pthread.m4
++++ b/m4/ax_pthread.m4
+@@ -87,11 +87,11 @@
+ # modified version of the Autoconf Macro, you may extend this special
+ # exception to the GPL to apply to your modified version as well.
+
+-#serial 30
++#serial 31
+
+ AU_ALIAS([ACX_PTHREAD], [AX_PTHREAD])
+ AC_DEFUN([AX_PTHREAD], [
+-AC_REQUIRE([AC_CANONICAL_TARGET])
++AC_REQUIRE([AC_CANONICAL_HOST])
+ AC_REQUIRE([AC_PROG_CC])
+ AC_REQUIRE([AC_PROG_SED])
+ AC_LANG_PUSH([C])
+@@ -158,7 +158,7 @@ ax_pthread_flags="pthreads none -Kthread -pthread -pthreads -mthreads pthread --
+ # --thread-safe: KAI C++
+ # pthread-config: use pthread-config program (for GNU Pth library)
+
+-case $target_os in
++case $host_os in
+
+ freebsd*)
+
+@@ -248,7 +248,7 @@ AS_IF([test "x$ax_pthread_clang" = "xyes"],
+ # definitions is, on some systems, a strong hint that pthreads support is
+ # correctly enabled
+
+-case $target_os in
++case $host_os in
+ darwin* | hpux* | linux* | osf* | solaris*)
+ ax_pthread_check_macro="_REENTRANT"
+ ;;
+@@ -450,7 +450,7 @@ if test "x$ax_pthread_ok" = "xyes"; then
+ AC_CACHE_CHECK([whether more special flags are required for pthreads],
+ [ax_cv_PTHREAD_SPECIAL_FLAGS],
+ [ax_cv_PTHREAD_SPECIAL_FLAGS=no
+- case $target_os in
++ case $host_os in
+ solaris*)
+ ax_cv_PTHREAD_SPECIAL_FLAGS="-D_POSIX_PTHREAD_SEMANTICS"
+ ;;
+@@ -480,7 +480,7 @@ if test "x$ax_pthread_ok" = "xyes"; then
+
+ # More AIX lossage: compile with *_r variant
+ if test "x$GCC" != "xyes"; then
+- case $target_os in
++ case $host_os in
+ aix*)
+ AS_CASE(["x/$CC"],
+ [x*/c89|x*/c89_128|x*/c99|x*/c99_128|x*/cc|x*/cc128|x*/xlc|x*/xlc_v6|x*/xlc128|x*/xlc128_v6],