summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-08 06:08:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-08 06:40:30 +0100
commita8c76a8a871f81e98a634a6ad1164de7798f5b52 (patch)
tree3cf45e71e8614e56e0db432173e6866fc1c4506e
parentdev-python/types-docutils: Bump to 0.20.0.20240308 (diff)
downloadgentoo-a8c76a8a871f81e98a634a6ad1164de7798f5b52.tar.gz
gentoo-a8c76a8a871f81e98a634a6ad1164de7798f5b52.tar.bz2
gentoo-a8c76a8a871f81e98a634a6ad1164de7798f5b52.zip
dev-python/pyglet: Bump to 2.0.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyglet/Manifest1
-rw-r--r--dev-python/pyglet/pyglet-2.0.13.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index 589500c0c9ff..971042da7167 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -1,2 +1,3 @@
DIST pyglet-2.0.10.gh.tar.gz 6414679 BLAKE2B 42d6724d67bfac5b80f22f8e995b601dde9e68c49e75b75d1deffb5816ac5a246f0fa5923d159ea27b71720a8301f49dade12ed5179dd4dd69af81085a3daf80 SHA512 cb92e920eebc7b09ccbf396f5a78e5e089df17fbc0cd40b862be9309d97999fcf76995de5602c75efa2294bb387c7489a075fa0bd8ef322ec3573ba6524a3aa4
DIST pyglet-2.0.12.gh.tar.gz 6415028 BLAKE2B ba1a697fe4e75b77da2b4ed7c1fa7b95269eb6f67502103fba158ec9fca636fe6027c6ece10c517ed4f7bbaae063b62d947cf9963bb4ed31b842eb7fddf793cb SHA512 e94009f002b295df891367f7e2b30f692606b0a35c1475e9ddf7f463ef5286691f8755f804b24c382fbea97ab2d58dfd51422110be9994a520dce6d365b90df0
+DIST pyglet-2.0.13.gh.tar.gz 6417145 BLAKE2B ad47d22e53b4da08e6a4b4f4351ba03ea7b236d8680edd793e83c3e0bc5c350d8b1514b08c0dfe24b392761f7df64cf5e0ef8972d9fed6f9d367b0c887567ea5 SHA512 3ffb67b4a5aac72f4c2cdbe4f2492e9e41e69749e544d281bfa8bc491dc56fd2bb4833ffff92b4f639070c162c9460baf01f25090d91b9bd371d8ce23a4309c3
diff --git a/dev-python/pyglet/pyglet-2.0.13.ebuild b/dev-python/pyglet/pyglet-2.0.13.ebuild
new file mode 100644
index 000000000000..28c5feeacc17
--- /dev/null
+++ b/dev-python/pyglet/pyglet-2.0.13.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Cross-platform windowing and multimedia library for Python"
+HOMEPAGE="
+ https://pyglet.org/
+ https://github.com/pyglet/pyglet/
+ https://pypi.org/project/pyglet/
+"
+SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples image +sound"
+
+RDEPEND="
+ virtual/glu
+ virtual/opengl
+ image? (
+ || (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2
+ )
+ )
+ sound? (
+ || (
+ media-libs/libpulse
+ media-libs/openal
+ )
+ )
+"
+# ffmpeg? ( media-libs/avbin-bin )
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/fontconfig
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ xdg_environment_reset
+
+ local EPYTEST_DESELECT=(
+ # lacking device/server permissions
+ tests/unit/media/test_listener.py::test_openal_listener
+ tests/unit/media/test_listener.py::test_pulse_listener
+ # fragile to system load
+ tests/unit/media/test_player.py::PlayerTestCase::test_pause_resume
+ tests/unit/test_clock_freq.py::test_elapsed_time_between_tick
+ )
+
+ # Specify path to avoid running interactive tests
+ # We could add in integration tests, but they're slow
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest tests/unit || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}