summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-10-21 21:59:27 -0500
committerMichał Górny <mgorny@gentoo.org>2018-11-28 11:03:57 +0100
commita8d045f19b6bf76f46c7120d3a2462c068c5bb72 (patch)
tree5219b6287358c34fbbd8028708ebf987e8bec533
parentuse.desc: Remove now-local-only flags (diff)
downloadgentoo-a8d045f19b6bf76f46c7120d3a2462c068c5bb72.tar.gz
gentoo-a8d045f19b6bf76f46c7120d3a2462c068c5bb72.tar.bz2
gentoo-a8d045f19b6bf76f46c7120d3a2462c068c5bb72.zip
dev-python/asynctest: Introducing new package
Introducing the latest available version of the package. Closes: https://bugs.gentoo.org/669272 Signed-off-by: Oleksandr Trotsenko <oleksandr.trotsenko@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10196 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/asynctest/Manifest1
-rw-r--r--dev-python/asynctest/asynctest-0.12.2.ebuild31
-rw-r--r--dev-python/asynctest/metadata.xml17
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/asynctest/Manifest b/dev-python/asynctest/Manifest
new file mode 100644
index 000000000000..703eb9f665d1
--- /dev/null
+++ b/dev-python/asynctest/Manifest
@@ -0,0 +1 @@
+DIST asynctest-0.12.2.tar.gz 49647 BLAKE2B 40bb5212409b2f0d9efce5c2559ffeea081c41b3f5158874d9a733f6f5dd2e6a2d7acf3eb495d91c1bc94e785dfd67c9bf5d1845e6fe40ad72aa36ea548b15b9 SHA512 e182fcf0c42d726dde810b9e2d50492b9e5ec9209b5419bd5faef28ee475ff04d6c8220bc165ec506eb9fc2dd38e45d7c3f8bc4ba1f0e279e44214e39862fe0f
diff --git a/dev-python/asynctest/asynctest-0.12.2.ebuild b/dev-python/asynctest/asynctest-0.12.2.ebuild
new file mode 100644
index 000000000000..9ce7712a4051
--- /dev/null
+++ b/dev-python/asynctest/asynctest-0.12.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Enhance the standard unittest with features for testing asyncio libraries"
+HOMEPAGE="https://github.com/Martiusweb/asynctest/ https://pypi.org/project/asynctest/"
+SRC_URI="https://github.com/Martiusweb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ default
+
+ sed -i "{s/test_events_watched_outside_test_are_ignored/_&/}" "test/test_selector.py" || die "Could not disable the failing test."
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest -v test || die "Testing failed"
+}
diff --git a/dev-python/asynctest/metadata.xml b/dev-python/asynctest/metadata.xml
new file mode 100644
index 000000000000..98bce3b47a08
--- /dev/null
+++ b/dev-python/asynctest/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>oleksandr.trotsenko@gmail.com</email>
+ <name>Oleksandr Trotsenko</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Martiusweb/asynctest</remote-id>
+ <doc>http://asynctest.readthedocs.org/en/latest/</doc>
+ <bugs-to>https://github.com/Martiusweb/asynctest/issues</bugs-to>
+ </upstream>
+</pkgmetadata>