summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-08-12 00:47:41 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-08-12 01:12:47 -0400
commita8d21b852ffc74494636b5f0c844f838dfa44dad (patch)
tree8d34cf829fea3dedb4954c04e45fb88ed9903d5d
parentmate-extra/mate-netbook: 1.12.x vbump, add gtk3, import from project repo (diff)
downloadgentoo-a8d21b852ffc74494636b5f0c844f838dfa44dad.tar.gz
gentoo-a8d21b852ffc74494636b5f0c844f838dfa44dad.tar.bz2
gentoo-a8d21b852ffc74494636b5f0c844f838dfa44dad.zip
mate-extra/mate-sensors-applet: 1.12.x vbump, add gtk3, from project repo
Package-Manager: portage-2.3.0
-rw-r--r--mate-extra/mate-sensors-applet/Manifest1
-rw-r--r--mate-extra/mate-sensors-applet/mate-sensors-applet-1.12.1.ebuild68
-rw-r--r--mate-extra/mate-sensors-applet/metadata.xml3
3 files changed, 72 insertions, 0 deletions
diff --git a/mate-extra/mate-sensors-applet/Manifest b/mate-extra/mate-sensors-applet/Manifest
index 55c38c2f24d9..d4da0be8c361 100644
--- a/mate-extra/mate-sensors-applet/Manifest
+++ b/mate-extra/mate-sensors-applet/Manifest
@@ -1 +1,2 @@
DIST mate-sensors-applet-1.10.4.tar.xz 377664 SHA256 dbcada771877ddbfd9c95945e6e776dcf6789ab2f74920c0be6daa283858d795 SHA512 3f6521d605f66cc0c836a605988415293af0b63ddf0ef3ace4712c136f8da1394b95ccc8ca2ead454a706d36711d067d38b7cfc1c0c4dce8952363770e373e0b WHIRLPOOL e4a0d0fef7578d258afc3125ece56ad02092339f3b4f0f074fccccd1909d2ec252ec6b1e7d0901d4277c50675b3ccb1fcd997bd0eb457d980c4dff9f4f30934f
+DIST mate-sensors-applet-1.12.1.tar.xz 369492 SHA256 94d1eae184d11431a922eabc3210bb192f3686ca75441718ac5ff9e05bd39933 SHA512 2e96708e4e27d545b0ad010dbd04139c5d340be1138236ba1197c2cf16486005905264e381f8dde75ea6c23c29bd1a0dd03afb5726340cad718d06914d4dd994 WHIRLPOOL 5534897f6532fb4d2b8016cd06b2f64bef7b97aca7156062327def9174a9a03e497e2120fb09f0acf36b663256c809db10a30d1edad922a8590e23e32c2e59e6
diff --git a/mate-extra/mate-sensors-applet/mate-sensors-applet-1.12.1.ebuild b/mate-extra/mate-sensors-applet/mate-sensors-applet-1.12.1.ebuild
new file mode 100644
index 000000000000..8ba4ae9e360e
--- /dev/null
+++ b/mate-extra/mate-sensors-applet/mate-sensors-applet-1.12.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="MATE panel applet to display readings from hardware sensors"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="+dbus gtk3 hddtemp libnotify lm_sensors video_cards_fglrx video_cards_nvidia"
+
+RDEPEND="app-text/rarian:0
+ >=dev-libs/glib-2.36:2
+ >=mate-base/mate-panel-1.6[gtk3(-)=]
+ >=x11-libs/cairo-1.0.4:0
+ x11-libs/gdk-pixbuf:2
+ virtual/libintl:0
+ !gtk3? ( >=x11-libs/gtk+-2.24:2 )
+ gtk3? ( >=x11-libs/gtk+-3.0:3 )
+ hddtemp? (
+ dbus? (
+ >=dev-libs/dbus-glib-0.80:0
+ >=dev-libs/libatasmart-0.16:0 )
+ !dbus? ( >=app-admin/hddtemp-0.3_beta13:0 ) )
+ libnotify? ( >=x11-libs/libnotify-0.7:0 )
+ lm_sensors? ( sys-apps/lm_sensors:0 )
+ video_cards_fglrx? ( x11-drivers/ati-drivers:* )
+ video_cards_nvidia? ( || (
+ >=x11-drivers/nvidia-drivers-100.14.09:0[static-libs,tools]
+ media-video/nvidia-settings:0
+ ) )"
+
+DEPEND="${RDEPEND}
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+PDEPEND="hddtemp? ( dbus? ( sys-fs/udisks:0 ) )"
+
+src_configure() {
+ local udisks
+
+ if use hddtemp && use dbus; then
+ udisks="--enable-udisks"
+ else
+ udisks="--disable-udisks"
+ fi
+
+ mate_src_configure \
+ --disable-static \
+ --with-gtk=$(usex gtk3 3.0 2.0) \
+ $(use_enable libnotify) \
+ $(use_with lm_sensors libsensors) \
+ $(use_with video_cards_fglrx aticonfig) \
+ $(use_with video_cards_nvidia nvidia) \
+ ${udisks}
+}
diff --git a/mate-extra/mate-sensors-applet/metadata.xml b/mate-extra/mate-sensors-applet/metadata.xml
index cb39f022029e..e385b4bd23a2 100644
--- a/mate-extra/mate-sensors-applet/metadata.xml
+++ b/mate-extra/mate-sensors-applet/metadata.xml
@@ -5,6 +5,9 @@
<email>mate@gentoo.org</email>
<name>Gentoo MATE Desktop</name>
</maintainer>
+ <use>
+ <flag name="gtk3">Build with GTK+3 instead of GTK+2</flag>
+ </use>
<upstream>
<remote-id type="github">mate-desktop/mate-sensors-applet</remote-id>
</upstream>